This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 806794 - [abrt] epiphany-3.3.92-1.fc17: __nscd_get_mapping: Process /usr/bin/epiphany was killed by signal 11 (SIGSEGV)
[abrt] epiphany-3.3.92-1.fc17: __nscd_get_mapping: Process /usr/bin/epiphany ...
Status: CLOSED DUPLICATE of bug 806070
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
abrt_hash:c8dfc04caf1cb2fb451464a85f5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 05:14 EDT by Ryan Farmer
Modified: 2012-03-27 11:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 11:25:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (12.46 KB, text/plain)
2012-03-26 05:14 EDT, Ryan Farmer
no flags Details
File: build_ids (5.04 KB, text/plain)
2012-03-26 05:14 EDT, Ryan Farmer
no flags Details
File: xsession_errors (120.63 KB, text/plain)
2012-03-26 05:14 EDT, Ryan Farmer
no flags Details
File: backtrace (66.19 KB, text/plain)
2012-03-26 05:14 EDT, Ryan Farmer
no flags Details
File: maps (61.56 KB, text/plain)
2012-03-26 05:14 EDT, Ryan Farmer
no flags Details

  None (edit)
Description Ryan Farmer 2012-03-26 05:14:17 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        epiphany
comment:        If you use the new "App Menu" to close Epiphany and then restart it later, it will think it has crashed and offer to restore your last session, if you tell it to, it will crash. This is what I'm reporting. 
crash_function: __nscd_get_mapping
executable:     /usr/bin/epiphany
kernel:         3.3.0-1.fc17.x86_64
pid:            30793
pwd:            /home/ryan
reason:         Process /usr/bin/epiphany was killed by signal 11 (SIGSEGV)
time:           Mon 26 Mar 2012 05:11:16 AM EDT
uid:            1000
username:       ryan

backtrace:      Text file, 67779 bytes
build_ids:      Text file, 5166 bytes
dso_list:       Text file, 12758 bytes
maps:           Text file, 63033 bytes
xsession_errors: Text file, 123521 bytes

environ:
:XDG_VTNR=2
:XDG_SESSION_ID=20
:HOSTNAME=ryan-desktop
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:GNOME_KEYRING_CONTROL=/home/ryan/.cache/keyring-ztL8nn
:IMSETTINGS_MODULE=none
:USER=ryan
:USERNAME=ryan
:MAIL=/var/spool/mail/ryan
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/ryan/.local/bin:/home/ryan/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/ryan
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=25596
:LANG=en_US.UTF-8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/ryan
:SHLVL=1
:LOGNAME=ryan
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-LWb4isHjc2,guid=af32bfad2718db13d1ad3b4000003624
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=2
:XDG_RUNTIME_DIR=/run/user/ryan
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-ryan-imuVM4/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/25605,unix/unix:/tmp/.ICE-unix/25605
:GPG_AGENT_INFO=/home/ryan/.cache/keyring-ztL8nn/gpg:0:1
:SSH_AUTH_SOCK=/home/ryan/.cache/keyring-ztL8nn/ssh
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:G_MESSAGES_DEBUG=all
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/epiphany.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=30793
:DESKTOP_STARTUP_ID=gnome-shell-28092-ryan-desktop-epiphany-14_TIME19046602

smolt_data:
:
:
:General
:=================================
:UUID: fda5a813-2bc6-4847-b512-ebecfeff89ed
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5986.68
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Phenom(tm) II X4 945 Processor
:CPU Stepping: 2
:CPU Family: 16
:CPU Model Num: 4
:Number of CPUs: 4
:CPU Speed: 3000
:System Memory: 7987
:System Swap: 16383
:Vendor: MICRO-STAR INTERNATIONAL CO.,LTD
:System: MS-7501 1.0
:Form factor: Desktop
:Kernel: 3.3.0-1.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4098:17296:5218:29953) pci, ahci, STORAGE, SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode]
:(4098:43616:4163:43616) pci, snd_hda_intel, MULTIMEDIA, Redwood HDMI Audio [Radeon HD 5600 Series]
:(4130:38400:4130:38400) pci, None, HOST/PCI, RS780 Host Bridge
:(4130:4612:0:0) pci, None, HOST/PCI, Family 10h Processor Link Control
:(4130:4609:0:0) pci, None, HOST/PCI, Family 10h Processor Address Map
:(4130:4608:0:0) pci, None, HOST/PCI, Family 10h Processor HyperTransport Configuration
:(4130:4611:0:0) pci, None, HOST/PCI, Family 10h Processor Miscellaneous Control
:(4130:4610:0:0) pci, None, HOST/PCI, Family 10h Processor DRAM Controller
:(4332:33128:5218:20508) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(4130:38403:4130:38400) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (ext gfx port 0)
:(4098:17308:5218:29953) pci, pata_atiixp, STORAGE, SB7x0/SB8x0/SB9x0 IDE Controller
:(4098:17285:5218:29953) pci, piix4_smbus, SERIAL, SBx00 SMBus Controller
:(4098:17309:5218:29953) pci, None, PCI/ISA, SB7x0/SB8x0/SB9x0 LPC host controller
:(4098:17283:5218:29953) pci, snd_hda_intel, MULTIMEDIA, SBx00 Azalia (Intel HDA)
:(4098:17305:5218:29953) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
:(4098:17284:0:0) pci, None, PCI/PCI, SBx00 PCI to PCI Bridge
:(4098:17302:5218:29953) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:26840:4163:854) pci, radeon, VIDEO, Redwood [Radeon HD 5670]
:(4098:17303:5218:29953) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4098:17304:5218:29953) pci, ohci_hcd, USB, SB7x0 USB OHCI1 Controller
:(4098:17302:5218:29953) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17304:5218:29953) pci, ohci_hcd, USB, SB7x0 USB OHCI1 Controller
:(4098:17303:5218:29953) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4130:38405:4130:38400) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (PCIE port 1)
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 239770915 232262897 229863341 60006400 59823138 59823138
:/dev/sdg WITHHELD vfat 32768 32768 241540 175377 175377 0 0 0
:/dev/sdh1 WITHHELD vfat 4096 4096 3914240 1414998 1414998 0 0 0
:/dev/sdb1 WITHHELD xfs 4096 4096 1951337 712376 712376 7815552 7815494 7815494
:

var_log_messages:
:Mar 25 13:41:04 ryan-desktop yum[11594]: Installed: 1:epiphany-3.3.92-1.fc17.x86_64
:Mar 25 13:41:05 ryan-desktop yum[11594]: Installed: epiphany-extensions-3.3.90-1.fc17.x86_64
:Mar 26 02:50:55 ryan-desktop kernel: [10629.969592] epiphany[20973] trap divide error ip:36c8d2d7d5 sp:7fffc43733c0 error:0 in libgtk-3.so.0.320.0[36c8c00000+4b9000]
:Mar 26 02:50:57 ryan-desktop abrt[21014]: Saved core dump of pid 20973 (/usr/bin/epiphany) to /var/spool/abrt/ccpp-2012-03-26-02:50:55-20973 (1207926784 bytes)
:Mar 26 02:51:50 ryan-desktop kernel: [10685.455502] epiphany[21067] trap divide error ip:36c8d2d7d5 sp:7fffcb2c6090 error:0 in libgtk-3.so.0.320.0[36c8c00000+4b9000]
:Mar 26 02:51:53 ryan-desktop abrt[21084]: Saved core dump of pid 21067 (/usr/bin/epiphany) to /var/spool/abrt/ccpp-2012-03-26-02:51:50-21067 (1199259648 bytes)
:Mar 26 02:53:28 ryan-desktop kernel: [10783.060999] epiphany[21274] trap divide error ip:36c8d2d7d5 sp:7fff660563b0 error:0 in libgtk-3.so.0.320.0[36c8c00000+4b9000]
:Mar 26 02:53:30 ryan-desktop abrt[21287]: Saved core dump of pid 21274 (/usr/bin/epiphany) to /var/spool/abrt/ccpp-2012-03-26-02:53:28-21274 (1157251072 bytes)
:Mar 26 02:55:43 ryan-desktop kernel: [10918.791261] epiphany[21338] trap divide error ip:36c8d2d7d5 sp:7fffb523ecc0 error:0 in libgtk-3.so.0.320.0[36c8c00000+4b9000]
:Mar 26 02:55:47 ryan-desktop abrt[21419]: Saved core dump of pid 21338 (/usr/bin/epiphany) to /var/spool/abrt/ccpp-2012-03-26-02:55:43-21338 (1219137536 bytes)
:Mar 26 03:43:36 ryan-desktop kernel: [13791.727087] epiphany[25406] trap divide error ip:36c8d2d7d5 sp:7fff49a4d2c0 error:0 in libgtk-3.so.0.320.0[36c8c00000+4b9000]
:Mar 26 03:43:39 ryan-desktop abrt[25439]: Saved core dump of pid 25406 (/usr/bin/epiphany) to /var/spool/abrt/ccpp-2012-03-26-03:43:36-25406 (1222660096 bytes)
:Mar 26 03:45:45 ryan-desktop kernel: [13920.743773] epiphany[26045] trap divide error ip:36c8d2d7d5 sp:7fffe72dfb00 error:0 in libgtk-3.so.0.320.0[36c8c00000+4b9000]
:Mar 26 03:45:48 ryan-desktop abrt[26058]: Saved core dump of pid 26045 (/usr/bin/epiphany) to /var/spool/abrt/ccpp-2012-03-26-03:45:45-26045 (1157341184 bytes)
:Mar 26 04:36:59 ryan-desktop kernel: [16994.373348] epiphany[29029] trap divide error ip:36c8d2d7d5 sp:7fff9cd80c30 error:0 in libgtk-3.so.0.320.0[36c8c00000+4b9000]
:Mar 26 04:37:01 ryan-desktop abrt[29187]: Saved core dump of pid 29029 (/usr/bin/epiphany) to /var/spool/abrt/ccpp-2012-03-26-04:36:59-29029 (1175445504 bytes)
:Mar 26 04:59:55 ryan-desktop kernel: [18370.587690] epiphany[29239]: segfault at 7f3b0572bc10 ip 00007f3b0572bc10 sp 00007fff93466fd8 error 14 in libtabstatesextension.so[7f3b0592f000+2000]
:Mar 26 05:00:00 ryan-desktop abrt[30337]: Saved core dump of pid 29239 (/usr/bin/epiphany) to /var/spool/abrt/ccpp-2012-03-26-04:59:55-29239 (1288007680 bytes)
:Mar 26 05:11:18 ryan-desktop abrt[30808]: Saved core dump of pid 30793 (/usr/bin/epiphany) to /var/spool/abrt/ccpp-2012-03-26-05:11:16-30793 (1178034176 bytes)
Comment 1 Ryan Farmer 2012-03-26 05:14:24 EDT
Created attachment 572713 [details]
File: dso_list
Comment 2 Ryan Farmer 2012-03-26 05:14:32 EDT
Created attachment 572714 [details]
File: build_ids
Comment 3 Ryan Farmer 2012-03-26 05:14:35 EDT
Created attachment 572715 [details]
File: xsession_errors
Comment 4 Ryan Farmer 2012-03-26 05:14:37 EDT
Created attachment 572716 [details]
File: backtrace
Comment 5 Ryan Farmer 2012-03-26 05:14:40 EDT
Created attachment 572717 [details]
File: maps
Comment 6 Jeff Law 2012-03-27 11:12:25 EDT
Ryan,
Is this consistently reproducible?  I've got a theory about how this happens as well as a testbuild which avoids the situation which might be causing this problem.

If it's reproducible and you can test the RPMS, let me know and I'll pass along a pointer.
Comment 7 Jeff Law 2012-03-27 11:25:30 EDT

*** This bug has been marked as a duplicate of bug 806070 ***

Note You need to log in before you can comment on or make changes to this bug.