Bug 806070 - Ktorrent crashes during startup.
Ktorrent crashes during startup.
Status: CLOSED DUPLICATE of bug 806029
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jeff Law
Fedora Extras Quality Assurance
:
: 801767 803515 804691 806671 806794 (view as bug list)
Depends On:
Blocks: 806029
  Show dependency treegraph
 
Reported: 2012-03-22 16:14 EDT by Leonid Zhaldybin
Modified: 2016-11-24 07:33 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 806029
Environment:
Last Closed: 2012-03-29 12:27:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 296560 None None None Never
Launchpad 929219 None None None Never

  None (edit)
Description Leonid Zhaldybin 2012-03-22 16:14:42 EDT
+++ This bug was initially created as a clone of Bug #806029 +++

Created attachment 572048 [details]
Ktorrent backtrace.

Description of problem:
After I added a few torrents to Ktorrent, starting it up became quite a problem. It crashes every time I try to start it and I have to hit "restart application" button in the  KDE Crash Handler a few times to finally get it running.

Version-Release number of selected component (if applicable):
ktorrent-4.2.0-1.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. Add a few torrents to Ktorrent.
2. Close it and try to start it up again.
3. Ktorrent will crash.
  
Actual results:
Ktorrent krushes on startup.

Expected results:
Ktorrent starts up successfully.

Additional info:

--- Additional comment from lzhaldyb@redhat.com on 2012-03-22 19:45:35 CET ---

I've discovered that if nscd is running, then ktorrent starts up just fine. So, to work around this problem, do the following:

yum install nscd
service nscd start

--- Additional comment from alekcejk@googlemail.com on 2012-03-22 19:54:28 CET ---

Can't reproduce this so, lease report this bug to upstream:
https://bugs.kde.org/enter_bug.cgi?product=ktorrent

--- Additional comment from lzhaldyb@redhat.com on 2012-03-22 21:13:39 CET ---

(In reply to comment #2)
> Can't reproduce this so, lease report this bug to upstream:
> https://bugs.kde.org/enter_bug.cgi?product=ktorrent

I've already reported this to upstream (see https://bugs.kde.org/show_bug.cgi?id=296560). Turns out, this is probably a bug in glibc. I'm creating a clone.
Comment 1 Leonid Zhaldybin 2012-03-22 16:17:09 EDT
Version of the glibc I have installed:
glibc-2.15-28.fc17.x86_64
Comment 2 Jeff Law 2012-03-27 11:20:09 EDT
*** Bug 801767 has been marked as a duplicate of this bug. ***
Comment 3 Jeff Law 2012-03-27 11:23:26 EDT
*** Bug 803515 has been marked as a duplicate of this bug. ***
Comment 4 Jeff Law 2012-03-27 11:24:22 EDT
*** Bug 804691 has been marked as a duplicate of this bug. ***
Comment 5 Jeff Law 2012-03-27 11:24:57 EDT
*** Bug 806671 has been marked as a duplicate of this bug. ***
Comment 6 Jeff Law 2012-03-27 11:25:30 EDT
*** Bug 806794 has been marked as a duplicate of this bug. ***
Comment 7 Jeff Law 2012-03-29 12:27:34 EDT

*** This bug has been marked as a duplicate of bug 806029 ***

Note You need to log in before you can comment on or make changes to this bug.