Bug 806867 - dracut Warning: /dev/root does not exist.
dracut Warning: /dev/root does not exist.
Status: CLOSED DUPLICATE of bug 806966
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-26 07:39 EDT by Hongqing Yang
Modified: 2012-08-19 02:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 17:35:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hongqing Yang 2012-03-26 07:39:02 EDT
Description of problem:

preupgrade from f15 and f16 to f17, after copy all the packages, reboot the system to boot from F17, always get the following erro:
dracut Warning: /dev/root does not exist.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. preupgrade from f15 or f16 to f17
2. reboot
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Williamson 2012-03-26 11:19:05 EDT
Proposing as Beta blocker, preupgrade is required to work at Beta.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Petr Schindler 2012-03-26 12:39:34 EDT
I think this could be caused by the same option as in bug 806966

Does preupgrade use inst.repo=hd: option??
Comment 3 Adam Williamson 2012-03-26 13:36:00 EDT
Discussed at 2012-03-26 QA meeting acting as a blocker review meeting. Accepted as a blocker per criterion "The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria".



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Richard Hughes 2012-03-26 13:54:43 EDT
(In reply to comment #2)
> Does preupgrade use inst.repo=hd: option??

Yes, IIRC.
Comment 5 Adam Williamson 2012-03-26 17:32:33 EDT
Here's the preupgrade grub2.cfg entry:

linux /upgrade/vmlinuz preupgrade repo=hd::/var/cache/yum/preupgrade ks=hd:UUID=blahblah:/upgrade/ks.cfg stage2=hd:UUID=blahblah:/upgrade/squashfs.img

so yeah, it uses repo=hd: . I guess we should make this a dupe of 806966.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Adam Williamson 2012-03-26 17:35:54 EDT

*** This bug has been marked as a duplicate of bug 806966 ***

Note You need to log in before you can comment on or make changes to this bug.