Bug 806966 - installation with inst.repo=hd parameter doesn't boot (breaks preupgrade, livecd-iso-to-disk with dvd)
installation with inst.repo=hd parameter doesn't boot (breaks preupgrade, liv...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
: 806867 806962 (view as bug list)
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-26 12:11 EDT by Petr Schindler
Modified: 2013-01-06 18:10 EST (History)
14 users (show)

See Also:
Fixed In Version: anaconda-17.16-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-29 08:47:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
failed boot screenshot (9.01 KB, image/png)
2012-03-26 12:11 EDT, Petr Schindler
no flags Details
Screenshot showing /dev/root not existing. (166.16 KB, image/png)
2012-12-27 20:06 EST, Brian
no flags Details

  None (edit)
Description Petr Schindler 2012-03-26 12:11:37 EDT
Created attachment 572792 [details]
failed boot screenshot

Description of problem:
I encountered this bug while I was going through test case: https://fedoraproject.org/wiki/QA:Testcase_install_repository_Hard_drive_variation

When I try to run installer with inst.repo=hd:<device>:<path> parameter it fails to boot and it ends in debug shell.

I have two virtIO disks. One for new system and on the second one I have installation DVD (Beta.RC1). I boot the installer with inst.repo=hd:/dev/vdb1:/ parameter added. You can find screenshot with result in the attachment.

I don't know what causes this problem, but without inst.repo parameter it works fine.

Version-Release number of selected component (if applicable):
Beta.RC1 DVD.iso

How reproducible:
always (on my 64bit virtual machine)

Steps to Reproduce:
https://fedoraproject.org/wiki/QA:Testcase_install_repository_Hard_drive_variation
  
Actual results:
Installer doesn't boot


Expected results:
Installer boots up and use repository from the given iso file.

Additional info:
I propose this as final blocker per criterion: "The installer must be able to use all supported local and remote package source options"
Comment 1 Adam Williamson 2012-03-26 17:35:55 EDT
*** Bug 806867 has been marked as a duplicate of this bug. ***
Comment 2 Adam Williamson 2012-03-26 17:37:16 EDT
This bug turns out to be the cause of 806867 - preupgrade failure with Beta RC1. That bug was accepted as a beta blocker. So, marked that as a dupe of this, and transferring the Beta blocker status to this bug.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Adam Williamson 2012-03-26 18:12:18 EDT
*** Bug 806962 has been marked as a duplicate of this bug. ***
Comment 4 Adam Williamson 2012-03-26 18:12:43 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2012-03-26 18:13:06 EDT
This bug also causes DVD ISO written to USB with livecd-iso-to-disk to fail to boot (806962).
Comment 6 Will Woods 2012-03-27 11:37:09 EDT
Reproduced the problem using a setup like the one in comment #1 (thanks for the info on your test setup - that's always helpful!).

This patch fixes it, in my testing:
  https://www.redhat.com/archives/anaconda-devel-list/2012-March/msg00307.html
Comment 7 Fedora Update System 2012-03-27 20:09:49 EDT
anaconda-17.15-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.15-1.fc17
Comment 8 Fedora Update System 2012-03-28 01:52:35 EDT
Package anaconda-17.15-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.15-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4745/anaconda-17.15-1.fc17
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-03-28 19:22:50 EDT
anaconda-17.16-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.16-1.fc17
Comment 10 Fedora Update System 2012-03-29 00:13:19 EDT
anaconda-17.16-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Tim Flink 2012-03-29 00:59:16 EDT
Successfully did a bare metal install with the F17 beta RC2 x86_64 DVD burned
to usb using livecd-iso-to-disk.

I would leave this as ON_QA but it's already been closed. It would be nice to have more testing on the remaining use cases that were affected.
Comment 12 Hongqing Yang 2012-03-29 05:21:14 EDT
reproduced with preupgrade from F15 to F17
Comment 13 Petr Schindler 2012-03-29 07:58:06 EDT
inst.repo=hd:... works fine with version 17.16. But preupgrade-1.1.10-1 still downloads and uses the old version of anaconda (17.14) so preupgrade still doesn't work
Comment 14 Adam Williamson 2012-03-29 08:47:45 EDT
Right. Hongqing, please remember that preupgrade is always behind the released images as it has to wait for anaconda to be pushed stable and then for a new automatic installer compose to happen.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Hongqing Yang 2012-04-05 02:09:29 EDT
(In reply to comment #13)
> inst.repo=hd:... works fine with version 17.16. But preupgrade-1.1.10-1 still
> downloads and uses the old version of anaconda (17.14) so preupgrade still
> doesn't work

This also happens with F17 Beta RC3
Comment 16 ZhaoYanbai 2012-05-29 06:13:51 EDT
The Bug also happens with F17.
Comment 17 Adam Williamson 2012-05-29 11:39:55 EDT
No, it doesn't. We have tested extensively. Please provide more details of your problem either as a new bug report or a request for help on a mailing list, IRC or forum.
Comment 18 Brian 2012-12-27 19:48:05 EST
I am currently getting this error trying to preupgrade from F15 to F17.  Preupgrade also seems to be ignoring my network configuration.  I have added biosdevname=0 to the grub entry for preupgrade, so it's stopped renaming eth0 to em1, but it still tries dhcp, despite me having a configuration for eth0.  I also tried creating an entry for ifconfig-em1 with biosdevname enabled, but it seemed to be ignored.

Here is the grub entry:

title Upgrade to Fedora 17 (Beefy Miracle)
        kernel /upgrade/vmlinuz preupgrade repo=hd::/var/cache/yum/preupgrade ks=hd:UUID=cf0fc1b5-265e-4b1e-a936-5552ccf59617:/upgrade/ks.cfg stage2=http://mirror.uoregon.edu/fedora/linux/releases/17/Fedora/x86_64/os/LiveOS/squashfs.img biosdevname=0
        initrd /upgrade/initrd.img
Comment 19 Brian 2012-12-27 20:06:08 EST
Created attachment 669729 [details]
Screenshot showing /dev/root not existing.

This may be more appropriately linked to https://bugzilla.redhat.com/show_bug.cgi?id=806867 but that was closed as a dupe of this.  My issue has nothing to do with live cd, I'm trying to do preupgrade as a network install.  Attached screenshot showing /dev/root not existing.

Note You need to log in before you can comment on or make changes to this bug.