Bug 806883 - Attribute unique in XML metadata
Attribute unique in XML metadata
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fence-agents (Show other bugs)
6.4
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Marek Grac
Cluster QE
: EasyFix
Depends On:
Blocks: 822507
  Show dependency treegraph
 
Reported: 2012-03-26 08:32 EDT by Marek Grac
Modified: 2012-06-20 10:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: fence-agents-3.1.5-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 822507 (view as bug list)
Environment:
Last Closed: 2012-06-20 10:40:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0943 normal SHIPPED_LIVE fence-agents bug fix and enhancement update 2012-06-19 17:00:16 EDT

  None (edit)
Description Marek Grac 2012-03-26 08:32:36 EDT
Attribute unique in XML metadata (-o metadata) is set to TRUE (1) by default in all of the cases. "Unique" should be used only in situation where same value cannot be used across several agents. Fence agents do not have such kind of attributes so default value should be FALSE (0).
Comment 3 Nate Straz 2012-05-17 10:10:08 EDT
I looked through the metadata generated by all fence agents and found the following agents still produce unique parameters

fence_brocade
fence_drac
fence_egenera
fence_kdump
fence_scsi

Should these fence agents be fixed too?
Comment 6 errata-xmlrpc 2012-06-20 10:40:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0943.html

Note You need to log in before you can comment on or make changes to this bug.