Bug 822507 - Attribute unique in XML metadata
Attribute unique in XML metadata
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fence-agents (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: 6.4
Assigned To: Marek Grac
Cluster QE
: EasyFix
Depends On: 806883
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 10:44 EDT by Nate Straz
Modified: 2013-09-19 15:56 EDT (History)
7 users (show)

See Also:
Fixed In Version: fence-agents-3.1.5-20.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 806883
Environment:
Last Closed: 2013-02-21 02:41:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nate Straz 2012-05-17 10:44:43 EDT
+++ This bug was initially created as a clone of Bug #806883 +++

Cloned to fix agents missed in 6.3.

Attribute unique in XML metadata (-o metadata) is set to TRUE (1) by default in all of the cases. "Unique" should be used only in situation where same value cannot be used across several agents. Fence agents do not have such kind of attributes so default value should be FALSE (0).

--- Additional comment from mgrac@redhat.com on 2012-03-26 08:40:06 EDT ---

Fixed in upstream:

http://git.fedorahosted.org/git/?p=fence-agents.git;a=commit;h=aefb817f08bfa8f2f1b1c1270ad4d697649fa40c

--- Additional comment from nstraz@redhat.com on 2012-05-17 10:10:08 EDT ---

I looked through the metadata generated by all fence agents and found the following agents still produce unique parameters

fence_brocade
fence_drac
fence_egenera
fence_kdump
fence_scsi

Should these fence agents be fixed too?
Comment 4 Marek Grac 2012-10-25 04:55:48 EDT
Unit test:

./fence_? -o metadata | grep unique 

<parameter name="action" unique="0" required="1">
<parameter name="ipaddr" unique="0" required="1">
..

there should be no answer for 

./fence_? -o metadata | grep 'unique="1"'
Comment 7 errata-xmlrpc 2013-02-21 02:41:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0286.html

Note You need to log in before you can comment on or make changes to this bug.