Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 806895 - errata.clone expects cloned channel
Summary: errata.clone expects cloned channel
Keywords:
Status: CLOSED DUPLICATE of bug 812053
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard: Regression
Depends On:
Blocks: sat541-triage
TreeView+ depends on / blocked
 
Reported: 2012-03-26 12:57 UTC by Tomas Lestach
Modified: 2012-04-16 15:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-16 15:10:12 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tomas Lestach 2012-03-26 12:57:21 UTC
Description of problem:
errata.clone fails with "Cloned channel expected" exception.

Version-Release number of selected component (if applicable):
sat541

How reproducible:
always

Steps to Reproduce:
1. call errata.clone and make sure you specify a channel that isn't a clone
  
Actual results:
xmlrpclib.Fault: <Fault -211: 'redstone.xmlrpc.XmlRpcFault: Cloned channel expected: rhn-tools-rhel-x86_64-server-5'>

Expected results:
Erratum successfully cloned into the specified channel.

Additional info:
Caused by commit: f72e4d7e0549723da9c648a08d539d297219f153
(errata.clone and errata.cloneAsOriginal share the same code now)

Comment 1 Tomas Lestach 2012-04-16 15:10:12 UTC
This memory ...

*** This bug has been marked as a duplicate of bug 812053 ***


Note You need to log in before you can comment on or make changes to this bug.