Bug 812053 - errata.clone fails with InvalidChannelException - Cloned channel expected
errata.clone fails with InvalidChannelException - Cloned channel expected
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
541
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Pavel Studeník
:
: 806895 (view as bug list)
Depends On:
Blocks: sat550-api sat550-lowbug 857812
  Show dependency treegraph
 
Reported: 2012-04-12 11:50 EDT by Tomas Lestach
Modified: 2013-01-16 09:53 EST (History)
5 users (show)

See Also:
Fixed In Version: spacewalk-java-1.7.54-22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 857812 (view as bug list)
Environment:
Last Closed: 2012-09-21 05:18:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Lestach 2012-04-12 11:50:16 EDT
Description of problem:
When running errata.clone API and the target channel isn't a cloned channel, the API fails.

Version-Release number of selected component (if applicable):
sat541

How reproducible:
always

Steps to Reproduce:
1. create a custom channel
2. run errata.clone api and specofy target channel as the one currently created
  
Actual results:
API fails with: InvalidChannelException - Cloned channel expected

Expected results:
no exception and no need for cloned channel
Comment 1 Jan Pazdziora 2012-04-13 08:26:42 EDT
The commit for this bugzilla seems to have gone to Spacewalk master, 44ae2fc89e9ac27f5548d25b4d848ab3b9a31b4e.

I fixed the checkstyle problem in ab89258e53a12bf0f455cf870c34af77866a6b45.
Comment 2 Tomas Lestach 2012-04-13 10:31:21 EDT
negate the condition ...

spacewalk.git: c99e53de2509e76e2ec04c484ae318c4a8f81480
Comment 3 Tomas Lestach 2012-04-16 11:10:12 EDT
*** Bug 806895 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Lestach 2012-04-16 11:14:59 EDT
one more commit ...
 return cloned errata list (not an empty array)
 rename confusing inheritAllPackages -> inheritPackages

spacewalk.git: 9670d422b2f707f51c4a22e21a16a070d3b867b3
Comment 8 Clifford Perry 2012-09-21 05:18:21 EDT
This issue is resolved with the release of RHN Satellite 5.5. 

As of September 20th 2012, RHN Satellite 5.5 has been generally available. 

Release Notes and other 5.5 documentation can be found here:

 https://access.redhat.com/knowledge/docs/Red_Hat_Network_Satellite/

The associated Errata for the 5.5 release are:

5.5 Satellite GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1296.html

5.5 Upgrade Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1298.html

5.5 RHN Proxy GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1297.html

5.5 RHN Tools GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1299.html

Regards,
Clifford
- Engineering Manager, Satellite

Note You need to log in before you can comment on or make changes to this bug.