Bug 806989 - consumed_gears not being updated when apps/domains deleted
consumed_gears not being updated when apps/domains deleted
Status: CLOSED DUPLICATE of bug 806817
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
1.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Rajat Chopra
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 13:24 EDT by Clayton Coleman
Modified: 2012-03-27 16:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 16:34:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Coleman 2012-03-26 13:24:14 EDT
Unit tests for site are reusing the domain and invoking either app deletion or domain deletion at the end of the test.  However, consumed gears is not being updated, so a user in the DB looks like:

{ "_id" : "app_test1@test1.com", "apps" : [ ], "consumed_gears" : 5, "domains" : [ ], "login" : "app_test1@test1.com", "max_gears" : 5, "ssh_keys" : { }, "uuid" : "7945a098eecc4fd0a3308e57f8eb33a2", "vip" : false }

Suspect the count isn't being updated.
Comment 1 Rajat Chopra 2012-03-27 16:34:51 EDT
Count was wrongly updated in the beginning, as a result even if the app count was 0, the gear count could be 1.

*** This bug has been marked as a duplicate of bug 806817 ***

Note You need to log in before you can comment on or make changes to this bug.