Bug 807101 - parted does not offer resize option
parted does not offer resize option
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
17
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
: Reopened
: 833023 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 21:56 EDT by Pete Travis
Modified: 2015-11-05 00:04 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 14:15:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
me: fedora_requires_release_note+


Attachments (Terms of Use)

  None (edit)
Description Pete Travis 2012-03-26 21:56:15 EDT
Description of problem:
parted does not present the option to or allow resizing of partitions, an expected feature.

Version-Release number of selected component (if applicable):
3.0-8

How reproducible:
use parted via interactive prompt, or specify arguments at runtime. 'resize' is not an accepted option.
Comment 1 Brian Lane 2012-03-27 09:49:30 EDT
parted no longer handles resizing of filesystems. That was removed in parted 2.4

You should use the filesystem-specific tools to handle resizes.
Comment 2 Jan ONDREJ 2012-04-02 02:08:26 EDT
The problem is, that man page still displays these commands removed in parted-2.4. Please update man page and remove them.

info parted:

  Note that after version 2.4, the following commands were removed:
check, cp, mkfs, mkpartfs, move, resize.

man parted:

              check partition
                     Do a simple check on partition.

              cp [source-device] source dest
                     Copy the source partition's filesystem  on  source-device
                     (or  the current device if no other device was specified)
                     to the dest partition on the current device.
              mkfs partition fs-type
                     Make a filesystem fs-type on partition.  fs-type  can  be
                     one  of "fat16", "fat32", "ext2", "linux-swap", or "reis‐
                     erfs".
              mkpartfs part-type fs-type start end
                     Make a part-type partition with filesystem fs-type begin‐
                     ning  at  start  and  ending  at  end  (by   default   in
                     megabytes).   Using this command is discouraged.  Instead
                     use mkpart to create an empty  partition,  and  then  use
                     external tools like mke2fs(8) to create the filesystem.
              move partition start end
                     Move  partition  so  that  it begins at start and ends at
                     end.  Note: move never changes the minor number.
              resize partition start end
                     Resize  the  filesystem on partition so that it begins at
                     start and ends at end (by default in megabytes).
Comment 3 Benjamin Herrenschmidt 2012-05-10 23:01:58 EDT
Also how am I supposed to resize the partition itself so I can then resize the filesystem it contains ?
Comment 4 Brian Lane 2012-05-11 13:31:59 EDT
You can't used parted to resize a partition.
Comment 5 Benjamin Herrenschmidt 2012-05-11 17:34:38 EDT
Can you add it back then ? I mean seriously, are we back to the stone age of having to recreate the partition map with fdisk from scratch whenever we want to extend a partition in a disk image ?
Comment 6 Brian Lane 2012-06-18 16:49:07 EDT
*** Bug 833023 has been marked as a duplicate of this bug. ***
Comment 7 techtonik 2012-06-18 16:55:06 EDT
I guess the problem was with user complains, who don't get the difference between partition table and physical partition sizes. Stone age, indeed. To resize a partition you need to delete it with fdisk and then manually create with the same params.
Comment 8 Matthew Booth 2012-11-02 14:24:35 EDT
This is a major feature omission. I understand why parted removed the legacy resize feature, which misguidedly tried to resize both the filesystem and partition. However, parted is the only system tool for editing GPT, and it can no longer resize a partition. Filesystem resizing is best left to filesystem tools, but there also has to be a tool for editing partitions!
Comment 9 Fedora End Of Life 2013-07-04 02:40:36 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 10 Fedora End Of Life 2013-08-01 14:16:02 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 11 Peter Backes 2014-01-17 21:17:45 EST
Please reopen, this is still a pressing issue in F20.

Why doesn't parted allow resizing a partition, without the filesystem? This is clearly a feature such a tool should offer. Especially resizing extended partitions. It's as easy as overwriting one attribute in the partition table.

parted-3.1-13.fc20.i686

This package comes with /usr/lib/libparted-fs-resize.so -- what is its purpose? Despite its existence, parted doesn't seem to accept the resize command.
Comment 12 Brian Lane 2014-01-20 12:12:19 EST
The correct way to handle this is to file an issue upstream. Phillip Susi has some patches for Debian that implement this, so it may show up soon.
Comment 13 sean darcy 2014-07-14 10:40:13 EDT
Another voice for fixing this. On F20, it'd be _very_ helpful to be able to resize a partition. Like Peter Backes, I don't understand why we can't resize the partition, and then use a filesystem tool to resize the filesystem.
Comment 14 Brian Lane 2014-07-14 12:10:45 EDT
Upstream now has the resizepart command, I'll make sure that makes it into F21.
Comment 15 Pete Travis 2014-07-16 01:37:33 EDT
Thanks Brian (and to Petr & Phillip for the code) !  The manual process of removing and readding partitions is a bit intimidating, I'm sure a lot of users will appreciate this.

For those of you following along at home,
http://pkgs.fedoraproject.org/cgit/parted.git/commit/?h=f21&id=13386670d031a92365c5ae975a527750c0aa0029
and upstream (somewhere in there :)
http://git.savannah.gnu.org/cgit/parted.git/log/
Comment 16 Brian Lane 2014-07-16 12:13:44 EDT
parted-3.1-29 for f21 and f22 now include the resizepart command. Don't forget to backup your data first!
Comment 17 Gerry Reno 2014-09-17 18:59:16 EDT
Can we please have a backport of parted-3.1-29 to f20?  Thanks.
Comment 18 Brian Lane 2014-09-17 19:14:34 EDT
Sorry, but I'm only adding bugfixes to the f20 version at this point. 3.1-29 has a large number of changes relative to 3.1-13 (I was trying to closely track upstream as a 3.2 release approached).

You'll either have to wait for f21, or build the newer version for f20 yourself.
Comment 19 Jan ONDREJ 2014-09-18 01:06:21 EDT
(In reply to Gerry Reno from comment #17)
> Can we please have a backport of parted-3.1-29 to f20?  Thanks.

You can try to install F21 version in F20 by running this command:

yum --releasever=21 --disablerepo='*' --enablerepo=fedora --enablerepo=updates update parted
Comment 20 BugMasta 2015-11-05 00:04:01 EST
Unbelieveable.
I am on Centos 6, i go to resize a partition, and i get warning about using filesystem specific tools, and then failure to detect filesystem in the lvm volume, then it refuses to even resize the partition itself.

I didnt even WANT parted to resize the filesystem. I will use pvextend, lvextend, and resize2fs to do that.

All i wanted parted to do was resize the partition, which IS PARTEDS GODDAMN JOB.

The people "developing" parted make me depair for humanity.
Comment 21 BugMasta 2015-11-05 00:04:30 EST
Despair even.

Note You need to log in before you can comment on or make changes to this bug.