Bug 807268 - Get "NoMethodError" while running rhc-domain-info without domain created
Summary: Get "NoMethodError" while running rhc-domain-info without domain created
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: oc
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: John (J5) Palmieri
QA Contact: libra bugs
URL:
Whiteboard:
: 807514 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-27 11:58 UTC by jizhao
Modified: 2015-05-15 01:49 UTC (History)
6 users (show)

Fixed In Version: rhc-0.89.9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-13 18:33:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description jizhao 2012-03-27 11:58:47 UTC
Description of problem:
Destroy domain and run "rhc-domain-info". Get NoMethodError.

Version-Release number of selected component (if applicable):
rhc-0.89.4-1.git.0.a917794.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1.Destroy existing domains if any
$ rhc domain destroy -n <domain_name>
2.Run rhc-domain-info
$ rhc-domain-info -ai -d
3.
  
Actual results:
<--------output------------>
/usr/lib/ruby/gems/1.8/gems/rhc-0.89.4/bin/rhc-domain-info:84: undefined method `[]' for nil:NilClass (NoMethodError)
	from /usr/bin/rhc-domain-info:19:in `load'
	from /usr/bin/rhc-domain-info:19
<-------------------------->

Expected results:
Should get "user doesn't have registered namespace"

Additional info:

Comment 1 bzhao 2012-03-28 11:20:59 UTC
Version-Release number of selected component
rhc-0.89.7-1.el6_2.noarch

It'll output the following message while running rhc-domain-info without created domain ..

Output message as follows:

Application Info
================
No applications found.  You can use rhc-create-app to create new applications.

It has still problems, we should get "user doesn't have registered namespace" or the others for expected results

Comment 2 Rob Millner 2012-03-28 17:40:36 UTC
*** Bug 807514 has been marked as a duplicate of this bug. ***

Comment 3 John (J5) Palmieri 2012-03-29 20:29:12 UTC
This is now fixed for 'rhc-domain-info --info' similarly to how we fixed 'rhc domain info'

git commit 6241168dcd196853d6d8465863fdbffbaa56bbc4

Comment 4 jizhao 2012-03-30 06:17:35 UTC
Verified on devenv_stage_154.


Note You need to log in before you can comment on or make changes to this bug.