Bug 807514 - undefined method `[]' for nil:NilClass error is seen when trying to show an empty domain info
undefined method `[]' for nil:NilClass error is seen when trying to show an e...
Status: CLOSED DUPLICATE of bug 807268
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
1.x
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 23:00 EDT by Johnny Liu
Modified: 2012-03-28 13:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-28 13:40:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2012-03-27 23:00:25 EDT
Description of problem:
Before user create domain, run the following command:
$ rhc domain show
Password: 

User Info
=========
/usr/lib/ruby/gems/1.8/gems/rhc-0.89.7/bin/rhc-domain:213:in `show_domain_info': undefined method `[]' for nil:NilClass (NoMethodError)
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.89.7/bin/rhc-domain:316
	from /usr/bin/rhc-domain:19:in `load'
	from /usr/bin/rhc-domain:19


Version-Release number of selected component (if applicable):
devenv-1677
rhc-0.89.7-1.el6_2.noarch

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rob Millner 2012-03-28 13:40:36 EDT

*** This bug has been marked as a duplicate of bug 807268 ***

Note You need to log in before you can comment on or make changes to this bug.