Bug 80730 - SMP-kernel Oops, UP works fine
SMP-kernel Oops, UP works fine
Status: CLOSED DUPLICATE of bug 82123
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2002-12-30 10:52 EST by Magnus Johansson
Modified: 2013-07-02 22:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from dmidecode as requested (5.85 KB, text/plain)
2003-01-01 09:19 EST, Magnus Johansson
no flags Details

  None (edit)
Description Magnus Johansson 2002-12-30 10:52:22 EST
Description of problem:
The SMP-version of the kernel oopses every time i try to start it. The UP-kernel
works fine. Various 7.1 and 7.2 smp-kernels (including errata) have worked fine
on the same hardware.

This is the message on the screen.

00000068
*pde=00000000
Oops: 0000

CPU: 1
EIP: 0060:[<00000068>] Not tainted
EFLAGS:  00010246

EIP is at Using_Versions[] 0x67 (2.4.20-2.2smp)

eax: 00000000  ebx: c2522000  ecx: 00000002 edx: c2522000  esi: c01070c0
edi: 00000000  ebp: 00000000  esp: c2523fb8
ds: 0068  es: 0068  ss: 0068

Process swapper  (pid: 0, Stackpage = c2523000)

Stack:   c0107164 00000002 00000000 00000cb9 00000cb9 c01226c5 00000cb9
00000282 ffffffff 00000000 00000001 00000282 00000001 c040de4a 00000246
0000002a 00000000 c0122932

Call Trace [<c0107164>] cpu_idle [kernel] 0x24 (0xc2523fb8)
[<c01226c5>] call_console_drivers [kernel] 0x65 (0xc2523fcc)
[<c0122932>] printk [kernel] 0x142 (0xc2523ffc)

Code: Bad EIP Value
<0> Kernel panic: Attempted to kill the idle task!
In idle task - not syncing


Version-Release number of selected component (if applicable): 2.4.20-2.2smp


How reproducible: Always


Steps to Reproduce:
1. Press Power on, wait.
2.
3.
    
Actual results:


Expected results:


Additional info:

Motherboard: Tyan 230
CPU: 2xPIII 933 MHz
Memory: 1.5 GB
Video card: Matrox G400 16MB
Comment 1 Arjan van de Ven 2002-12-30 11:07:52 EST
does this get fixed if you use "acpi=off" ?
Comment 2 Magnus Johansson 2002-12-30 12:04:28 EST
Yes, the SMP-kernel now boots up fine. For a beta-release we're now OK, this
issue can be closed.
Comment 3 Bill Nottingham 2003-01-01 01:13:17 EST
Please attach the output of 'dmidecode' from the kernel-utils package on your
system.
Comment 4 Magnus Johansson 2003-01-01 09:19:19 EST
Created attachment 89028 [details]
Output from dmidecode as requested
Comment 5 Magnus Johansson 2003-01-01 09:49:39 EST
I ran successfully a test with Memtest86 3.0 on the hardware. I should also
mention that this test-machine has also successfully run Solaris 8 and FreeBSD
4.7 UP.

The reason that I mention this is that I get both SMP and UP kernel oops (with
acpi=off, obviously) when I have httpd started during boot-up, which was a big
surprise. If I start httpd from a Gnome-terminal, the kernel doesn't Oops, but
httpd goes into infinite 99.9% CPU consumption. 
Unfortunately it is difficult to get good Oops messages for this. Sometimes the
screen just goes black, sometimes the messages are reported very fast in an
infinite loop. Should this be reported as a separate error?
Comment 6 Jeff Garzik 2003-01-17 16:20:16 EST

*** This bug has been marked as a duplicate of 82123 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:50:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.