Bug 82123 - ACPI meta-bug for phoebe public beta
ACPI meta-bug for phoebe public beta
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
: 77948 78417 78998 79201 80211 80225 80285 80330 80337 80360 80366 80371 80395 80404 80449 80525 80563 80587 80588 80602 80680 80702 80730 80779 80811 80821 80882 81250 (view as bug list)
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-01-17 15:59 EST by Jeff Garzik
Modified: 2013-07-02 22:09 EDT (History)
34 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-03 03:35:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Garzik 2003-01-17 15:59:13 EST
Description of problem:
This is a meta-bug which contains all known ACPI bugs that were new in phoebe
public beta 1.  These bugs originated because Red Hat turned on ACPI by default,
which was a change in behavior.  Typical observed problems include oops's on
boot, failing to poweroff, and similar issues.
Comment 1 Jeff Garzik 2003-01-17 16:00:41 EST
*** Bug 81250 has been marked as a duplicate of this bug. ***
Comment 2 Jeff Garzik 2003-01-17 16:02:11 EST
*** Bug 80987 has been marked as a duplicate of this bug. ***
Comment 3 Jeff Garzik 2003-01-17 16:04:39 EST
*** Bug 77948 has been marked as a duplicate of this bug. ***
Comment 4 Jeff Garzik 2003-01-17 16:06:13 EST
*** Bug 78417 has been marked as a duplicate of this bug. ***
Comment 5 Jeff Garzik 2003-01-17 16:07:37 EST
*** Bug 78998 has been marked as a duplicate of this bug. ***
Comment 6 Jeff Garzik 2003-01-17 16:09:43 EST
*** Bug 79201 has been marked as a duplicate of this bug. ***
Comment 7 Jeff Garzik 2003-01-17 16:11:24 EST
*** Bug 80360 has been marked as a duplicate of this bug. ***
Comment 8 Jeff Garzik 2003-01-17 16:14:26 EST
*** Bug 80285 has been marked as a duplicate of this bug. ***
Comment 9 Jeff Garzik 2003-01-17 16:15:55 EST
*** Bug 80395 has been marked as a duplicate of this bug. ***
Comment 10 Jeff Garzik 2003-01-17 16:16:48 EST
*** Bug 80404 has been marked as a duplicate of this bug. ***
Comment 11 Jeff Garzik 2003-01-17 16:18:43 EST
*** Bug 80587 has been marked as a duplicate of this bug. ***
Comment 12 Jeff Garzik 2003-01-17 16:19:27 EST
*** Bug 80702 has been marked as a duplicate of this bug. ***
Comment 13 Jeff Garzik 2003-01-17 16:20:28 EST
*** Bug 80730 has been marked as a duplicate of this bug. ***
Comment 14 Jeff Garzik 2003-01-17 16:22:45 EST
*** Bug 80211 has been marked as a duplicate of this bug. ***
Comment 15 Jeff Garzik 2003-01-17 16:23:45 EST
*** Bug 80225 has been marked as a duplicate of this bug. ***
Comment 16 Jeff Garzik 2003-01-17 16:25:29 EST
*** Bug 80366 has been marked as a duplicate of this bug. ***
Comment 17 Jeff Garzik 2003-01-17 16:33:04 EST
*** Bug 80371 has been marked as a duplicate of this bug. ***
Comment 18 Jeff Garzik 2003-01-17 16:37:40 EST
*** Bug 80449 has been marked as a duplicate of this bug. ***
Comment 19 Jeff Garzik 2003-01-17 16:39:45 EST
*** Bug 80563 has been marked as a duplicate of this bug. ***
Comment 20 Jeff Garzik 2003-01-17 16:40:37 EST
*** Bug 80588 has been marked as a duplicate of this bug. ***
Comment 21 Jeff Garzik 2003-01-17 16:41:46 EST
*** Bug 80602 has been marked as a duplicate of this bug. ***
Comment 22 Jeff Garzik 2003-01-17 16:43:25 EST
*** Bug 80680 has been marked as a duplicate of this bug. ***
Comment 23 Jeff Garzik 2003-01-17 16:44:56 EST
*** Bug 80811 has been marked as a duplicate of this bug. ***
Comment 24 Jeff Garzik 2003-01-17 16:45:55 EST
*** Bug 80821 has been marked as a duplicate of this bug. ***
Comment 25 Jeff Garzik 2003-01-17 16:57:08 EST
*** Bug 80525 has been marked as a duplicate of this bug. ***
Comment 26 Jeff Garzik 2003-01-18 18:54:17 EST
*** Bug 80779 has been marked as a duplicate of this bug. ***
Comment 27 Jeff Garzik 2003-01-18 18:55:15 EST
*** Bug 80337 has been marked as a duplicate of this bug. ***
Comment 28 Jeff Garzik 2003-01-18 18:56:12 EST
*** Bug 80330 has been marked as a duplicate of this bug. ***
Comment 29 Jos Vos 2003-01-18 19:24:57 EST
In beta4 (were ACPI is default turned off AFAIK) powerdown is working again.
Comment 30 Pam Huntley 2003-01-27 16:24:19 EST
An ACPI bug has been found in the ThinkPad BIOS,

"In short, ECDT -> EC_ID is supposed to be the full path name of your EC
device in ACPI Namespace like "\_SB.PCI0.LPC.EC", but IBM BIOSes
accidentally left out the "_", making the path invalid."
(not sure who originally wrote that, it's been forwarded so many times, but
accurately describes the problem).

The fix is being tested now and will be in the 1st quarter BIOS updates, ETA
around end of 1st quarter, beginning of second (I think that puts it around April).

For development purposes, a temporary BIOS ROM with this bug fixed can be made
available, pls contact me if you want it (I work at IBM).   It's for development
purposes, and isn't supported, but it should let you know if your code will work
with the new fix.
Comment 31 Bill Nottingham 2003-02-19 21:17:25 EST
*** Bug 80882 has been marked as a duplicate of this bug. ***
Comment 33 Pam Huntley 2003-04-09 22:28:27 EDT
Updates are now available for the ThinkPad EC_ID ACPI bug.

The following machines are affected:
R30,31,32,40 (certain models only for the R40)
X22,23,24,30
T30
A20,21,22,30,31

All of the T, A & X series machines have BIOS updates, or will have them by the
end of May, so even if your system isn't on the list it's a good idea to check
for updates.

You can get the updates here:
http://www-3.ibm.com/pc/support/site.wss/document.do?lndocid=TPAD-MATRIX 
Comment 34 Jeff Garzik 2004-03-03 03:35:09 EST
Closing bug, as we did not ship ACPI enabled.

Note You need to log in before you can comment on or make changes to this bug.