Bug 807567 - JavaScript files missing for dashboard
JavaScript files missing for dashboard
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-django-horizon (Show other bugs)
17
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 801684 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 03:57 EDT by Fridtjof Busse
Modified: 2012-04-26 16:08 EDT (History)
10 users (show)

See Also:
Fixed In Version: python-django-horizon-2012.1-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 16:08:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fridtjof Busse 2012-03-28 03:57:48 EDT
Description of problem:
The openstack dashboard expects several .js files under the URL /static/horizon/js/
Those files do not exist at that location (/usr/share/openstack-dashboard/openstack_dashboard/static on the FS).

Linking /usr/lib/python2.7/site-packages/horizon/static/horizon into /usr/share/openstack-dashboard/openstack_dashboard/static/ is a workaround.

Version-Release number of selected component (if applicable):
openstack-dashboard-2012.1-0.1.rc1.fc17.noarch

How reproducible:
Simply install the dashboard and look at the JavaScript debugger in your browser.
Comment 1 Pádraig Brady 2012-03-28 05:37:35 EDT
I think the general way to collect all the static files
from possible dependent projects too, is to:

./manage.py collectstatic

though I notice the STATIC_ROOT in settings.py has an extraneous '..' ?
Comment 2 Cole Robinson 2012-04-09 09:52:44 EDT
*** Bug 801684 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2012-04-09 19:48:15 EDT
python-django-horizon-2012.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-django-horizon-2012.1-1.fc17
Comment 4 Fedora Update System 2012-04-10 16:15:59 EDT
Package python-django-horizon-2012.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-django-horizon-2012.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5568/python-django-horizon-2012.1-1.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-04-17 15:11:13 EDT
python-django-horizon-2012.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-django-horizon-2012.1-2.fc17
Comment 6 Fedora Update System 2012-04-17 15:11:30 EDT
python-django-horizon-2012.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-django-horizon-2012.1-2.fc17
Comment 7 Fedora Update System 2012-04-26 16:08:36 EDT
python-django-horizon-2012.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.