Bug 807574 - User can create multiple domains
User can create multiple domains
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Lili Nader
libra bugs
: Triaged
: 811423 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 04:25 EDT by jizhao
Modified: 2015-05-14 21:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 16:46:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jizhao 2012-03-28 04:25:26 EDT
Description of problem:
User can create multiple domains. Create domain always return SUCCESS.

Version-Release number of selected component (if applicable):
rhc-common-0.76.1-1.el6_2.noarch
rhc-server-common-0.87.1-1.el6_2.noarch
rhc-broker-0.89.4-1.el6_2.noarch
rhc-0.89.7-1.el6_2.noarch

How reproducible:
Always

Steps to Reproduce:
1.Create domain
$ rhc domain create -n <domain_one>
2.Create a different domain
$ rhc domain create -n <domain_two>
3.Check domain info
$ rhc domain show
4.Destroy <domain_one>
$ rhc domain destroy -n <domain_one>
5.Check domain info
$ rhc domain show
  
Actual results:
2.Creation succeeds. Get "Command return success", "You may now create an application."
3.<domain_one> is shown in domain info.
4.<domain_one> is destroyed successfully.
5.<domain_two> is shown in domain info.

Expected results:
User shouldn't be able to create multiple domains.

Additional info:
Comment 1 Rob Millner 2012-03-28 13:58:38 EDT
Multiple domains will happen soon but may not be delivered in this sprint (US1876).  If its not being delivered then a simple, easy to remove block should go in place preventing it till the next sprint when there's time to finish the client tools.
Comment 2 Lili Nader 2012-04-10 15:28:59 EDT
rhc client tools need to be updated to enable user to pass a domain id
Comment 3 Clayton Coleman 2012-04-10 18:22:01 EDT
We're not going to be able to get to the client tools anytime soon.  The old API needs to continue to work.
Comment 4 Clayton Coleman 2012-04-10 19:00:33 EDT
All old API code needs to assume the first domain ID, just like the site.  If the API code can't do that, the broker must restrict creating more than one domain until the client tools and UI can react (which won't be until late May at the earliest).  Spoke with Mike this morning, he agreed we should put the limit in place.
Comment 5 Xiaoli Tian 2012-04-10 22:18:55 EDT
*** Bug 811423 has been marked as a duplicate of this bug. ***
Comment 6 Nam Duong 2012-04-18 13:11:59 EDT
Raising severity on this bug to medium as we're seeing issues in the field:
https://www.redhat.com/openshift/community/forums/openshift/app-missing-from-console#comment-20095
Comment 7 Lili Nader 2012-04-23 16:20:18 EDT
Above reported issue was due to multiple account and not domains.  The rest api now prevents multiple domains from being created.
Comment 8 Xiaoli Tian 2012-04-24 04:02:07 EDT
Tested it on devenv_1738, now with CLI, only 1 domain could be created, if try to create another domain, it will output error:

RESULT:
User already has a domain associated. Update the domain to modify.

Note You need to log in before you can comment on or make changes to this bug.