Bug 811423 - I'm able to create more than one namespace using rhc client tools
I'm able to create more than one namespace using rhc client tools
Status: CLOSED DUPLICATE of bug 807574
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 22:09 EDT by Nam Duong
Modified: 2015-05-14 21:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 22:18:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-04-10 22:09:08 EDT
Description of problem:
I'm on production and am able to create more than one namespace:
----
Nams-MacBook-Pro:.openshift nduong$ rhc domain create -n nduong -l nduong+mac@redhat.com
Password: 
OpenShift Express key found at /Users/nduong/.ssh/libra_id_rsa.  Reusing...
Checking ~/.ssh/config
Found rhcloud.com in ~/.ssh/config... No need to adjust
Creation successful

You may now create an application.

Nams-MacBook-Pro:.openshift nduong$ rhc domain create -n nduong2 -l nduong+mac@redhat.com
Password: 
OpenShift Express key found at /Users/nduong/.ssh/libra_id_rsa.  Reusing...
Checking ~/.ssh/config
Found rhcloud.com in ~/.ssh/config... No need to adjust
Creation successful

You may now create an application.
---

Problem is, none of the tools/UI take this business logic change into account - e.g., I can't switch from one to the other using the rhc client tools or Web UI (assuming same for Eclipse plugin)

I'm not able destroy a newly created namespace at this point either:
---
Nams-MacBook-Pro:.openshift nduong$ rhc domain destroy -n nduong2 -l nduong+mac@redhat.com
Password: 
Problem reported from server. Response code was 400.
Re-run with -d for more information.

RESULT:
Could not delete domain.Domain has valid applications.
---
Comment 1 Mike McGrath 2012-04-10 22:11:20 EDT
Side note: Lets make sure we get some automated tests for this if they're not there already.
Comment 2 Xiaoli Tian 2012-04-10 22:18:54 EDT
It's similar to bug 807574, let me close it as duplicate, if not ,feel free to open it

*** This bug has been marked as a duplicate of bug 807574 ***

Note You need to log in before you can comment on or make changes to this bug.