Bug 807737 - [abrt] gjs-1.31.22-1.fc17: g_cancellable_cancel: Process /usr/bin/gjs-console was killed by signal 11 (SIGSEGV)
[abrt] gjs-1.31.22-1.fc17: g_cancellable_cancel: Process /usr/bin/gjs-console...
Status: CLOSED DUPLICATE of bug 804192
Product: Fedora
Classification: Fedora
Component: gjs (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
abrt_hash:680410f98e07ca7dbf455968f7e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 11:16 EDT by Joel
Modified: 2012-04-10 13:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 13:20:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (4.75 KB, text/plain)
2012-03-28 11:16 EDT, Joel
no flags Details
File: backtrace (64.66 KB, text/plain)
2012-03-28 11:16 EDT, Joel
no flags Details
File: maps (93.51 KB, text/plain)
2012-03-28 11:16 EDT, Joel
no flags Details
File: dso_list (17.22 KB, text/plain)
2012-03-28 11:16 EDT, Joel
no flags Details
File: build_ids (5.89 KB, text/plain)
2012-03-28 11:16 EDT, Joel
no flags Details

  None (edit)
Description Joel 2012-03-28 11:16:19 EDT
libreport version: 2.0.10
abrt_version:   2.0.9
backtrace_rating: 4
cmdline:        /usr/bin/gjs-console -I /usr/share/gnome-documents/js -c 'const Main = imports.main; Main.start();'
comment:        Was able to open several documents stored locally, but after viewing a document stored on Google Docs and hitting the 'back' button, I saw this crash.
crash_function: g_cancellable_cancel
executable:     /usr/bin/gjs-console
kernel:         3.3.0-1.fc17.x86_64
pid:            15544
pwd:            /home/joel
remote_result:  NOTFOUND
time:           Wed 28 Mar 2012 11:10:40 AM EDT
uid:            1000
username:       joel

backtrace:      Text file, 66212 bytes
build_ids:      Text file, 6027 bytes
core_backtrace: Text file, 4866 bytes
dso_list:       Text file, 17636 bytes
maps:           Text file, 95753 bytes

environ:
:XDG_VTNR=3
:XDG_SESSION_ID=26
:HOSTNAME=f17x64
:GIO_LAUNCHED_DESKTOP_FILE_PID=15542
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/home/joel/.cache/keyring-VamMvF/gpg:0:1
:DESKTOP_STARTUP_ID=gnome-shell-10868-f17x64-gnome-documents-2_TIME75017313
:TERM=dumb
:SHELL=/bin/bash
:HISTSIZE=1000
:G_MESSAGES_DEBUG=all
:GJS_DEBUG_OUTPUT=stderr
:GNOME_KEYRING_CONTROL=/home/joel/.cache/keyring-VamMvF
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=joel
:LD_LIBRARY_PATH=/usr/lib64/gnome-documents
:SSH_AUTH_SOCK=/home/joel/.cache/keyring-VamMvF/ssh
:GJS_PATH=/usr/share/gnome-documents/js
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/10670,unix/unix:/tmp/.ICE-unix/10670
:USERNAME=joel
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/gnome-documents.desktop
:DESKTOP_SESSION=gnome
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/joel/.local/bin:/home/joel/bin
:MAIL=/var/spool/mail/joel
:QT_IM_MODULE=xim
:PWD=/home/joel
:XMODIFIERS=@im=none
:LANG=en_US.utf8
:GNOME_KEYRING_PID=10665
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:SHLVL=2
:HOME=/home/joel
:XDG_SEAT=seat0
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=joel
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-bx138siXQk,guid=d0909364041f919123f8580000010a9b
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=3
:GI_TYPELIB_PATH=/usr/lib64/gnome-documents/girepository-1.0
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/joel
:XAUTHORITY=/var/run/gdm/auth-for-joel-bZUwGO/database
:_=/usr/bin/gjs-console

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 29884                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       29884                29884                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/joel/.xsession-errors
:pos:	23438
:flags:	0102002
:2:/home/joel/.xsession-errors
:pos:	23438
:flags:	0102002
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:6:socket:[706998]
:pos:	0
:flags:	02004002
:7:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:8:socket:[706999]
:pos:	0
:flags:	02004002
:9:socket:[707000]
:pos:	0
:flags:	02004002
:10:/dev/dri/card0
:pos:	0
:flags:	0100002
:11:/home/joel/.cache/tracker/meta.db
:pos:	2354176
:flags:	02100000
:12:/home/joel/.cache/tracker/meta.db-wal
:pos:	459056
:flags:	02100002
:13:/home/joel/.cache/tracker/meta.db-shm
:pos:	0
:flags:	0100002
:14:anon_inode:inotify
:pos:	0
:flags:	02004000
:15:socket:[708469]
:pos:	0
:flags:	02004002
:16:/tmp/ffi8v0pUy (deleted)
:pos:	0
:flags:	0100002
:17:/dev/urandom
:pos:	0
:flags:	02100000
:18:/home/joel/.thumbnails/normal/c54750c8d1f9f782ee48f712937ba912.png
:pos:	8968
:flags:	0100000
:19:/home/joel/.thumbnails/normal/ad283d50c6590552635fbbcf3da31e77.png
:pos:	12090
:flags:	0100000
:20:/home/joel/Downloads/DCSA470N.pdf
:pos:	4096
:flags:	0100000
:21:/home/joel/.thumbnails/normal/c54750c8d1f9f782ee48f712937ba912.png
:pos:	8968
:flags:	0100000
:22:/home/joel/.thumbnails/normal/ad283d50c6590552635fbbcf3da31e77.png
:pos:	12090
:flags:	0100000
:23:/home/joel/.thumbnails/normal/c54750c8d1f9f782ee48f712937ba912.png
:pos:	8968
:flags:	0100000
:24:/home/joel/.thumbnails/normal/ad283d50c6590552635fbbcf3da31e77.png
:pos:	12090
:flags:	0100000
:25:/home/joel/Downloads/Portfolio 70 | Index Funds Advisors Inc..pdf
:pos:	431253
:flags:	0100000
:26:/dev/urandom
:pos:	0
:flags:	02100000
:27:socket:[710147]
:pos:	0
:flags:	02000002
:28:socket:[710149]
:pos:	0
:flags:	02
:29:socket:[710150]
:pos:	0
:flags:	02004002
:30:socket:[708996]
:pos:	0
:flags:	02004002
:31:/home/joel/.cache/gnome-documents/gnome-documents-3546622919.pdf
:pos:	36936
:flags:	0100000

var_log_messages:
:Mar 28 11:10:40 f17x64 kernel: [74972.677657] gjs-console[15544]: segfault at 100000000 ip 0000003cbae34caa sp 00007fffc245aac0 error 4 in libgio-2.0.so.0.3122.0[3cbae00000+152000]
:Mar 28 11:10:41 f17x64 abrt[15603]: Saved core dump of pid 15544 (/usr/bin/gjs-console) to /var/spool/abrt/ccpp-2012-03-28-11:10:40-15544 (158494720 bytes)
Comment 1 Joel 2012-03-28 11:16:23 EDT
Created attachment 573366 [details]
File: core_backtrace
Comment 2 Joel 2012-03-28 11:16:25 EDT
Created attachment 573367 [details]
File: backtrace
Comment 3 Joel 2012-03-28 11:16:26 EDT
Created attachment 573368 [details]
File: maps
Comment 4 Joel 2012-03-28 11:16:28 EDT
Created attachment 573369 [details]
File: dso_list
Comment 5 Joel 2012-03-28 11:16:29 EDT
Created attachment 573370 [details]
File: build_ids
Comment 6 Cosimo Cecchi 2012-04-10 13:20:08 EDT

*** This bug has been marked as a duplicate of bug 804192 ***

Note You need to log in before you can comment on or make changes to this bug.