Bug 804192 - [abrt] gjs-1.31.10-2.fc17: g_cancellable_cancel: Process /usr/bin/gjs-console was killed by signal 11 (SIGSEGV)
[abrt] gjs-1.31.10-2.fc17: g_cancellable_cancel: Process /usr/bin/gjs-console...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-documents (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Elad Alfassa
Fedora Extras Quality Assurance
abrt_hash:680410f98e07ca7dbf455968f7e...
:
: 801563 807737 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 15:34 EDT by Joel
Modified: 2013-01-23 01:59 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 17:24:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: build_ids (5.89 KB, text/plain)
2012-03-16 15:34 EDT, Joel
no flags Details
File: dso_list (17.08 KB, text/plain)
2012-03-16 15:34 EDT, Joel
no flags Details
File: maps (73.29 KB, text/plain)
2012-03-16 15:34 EDT, Joel
no flags Details
File: backtrace (65.04 KB, text/plain)
2012-03-16 15:34 EDT, Joel
no flags Details
File: backtrace (64.00 KB, text/plain)
2012-03-16 18:15 EDT, Joel
no flags Details
File: backtrace (63.21 KB, text/plain)
2012-03-18 06:10 EDT, Elad Alfassa
no flags Details
File: backtrace (65.35 KB, text/plain)
2012-03-23 14:53 EDT, Owen Taylor
no flags Details

  None (edit)
Description Joel 2012-03-16 15:34:04 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/bin/gjs-console -I /usr/share/gnome-documents/js -c 'const Main = imports.main; Main.start();'
comment:        While viewing a document using the Documents app, I hit the back button on the top left and this crash occurred.
crash_function: g_cancellable_cancel
executable:     /usr/bin/gjs-console
kernel:         3.3.0-0.rc7.git0.3.fc17.x86_64
pid:            1895
pwd:            /home/joel
reason:         Process /usr/bin/gjs-console was killed by signal 11 (SIGSEGV)
time:           Fri 16 Mar 2012 03:28:19 PM EDT
uid:            1000
username:       joel

backtrace:      Text file, 66602 bytes
build_ids:      Text file, 6027 bytes
dso_list:       Text file, 17489 bytes
maps:           Text file, 75052 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=f17x64
:GIO_LAUNCHED_DESKTOP_FILE_PID=1893
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/tmp/keyring-ZRcRu8/gpg:0:1
:DESKTOP_STARTUP_ID=gnome-shell-1023-f17x64-gnome-documents-6_TIME855044
:TERM=dumb
:SHELL=/bin/bash
:HISTSIZE=1000
:G_MESSAGES_DEBUG=all
:GJS_DEBUG_OUTPUT=stderr
:GNOME_KEYRING_CONTROL=/tmp/keyring-ZRcRu8
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=joel
:LD_LIBRARY_PATH=/usr/lib64/gnome-documents
:SSH_AUTH_SOCK=/tmp/keyring-ZRcRu8/ssh
:GJS_PATH=/usr/share/gnome-documents/js
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/808,unix/unix:/tmp/.ICE-unix/808
:USERNAME=joel
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/gnome-documents.desktop
:DESKTOP_SESSION=gnome
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/joel/.local/bin:/home/joel/bin
:MAIL=/var/spool/mail/joel
:QT_IM_MODULE=xim
:PWD=/home/joel
:XMODIFIERS=@im=none
:LANG=en_US.UTF-8
:GNOME_KEYRING_PID=803
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:SHLVL=2
:HOME=/home/joel
:XDG_SEAT=seat0
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=joel
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-4mm6EoXDJ2,guid=387de4f449e1627775e5d6a10000002a
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:GI_TYPELIB_PATH=/usr/lib64/gnome-documents/girepository-1.0
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/joel
:XAUTHORITY=/var/run/gdm/auth-for-joel-nS3maN/database
:_=/usr/bin/gjs-console

var_log_messages:
:Mar 16 15:28:19 f17x64 kernel: [  874.450614] gjs-console[1895] general protection ip:7f0d62521c5a sp:7fff9f590ae0 error:0 in libgio-2.0.so.0.3120.0[7f0d624ed000+152000]
:Mar 16 15:28:20 f17x64 abrt[1941]: Saved core dump of pid 1895 (/usr/bin/gjs-console) to /var/spool/abrt/ccpp-2012-03-16-15:28:19-1895 (146051072 bytes)
Comment 1 Joel 2012-03-16 15:34:06 EDT
Created attachment 570682 [details]
File: build_ids
Comment 2 Joel 2012-03-16 15:34:08 EDT
Created attachment 570683 [details]
File: dso_list
Comment 3 Joel 2012-03-16 15:34:09 EDT
Created attachment 570684 [details]
File: maps
Comment 4 Joel 2012-03-16 15:34:11 EDT
Created attachment 570685 [details]
File: backtrace
Comment 5 Joel 2012-03-16 18:15:25 EDT
Just hit the back button again.

backtrace_rating: 4
Package: gjs-1.31.10-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 6 Joel 2012-03-16 18:15:29 EDT
Created attachment 570726 [details]
File: backtrace
Comment 7 Elad Alfassa 2012-03-18 06:09:55 EDT
Used gnome-documents, then it crashed. 
I viewed a document, and then tried to go back to the list of documents.


backtrace_rating: 4
Package: gjs-1.31.10-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 Elad Alfassa 2012-03-18 06:10:01 EDT
Created attachment 570871 [details]
File: backtrace
Comment 9 Owen Taylor 2012-03-23 14:53:50 EDT
Hit back after viewing a document

backtrace_rating: 4
Package: gjs-1.31.22-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 10 Owen Taylor 2012-03-23 14:53:53 EDT
Created attachment 572365 [details]
File: backtrace
Comment 11 Cosimo Cecchi 2012-03-23 17:24:57 EDT
Submitted upstream as https://bugzilla.gnome.org/show_bug.cgi?id=672723
Comment 12 Cosimo Cecchi 2012-03-24 09:46:58 EDT
*** Bug 801563 has been marked as a duplicate of this bug. ***
Comment 13 Cosimo Cecchi 2012-04-10 13:20:08 EDT
*** Bug 807737 has been marked as a duplicate of this bug. ***
Comment 14 sangu 2012-11-19 00:38:12 EST
This issue still happens in GNOME 3.6.2 (gnome-documents-3.6.2-1.fc18.x86_64)
Comment 15 gabe@codehaus.org 2013-01-23 01:59:17 EST
This issue has been fixed upstream.

Note You need to log in before you can comment on or make changes to this bug.