Bug 807850 - RFE: User story: As a translator I would like to be able to run the Validation Checks on a whole book so that I can find errors even in existing translations.
Summary: RFE: User story: As a translator I would like to be able to run the Validatio...
Keywords:
Status: CLOSED DUPLICATE of bug 846314
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: zanata-dev-internal
QA Contact: Ding-Yi Chen
URL:
Whiteboard:
Depends On: 846314
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-28 22:19 UTC by Hedda Peters
Modified: 2013-02-05 00:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-05 00:07:20 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 846314 None None None Never

Internal Links: 846314

Description Hedda Peters 2012-03-28 22:19:48 UTC
User story: As a translator I would like to be able to run the Validation Checks on a whole book so that I can find errors even in existing translations.


It just occured to me when updating an already partly translated document. By chance, I opened the editor for an existing translation and was surprised to find Validation Warnings.

Comment 1 Runa Bhattacharjee 2012-07-30 13:20:13 UTC
Request for technical evaluation.

Comment 2 Michelle Kim 2012-11-13 01:03:13 UTC
Is this bug somewhat related to this bug https://bugzilla.redhat.com/show_bug.cgi?id=846314 ? If so, should we merge these two into one bug?

I believe implenting the 846314 (error view on the project list) will enable translators to check if there is a error on already translated document?

Comment 3 David Mason 2012-11-13 01:25:51 UTC
This bug is related to, but also distinct from https://bugzilla.redhat.com/show_bug.cgi?id=846314

This bug does not necessarily require the validation state to be persisted - validations could be run on-demand for a list of documents (with some caching to prevent excessive processing).The other bug would require persistence of the validation state of every project, and would require this state to be constantly kept up-to-date.

Comment 4 Michelle Kim 2013-02-05 00:07:20 UTC

*** This bug has been marked as a duplicate of bug 846314 ***


Note You need to log in before you can comment on or make changes to this bug.