Bug 846314 - RFE: Show validation state in doc list and link to error-filter view in editor
RFE: Show validation state in doc list and link to error-filter view in editor
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Alex Eng
Ding-Yi Chen
:
: 807850 (view as bug list)
Depends On: 903926
Blocks: 807850
  Show dependency treegraph
 
Reported: 2012-08-07 08:45 EDT by Runa Bhattacharjee
Modified: 2013-11-26 22:22 EST (History)
6 users (show)

See Also:
Fixed In Version: 2.3-SNAPSHOT (20130409-1233)
Doc Type: Bug Fix
Doc Text:
Story Points: 13
Clone Of:
Environment:
Last Closed: 2013-11-26 22:22:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attachment 1 - error indicator (37.96 KB, image/png)
2012-08-07 08:45 EDT, Runa Bhattacharjee
no flags Details
attachment 2 - Editor with only strings with errors (81.79 KB, image/png)
2012-08-07 08:47 EDT, Runa Bhattacharjee
no flags Details
attachment 3 - New string filter for errors (117.07 KB, image/png)
2012-08-07 08:48 EDT, Runa Bhattacharjee
no flags Details

  None (edit)
Description Runa Bhattacharjee 2012-08-07 08:45:20 EDT
Created attachment 602740 [details]
attachment 1 [details] - error indicator

After the user reaches the list of files that are available for translation for a project-version, an error indicator has been requested to be placed next to a file with possible validation errors.  [attachment 1 [details]]

A mouseover on the error indicator can display the number of errors detected on that file.

On clicking on the error indicator next to a file, the file is opened in the translation editor with only the strings with errors. [attachment 2 [details]]


Additional request:

An alternative method  to reach the UI as represented in attachment 2 [details] is by using an additional filter under the 'Editor Options', indicated as 'Error'. [attachment 3 [details]]


Possible impediments:

The validation checks that would be used for generating the initial error results for the indicator. A possible solution would be to identify a default set of checks for all projects or allow project maintainers to indicate a default set of checks while creating their project.
Comment 1 Runa Bhattacharjee 2012-08-07 08:47:05 EDT
Created attachment 602741 [details]
attachment 2 [details] - Editor with only strings with errors
Comment 2 Runa Bhattacharjee 2012-08-07 08:48:11 EDT
Created attachment 602742 [details]
attachment 3 [details] - New string filter for errors
Comment 3 Michelle Kim 2013-01-31 01:10:44 EST
1. On demand validation check button on the document list (works per page - page size limit to 25/50 pages). + Cache : story points 8

2. Error filter view in editor (to use the same cache) : story points 3
Comment 4 Michelle Kim 2013-02-04 19:07:20 EST
*** Bug 807850 has been marked as a duplicate of this bug. ***
Comment 6 Alex Eng 2013-03-17 18:26:51 EDT
Implemented:
1. On demand validation request on document list view 
2. Error filter view in editor

In progress: caching on validation result to be used by both implementation

See
https://github.com/zanata/zanata/commit/efb6fccd8109c44509a126bfec0a6da6c96c1357
https://github.com/zanata/zanata/commit/9645eb4c0c0c980962126485563d68e0a2863f1c
https://github.com/zanata/zanata/commit/c639b3459272ba3e679cf6ad8e085ddde53e7da2
https://github.com/zanata/zanata/commit/87e4cc5d31f3ccdd0ca3ba45001124750c5799cd
https://github.com/zanata/zanata/commit/0e6390d606b936322b802841f40ea0e51d8a8885
https://github.com/zanata/zanata/commit/d40df25a9b9c5fa224cdd17104e1fc8d064e3268
https://github.com/zanata/zanata/commit/9dd8501ec584e33dbc2ebb72e8a1c1a7f0a044a7
https://github.com/zanata/zanata/commit/8a250290daffd43699a7ae6ea73ce3931071323c
https://github.com/zanata/zanata/commit/f76325ed0e8adb7470b0043f071b6327f161b6aa
https://github.com/zanata/zanata/commit/3edaf4bb764bdde636457af3d1d21795c17d851f
https://github.com/zanata/zanata/commit/684d8ca6ebe020062c7ff916c839e8af71a49190
https://github.com/zanata/zanata/commit/75191a82f57c451626332ded9212a6c0a73612c2
https://github.com/zanata/zanata/commit/cc26bba62948a80b0411f6a670ff3cfc22e85744
https://github.com/zanata/zanata/commit/95239e5728819e350154d33fa9191e3ca60ba769
https://github.com/zanata/zanata/commit/bc9a29b12cbc2383a226b86c7a2e8a961cd6040c
https://github.com/zanata/zanata/commit/1dbaf6e6234578fdfcc2316f945de51048656119
https://github.com/zanata/zanata/commit/6324955d8ac38093c4cff899b5d613ce1a983481
https://github.com/zanata/zanata/commit/f37fa1e09a06f782a30884c394a4fd41bb1c58af
https://github.com/zanata/zanata/commit/ff545c3ba53a8f089e6221b06625d3c60935e014
https://github.com/zanata/zanata/commit/093a36f9657868e4725576168f25cfd61946eacf
https://github.com/zanata/zanata/commit/17dbaea4216fae54256e8d66432da408b1408559
https://github.com/zanata/zanata/commit/263996257e68cff96e2e00edf71c3bb42008f29e
https://github.com/zanata/zanata/commit/87aab47742962c65790027357d4ddc3f88ffa6c0
https://github.com/zanata/zanata/commit/86b76a3166a9a344fdacf37e4b02733dd738d9a4
https://github.com/zanata/zanata/commit/249ebe7d89595aff1307ceecc6ff1ca8b8ff5e62
https://github.com/zanata/zanata/commit/cbe50e5647fb8d41005c41a0fd1d9f3b9d754ac3
Comment 8 Ding-Yi Chen 2013-04-09 00:34:48 EDT
Note: the validation button is at Validation panel on the right.

VERIFIED with Zanata version 2.3-SNAPSHOT (20130409-1233)
Comment 9 Sean Flanigan 2013-11-26 22:22:27 EST
Closing bugs which were VERIFIED with snapshots <= 3.1.

Note You need to log in before you can comment on or make changes to this bug.