Bug 808334 - Sync status remains in 'Queued', however sync is finished at backend
Sync status remains in 'Queued', however sync is finished at backend
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Partha Aji
Sachin Ghai
: Triaged
: 859245 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 03:45 EDT by Sachin Ghai
Modified: 2014-09-18 11:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:37:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
UI is showing sync status as 'Queued', however in actual repo sync is finished at backend (121.78 KB, image/png)
2012-03-30 03:47 EDT, Sachin Ghai
no flags Details
Sync Status - after sync (134.82 KB, image/png)
2012-04-18 14:11 EDT, Brad Buckingham
no flags Details

  None (edit)
Description Sachin Ghai 2012-03-30 03:45:48 EDT
Description of problem:
I was trying to schedule a sync for custom repo. I created product/repo and defined a sync plan for next 15 minutes. Sync started at backend at its scheduled time as pulp logs updated when sync is finished, however UI was still showing the state 'queued'

Version-Release number of selected component (if applicable):

katello-0.1.307-1.el6.noarch
pulp-1.0.2-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Create provider/product/repo
2. Create a sync plan
3. Apply the sync plan on newly created product in step1
  
Actual results:
Sync status remains in queued state, however sync is finished at backend

Expected results:
Sync status should be properly reflected on UI

Additional info:
Comment 1 Sachin Ghai 2012-03-30 03:47:09 EDT
Created attachment 573905 [details]
UI is showing sync status as 'Queued', however in actual repo sync is finished at backend
Comment 2 Sachin Ghai 2012-03-30 03:47:54 EDT
pulp.logs when sync started:

2012-03-30 14:00:04,782 31299:139825390802688: pulp.server.api.repo_sync:INFO: repo_sync:260 Sync invoked for repo <ACME_Corporation-pulp-pulp_64>
2012-03-30 14:00:04,798 31299:139825390802688: pulp.server.api.repo_sync:INFO: repo_sync:274 Sync of ACME_Corporation-pulp-pulp_64 starting, skip_dict = {}
2012-03-30 14:00:05,422 31299:139825390802688: pulp.server.api.synchronizers:INFO: synchronizers:729 cacert = <None>, cert = <None>
2012-03-30 14:00:05,442 31299:139825390802688: pulp.server.api.synchronizers:INFO: synchronizers:778 Fetching repo to </var/lib/pulp//repos/ACME_Corporation/Library/custom/pulp/pulp_64> with verify_options <{'checksum': True, 'size': True}>
2012-03-30 14:00:48,400 31299:139825390802688: pulp.server.api.synchronizers:INFO: synchronizers:786 YumSynchronizer reported 20 successes, 20 downloads, 0 errors
2012-03-30 14:00:53,528 31299:139825390802688: pulp.server.api.synchronizers:INFO: synchronizers:849 checksum type for repo id ACME_Corporation-pulp-pulp_64 is sha256
2012-03-30 14:00:53,551 31299:139825390802688: pulp.server.api.synchronizers:INFO: synchronizers:832 Running createrepo, this may take a few minutes to complete.
2012-03-30 14:00:53,551 31299:139825390802688: pulp.server.util:INFO: util:507 metadata found; taking backup.
2012-03-30 14:00:53,851 31299:139825390802688: pulp.server.util:INFO: util:467 Checking what metadata types are available: ['filelists', 'other', 'primary']
2012-03-30 14:00:53,856 31299:139825390802688: pulp.server.util:INFO: util:489 started repo metadata update: ['createrepo', '--database', '--checksum', 'sha256', '--update', '/var/lib/pulp//repos/ACME_Corporation/Library/custom/pulp/pulp_64']
2012-03-30 14:00:59,345 31299:139825390802688: pulp.server.util:INFO: util:542 createrepo on /var/lib/pulp//repos/ACME_Corporation/Library/custom/pulp/pulp_64 finished
2012-03-30 14:00:59,346 31299:139825390802688: pulp.server.api.synchronizers:INFO: synchronizers:836 Createrepo finished in 5.79519796371 seconds
2012-03-30 14:00:59,356 31299:139825390802688: pulp.server.api.synchronizers:INFO: synchronizers:441 No image files to import to repo..
2012-03-30 14:00:59,450 31299:139825390802688: pulp.server.api.synchronizers:INFO: synchronizers:421 No metadata for 'File Sync' present; no files to import to repo..
2012-03-30 14:00:59,591 31299:139825390802688: pulp.server.api.synchronizers:INFO: synchronizers:411 Skipping errata imports from sync process
2012-03-30 14:00:59,602 31299:139825390802688: pulp.server.api.repo_sync:INFO: repo_sync:281 Sync on ACME_Corporation-pulp-pulp_64 returned 20 packages, 0 errata in 54.8035540581 seconds
2012-03-30 14:00:59,608 31299:139825390802688: pulp.server.api.repo_sync:INFO: repo_sync:292 0 old packages to process, 20 new packages to process
2012-03-30 14:00:59,708 31299:139825390802688: pulp.server.api.repo_sync:INFO: repo_sync:307 Examining 0 errata from repo ACME_Corporation-pulp-pulp_64
2012-03-30 14:00:59,710 31299:139825390802688: pulp.server.api.repo_sync:INFO: repo_sync:311 Removing 0 old errata from repo ACME_Corporation-pulp-pulp_64
2012-03-30 14:00:59,732 31299:139825390802688: pulp.server.api.repo_sync:INFO: repo_sync:320 Adding 0 new errata to repo ACME_Corporation-pulp-pulp_64
2012-03-30 14:00:59,753 31299:139825390802688: pulp.server.tasking.task:INFO: task:450 Task succeeded: Task 1cbf4a1c-7a90-11e1-9957-525400746b1e: _sync(ACME_Corporation-pulp-pulp_64, synchronizer=<pulp.server.api.synchronizers.YumSynchronizer object at 0x7f2b9c060fd0>, progress_callback=<bound method RepoSyncTask.progress_callback of <pulp.server.api.repo_sync_task.RepoSyncTask object at 0x7f2b9c06d3d0>>)
Comment 3 Sachin Ghai 2012-03-30 03:49:28 EDT
I created the pulp repo s and it is synced on katello server. However UI is not reflecting the correct status.
====

[root@scroponok pulp_64]# ls
gofer-0.66-1.el6.noarch.rpm                      pulp-1.0.0-2.el6.noarch.rpm                 python-gofer-0.66-1.el6.noarch.rpm
gofer-package-0.66-1.el6.noarch.rpm              pulp-admin-1.0.0-2.el6.noarch.rpm           python-isodate-0.4.4-4.pulp.el6.noarch.rpm
grinder-0.0.138-1.el6.noarch.rpm                 pulp-cds-1.0.0-2.el6.noarch.rpm             python-oauth2-1.5.170-2.pulp.el6.noarch.rpm
m2crypto-0.21.1.pulp-7.el6.x86_64.rpm            pulp-client-lib-1.0.0-2.el6.noarch.rpm      python-qpid-0.7.946106-1.el6.noarch.rpm
m2crypto-debuginfo-0.21.1.pulp-7.el6.x86_64.rpm  pulp-common-1.0.0-2.el6.noarch.rpm          python-rhsm-0.96.4-1.el6.noarch.rpm
mod_wsgi-3.3-3.pulp.el6.x86_64.rpm               pulp-consumer-1.0.0-2.el6.noarch.rpm        python-webpy-0.32-8.el6.noarch.rpm
mod_wsgi-debuginfo-3.3-3.pulp.el6.x86_64.rpm     pulp-selinux-server-1.0.0-2.el6.noarch.rpm  repodata
[root@scroponok pulp_64]# pwd
/var/lib/pulp/repos/ACME_Corporation/Library/custom/pulp/pulp_64
[root@scroponok pulp_64]#
Comment 4 Sachin Ghai 2012-04-02 05:02:12 EDT
Reproducible in latest puddle.

katello-0.1.307-1.el6.noarch
pulp-1.0.2-1.el6.noarch
Comment 5 Jeff Weiss 2012-04-03 09:26:42 EDT
This appears to be a regression of bug#746659
Comment 6 Jeff Weiss 2012-04-03 09:29:32 EDT
And bug#795825

Unfortunately the sync status page has been incredibly fragile for its entire lifetime.  I don't know what it will take to fix it permanently, seems like a design flaw if the same regression(s) keeps recurring over and over.
Comment 7 James Laska 2012-04-18 10:33:50 EDT
mmccune: How do we want to handle this for 1.0?

My impression, based on Jeff's feedback, is that we're not going to resolve all of the sync problems in time for the 1.0 release.  Does this bug prevent/block any actions from proceeding (like promoting the sync'd repo)?
Comment 8 Brad Buckingham 2012-04-18 14:11:51 EDT
Created attachment 578432 [details]
Sync Status - after sync
Comment 9 Brad Buckingham 2012-04-18 14:13:32 EDT
Ran a test w/ the following builds:
katello-0.1.310-1.el6_2.noarch
pulp-1.0.4-1.el6.noarch

Created provider/product/repo (zoo), created sync plan/schedule.  The sync completed successfully and was reflected in the UI (see attachment 578432 [details] above).  After the sync, was able to successfully promote the zoo product to the next environment.
Comment 11 Mike McCune 2012-05-09 11:30:49 EDT
Will take a look at this as well as:

https://bugzilla.redhat.com/show_bug.cgi?id=818204
Comment 12 Mike McCune 2012-08-03 13:21:42 EDT
lets retest this with the latest
Comment 13 Sachin Ghai 2012-08-13 05:49:30 EDT
The issue is still reproducible. I tried to reproduce with following build.

katello-1.1.4-1.git.1.a31b865.el6_3.noarch

The status remains in 'queued' state, however actual repo sync is finished and upadted in pulp.log.
Comment 14 Ivan Necas 2012-09-21 04:48:59 EDT
Sachin: would it be possible to attach katello-debug output with all the log files. It's hard to debug this kind of hardly reproducible issues
Comment 17 Mike McCune 2012-10-10 10:56:21 EDT
*** Bug 859245 has been marked as a duplicate of this bug. ***
Comment 18 Mike McCune 2014-03-18 13:37:12 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.