Bug 80841 - redhat-rpm-config broken in 8.0
redhat-rpm-config broken in 8.0
Status: CLOSED DUPLICATE of bug 70972
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
i686 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2002-12-31 17:23 EST by Need Real Name
Modified: 2006-02-21 13:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:50:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-12-31 17:23:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
The package manager is broken: it lists some installed packages as being not
installed; lists others as being installed that I'm pretty sure are not.  Then
when I activate the "update" button by selecting and then deselecting one
package, and click it, the package manager notifies that NN packages have been
selected for deletion and MM packages selected for installation -- even though
I've actually elected to make no changes!

Unfortunately, the last time I tested this, it notified me that it was about to
delete 32 components or packages, including gnome, the gimp, nautilus, metacity,
file-roller, the control center and more.

I have test this on all three of my RH 8.0 systems; the exact mistakes the
Package Installer makes in identifying packages to install and delete have been
different on each system; I have not made a record to compare whether the list
of installed packages turns out the same each time the package manager is invoked.

Version-Release number of selected component (if applicable):
Not available viat the 8.0 menuing system

How reproducible:

Steps to Reproduce:
1. Foot ->
2. System Settings ->
3. Packages ->
4. Password for root ->
5. Look at the collected packages, compare with known installation ->
6. Activate the "Update" button by selecting or deselecting something
7. Click "Update"
8. Look at the results!

Actual Results:  Potential disaster

Expected Results:  Proper detection of installed and uninstalled packages

Additional info:

An unprepared person could trash their installation!
Comment 1 Need Real Name 2002-12-31 18:10:18 EST
I inadvertently listed this as a 
issue; it is a 

I apologize
Comment 2 Jeremy Katz 2003-01-22 23:19:23 EST
Can you give an exact steps to reproduce this?  I haven't seen it myself
Comment 3 Need Real Name 2003-01-28 12:38:25 EST
I'm sorry, but I don't know how to be more specific than I was.  This occurred
on both of my Red Hat 8.0 installations, a Linux Hardware Solutions 1998 collage
of hardware, and my IBM T-series 1.2GHz laptop (a 2001 collage of hardware).  It
has been consistently and reliably produced by going through the menus in the
usual way, as I indicated in my first post.  I have not compared the screen
output from trial to trial.

What other information would be helpful?  Could I run a query of any sort and
send you the output?

If you need access to either machine, Michael K Johnson can provide it.
Comment 4 Helge Ingvoldstad 2003-02-07 06:32:18 EST
I've had the same problem as described here.
Comment 5 Richard L. Asmuth 2003-02-22 19:59:09 EST
redhat-config-packages crashes before displaying list of available packages.

To reproduce this, I do not touch the mouse or keyboard after invoking
the command from the shell.

$ redhat-config-packages
Xlib:  extension "RENDER" missing on display ":0.0".
Xlib:  extension "RENDER" missing on display ":0.0".
Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/MainWindow.py", line 163, in ?
    comps = im.readCompsViaMethod(hdlist, progress.update)
  File "/usr/share/redhat-config-packages/method.py", line 488, in
    update_method = update_method)
  File "/usr/share/redhat-config-packages/comps.py", line 387, in __init__
    self.readCompsFile(file, self.packages)
  File "/usr/share/redhat-config-packages/comps.py", line 471, in readCompsFile
  File "/usr/share/redhat-config-packages/comps.py", line 420, in setupStateDicts
    for prov in h[rpm.RPMTAG_PROVIDES]:
TypeError: iteration over non-sequence
Comment 6 Tim Farnum 2003-02-25 09:48:06 EST
I have had this same problem on my Sony VAIO FXA-36 laptop, while trying to
install relatively insignificant packages with complicated sets of
interdependencies (without a lot of interdependencies, it is still easier to use
rpm) after the original install of 8.0. Config-packages trashed my installation
to the point where I had to do a new install from the CD. It occurred following
an upgrade from 7.3, and I wondered if it was the result of a poor upgrade. On
other machines of mine, I have handled the redhat-config-packages program with
kid gloves.
Comment 7 Tim Farnum 2003-02-26 16:51:36 EST
just signing up for cc
Comment 8 Need Real Name 2003-03-12 14:35:38 EST
Yeah, I've watched the system threads while executing redhat-config-packages in
8.0. It exits out as soon as it calls on python. Rpm still works from the
terminal,though; I've just fallen back on that.
Comment 9 Jeremy Katz 2003-06-29 16:42:58 EDT

*** This bug has been marked as a duplicate of 70972 ***
Comment 10 Red Hat Bugzilla 2006-02-21 13:50:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.