Bug 808448 - Mouse scroll is not working properly
Mouse scroll is not working properly
Status: CLOSED DUPLICATE of bug 809419
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 08:13 EDT by Tom Mannerhagen
Modified: 2012-04-11 19:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 19:07:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Mannerhagen 2012-03-30 08:13:30 EDT
Description of problem:
Scrolling with the mouse wheel in certain Gnome applications is really strange.

Version-Release number of selected component (if applicable):
Example: Nautilus 3.4.0-1.fc17.i686

How reproducible:
100%

Steps to Reproduce:
1. Open f.ex. Nautilus to display a folder which need more space than 1 window can show
2. Use the mouse wheel to scroll up or down
3. The vertical scroll bar jumps down in the bottom and is not possible to move by use of the scroll wheel.
  
Actual results:
The vertical scrollbar in the Nautilus window jumps immediately down to the lowest point and is not possible to move with the mouse wheel.
Using the pointer to click-and-hold the scrollbar gives no problems.
Also using PgUp and PgDn to move around in the window works as expected.

The scroll-wheel works perfect in Firefox f.ex.


Expected results:
Normal scroll behaviour.

Additional info:
The mouse is black. :)
Comment 1 Allen Chen 2012-04-01 20:23:50 EDT
Confirmed this bug in Nautilus, but the mouse scrolling ok in Chrome or Firefox,
also it is ok for gnome-terminal and so forth.
Comment 2 Allen Chen 2012-04-01 21:07:38 EDT
It should be a gtk3 issue. Any gtk3 application has same issue.
Comment 3 Krisztian Ganyai 2012-04-09 09:50:57 EDT
I have same problem with Fedora 17 alpha. I have a simple Logitech USB mouse with a wheel and when scrolling in Evolution or in Nautilus, the window just jumps to the bottom and stays there.
Comment 4 Krisztian Ganyai 2012-04-09 10:03:19 EDT
Additional note: I'm running the 32bit version. Probably this is related: https://bugzilla.redhat.com/show_bug.cgi?id=809419
Comment 5 Matthias Clasen 2012-04-11 19:07:49 EDT

*** This bug has been marked as a duplicate of bug 809419 ***

Note You need to log in before you can comment on or make changes to this bug.