Bug 809419 - Mouse scroll wheel don't work on Fedora 17 i686 in most gnome 3.4 apps
Mouse scroll wheel don't work on Fedora 17 i686 in most gnome 3.4 apps
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libXi (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
: 808448 808457 809861 (view as bug list)
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-04-03 06:24 EDT by ToniTC
Modified: 2012-08-29 20:58 EDT (History)
10 users (show)

See Also:
Fixed In Version: libXi-1.6.0-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-14 00:35:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debian patch to XExtInt.c on libXi package (658 bytes, patch)
2012-04-03 06:24 EDT, ToniTC
no flags Details | Diff

  None (edit)
Description ToniTC 2012-04-03 06:24:11 EDT
Created attachment 574812 [details]
Debian patch to XExtInt.c on libXi package

Description of problem:
Mouse scroll wheel don't work on Fedora 17 i686 in most gnome 3.4 apps

Tested on gnome-system-monitor and nautilus 
Scroll wheel works ok in gnome-terminal

Mouse Scroll wheel works on x86_64 system


Version-Release number of selected component (if applicable):
libXi-1.5.99.2-4.20111222gitae0187c87.fc17


How reproducible:
Always. Start nautilus or gnome-system-monitor


Steps to Reproduce:
1. Start gnome-system-monitor
2. Try to scroll down with the mouse wheel
  
Actual results:
Window reacts only to the first "step down" and goes to the end of the list
Scroll up dont work anymore. 


Expected results:
Mouse wheel scrolling works up an down


Additional info:

I've found a patch (http://lists.debian.org/debian-x/2012/03/msg00086.html)
applied to libXi on debian. 
I've aplied that patch to the libXi-1.5.99.3-1.fc18 sources, compiled and installed the resulting package, and seems to solve the problem so far.
Comment 1 Simon Peeters 2012-04-09 17:07:35 EDT
I can confirm this bug and that the patch fixes this

i uploaded fixed rpm's for fc17 to https://docs.google.com/open?id=0B7ZiNhISDBrveXJmdFFGSGxEakk
Comment 2 Fedora Update System 2012-04-10 01:37:21 EDT
libXi-1.6.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libXi-1.6.0-1.fc17
Comment 3 Fedora Update System 2012-04-10 16:15:24 EDT
Package libXi-1.6.0-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libXi-1.6.0-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5566/libXi-1.6.0-1.fc17
then log in and leave karma (feedback).
Comment 4 Matthias Clasen 2012-04-11 19:05:40 EDT
*** Bug 808457 has been marked as a duplicate of this bug. ***
Comment 5 Matthias Clasen 2012-04-11 19:06:12 EDT
*** Bug 809861 has been marked as a duplicate of this bug. ***
Comment 6 Matthias Clasen 2012-04-11 19:07:49 EDT
*** Bug 808448 has been marked as a duplicate of this bug. ***
Comment 7 Allen Chen 2012-04-12 02:57:00 EDT
It fixed as tested after latest update. Nice.
Comment 8 Kamil Páral 2012-04-12 07:57:28 EDT
Fix verified. Please add karma to Bodhi.
Comment 9 Mikhail 2012-04-12 08:16:36 EDT
Seems fixed. Super. How add karma to Bodhi?
Comment 10 Kamil Páral 2012-04-12 08:23:08 EDT
(In reply to comment #9)
> Seems fixed. Super. How add karma to Bodhi?

Just log in and then click "Add comment" here:
https://admin.fedoraproject.org/updates/FEDORA-2012-5566/libXi-1.6.0-1.fc17
Comment 11 Mikhail 2012-04-12 10:02:36 EDT
How restory my `Username`? It seems I registered and now can not remember. :(
Comment 12 Kamil Páral 2012-04-12 11:50:55 EDT
Sorry, this is a bug report, not a support forum. Please ask anywhere on IRC, mailist list or Ask Fedora:
http://fedoraproject.org/en/get-help
Comment 13 Fedora Update System 2012-04-14 00:35:56 EDT
libXi-1.6.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2012-08-13 03:23:41 EDT
btparser-0.18-2.fc17, abrt-2.0.11-2.fc17, libreport-2.0.12-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-11529/abrt-2.0.11-2.fc17,libreport-2.0.12-3.fc17,btparser-0.18-2.fc17
Comment 15 Fedora Update System 2012-08-29 20:58:33 EDT
abrt-2.0.12-1.fc17, libreport-2.0.13-2.fc17, btparser-0.18-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.