Bug 808458 - Authconfig crashes when sets krb realm
Authconfig crashes when sets krb realm
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Stephen Gallagher
IDM QE LIST
: Regression
Depends On: 768935
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 09:07 EDT by Iveta Wiedermann
Modified: 2013-06-03 10:22 EDT (History)
5 users (show)

See Also:
Fixed In Version: sssd-1.8.0-22.el6
Doc Type: Bug Fix
Doc Text:
No technical note required
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 07:56:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Iveta Wiedermann 2012-03-30 09:07:56 EDT
Description of problem:
When setting krb5realm in authconfig, it prints this traceback:

# authconfig --update --nostart --krb5realm=REALM1.COM

Traceback (most recent call last):
  File "/usr/sbin/authconfig", line 926, in <module>
    sys.exit(module.run())
  File "/usr/sbin/authconfig", line 521, in run
    self.writeAuthInfo()
  File "/usr/sbin/authconfig", line 488, in writeAuthInfo
    if not self.info.writeChanged(self.pristineinfo):
  File "/usr/share/authconfig/authinfo.py", line 3531, in writeChanged
    ret = ret and group.saveFunction()
  File "/usr/share/authconfig/authinfo.py", line 2882, in writeSSSD
    self.sssdConfig.save_domain(domain)
  File "/usr/lib/python2.6/site-packages/SSSDConfig.py", line 1969, in save_domain
    self.delete_option_subtree(section_subtree['values'], 'option', option['name'], True)
KeyError: 'values'

# echo $?
1

Version-Release number of selected component (if applicable):
authconfig-6.1.12-6.el6

How reproducible:
100%

Steps to Reproduce:
1. authconfig --update --nostart --krb5realm=REALM1.COM
2.
3.
  
Actual results:
Traceback as above, krb5.conf is updated with realm1.com

Expected results:
No ouput on stdout

# echo $?
0

Properly updated krb5.conf

Additional info:
Comment 2 Tomas Mraz 2012-03-30 14:21:05 EDT
Does it happen if you downgrade authconfig to 6.1.12-5.el6 version?

What sssd package version do you have on the system?
Comment 6 Stephen Gallagher 2012-04-05 10:48:47 EDT
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1291
Comment 7 Stephen Gallagher 2012-04-05 10:50:07 EDT
Looks like we regressed this while we were fixing the crash from BZ #768935

We'll get this addressed immediately.
Comment 11 Stephen Gallagher 2012-04-10 12:51:09 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No technical note required
Comment 12 Kaushik Banerjee 2012-04-26 03:59:20 EDT
# authconfig --update --nostart --krb5realm=REALM1.COM
# echo $?
0


# rpm -qi sssd | head
Name        : sssd                         Relocations: (not relocatable)
Version     : 1.8.0                             Vendor: Red Hat, Inc.
Release     : 23.el6                        Build Date: Fri 20 Apr 2012 11:30:39 PM IST
Install Date: Wed 25 Apr 2012 07:28:48 PM IST      Build Host: x86-003.build.bos.redhat.com
Group       : Applications/System           Source RPM: sssd-1.8.0-23.el6.src.rpm
Size        : 7874744                          License: GPLv3+
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://fedorahosted.org/sssd/
Summary     : System Security Services Daemon
Comment 14 errata-xmlrpc 2012-06-20 07:56:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0747.html

Note You need to log in before you can comment on or make changes to this bug.