Bug 768935 - Crash when apply settings
Crash when apply settings
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.2
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Stephen Gallagher
IDM QE LIST
:
Depends On: 752495
Blocks: 808458
  Show dependency treegraph
 
Reported: 2011-12-19 08:18 EST by Stephen Gallagher
Modified: 2012-06-20 07:50 EDT (History)
11 users (show)

See Also:
Fixed In Version: sssd-1.8.0-2.el6.beta2
Doc Type: Bug Fix
Doc Text:
Cause: A bug in the SSSD configuration parser crashed the parser library when an old SSSD configuration domain was removed and a new one was saved Consequence: Applications that use the configuration parser such as authconfig would crash Fix: Removing old configuration domains and saving new ones was fixed on the SSSD configuration parser Result: Tools that use the configuration parser such as authconfig work fine now
Story Points: ---
Clone Of: 752495
Environment:
Last Closed: 2012-06-20 07:50:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2011-12-19 08:18:15 EST
+++ This bug was initially created as a clone of Bug #752495 +++

Description of problem:

Whenever I click on the apply button, the dialog crashes, my settings are not saved.


Version-Release number of selected component (if applicable):

authconfig-gtk-6.1.16-1.fc16.x86_64

How reproducible:

100%

Steps to Reproduce:
1. system-config-gtk
2. set some parameters, such as an LDAP configuration
3. click apply
  
Actual results:

[root@briemersw sssd]# system-config-authentication 
Traceback (most recent call last):
  File "/usr/sbin/system-config-authentication", line 701, in <module>
    module.apply()
  File "/usr/sbin/system-config-authentication", line 650, in apply
    self.info.writeChanged(self.pristineinfo)
  File "/usr/share/authconfig/authinfo.py", line 3632, in writeChanged
    ret = ret and group.saveFunction()
  File "/usr/share/authconfig/authinfo.py", line 2974, in writeSSSD
    self.sssdConfig.save_domain(domain)
  File "/usr/lib/python2.7/site-packages/SSSDConfig.py", line 1765, in save_domain
    self.delete_option_subtree(section_subtree, 'option', option['name'], True)
  File "/usr/lib/python2.7/site-packages/ipachangeconf.py", line 559, in delete_option_subtree
    index, item = self.findOpts(subtree, type, name, exclude_sections)
  File "/usr/lib/python2.7/site-packages/ipachangeconf.py", line 201, in findOpts
    if o['type'] == type and o['name'] == name:
TypeError: 'int' object is not subscriptable


Expected results:

savings are applied

Additional info:

--- Additional comment from tmraz@redhat.com on 2011-11-09 17:17:43 EST ---

I cannot reproduce the problem on my freshly updated Fedora 16 VM. The traceback comes from the SSSD configuration API, reassigning.

--- Additional comment from briemers@redhat.com on 2011-11-09 18:17:23 EST ---

Created attachment 532688 [details]
/etc/sssd/sssd.conf causing the error

It looks like the code that is reporting the error is designed to remove unrecognised options from the config file.   I do not know which option it is causing the problem.   Based on the idea that it works with a fresh install, I replaced this file with the fresh install file and reconfigured from scratch.

--- Additional comment from tmraz@redhat.com on 2011-11-10 05:14:12 EST ---

*** Bug 752741 has been marked as a duplicate of this bug. ***

--- Additional comment from jhrozek@redhat.com on 2011-11-10 07:08:26 EST ---

Upstream ticket:
https://fedorahosted.org/sssd/ticket/1082

--- Additional comment from jon+bugzilla.redhat.com@alcopop.org on 2011-11-10 09:35:34 EST ---

In my case (merged bug 752741) this was a pristine F16 install and no custom sssd.conf.
Comment 3 Jakub Hrozek 2012-04-03 14:01:06 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: A bug in the SSSD configuration parser crashed the parser library when an old SSSD configuration domain was removed and a new one was saved

Consequence: Applications that use the configuration parser such as authconfig would crash

Fix: Removing old configuration domains and saving new ones was fixed on the SSSD configuration parser

Result: Tools that use the configuration parser such as authconfig work fine now
Comment 4 Kaushik Banerjee 2012-04-26 01:54:16 EDT
Deleted older domains from sssd.conf and updated ldap configuration from system-config-authentication.

# system-config-authentication
Starting sssd:                                             [  OK  ]


Verified in version:
# rpm -qi sssd | head
Name        : sssd                         Relocations: (not relocatable)
Version     : 1.8.0                             Vendor: Red Hat, Inc.
Release     : 23.el6                        Build Date: Fri 20 Apr 2012 11:30:39 PM IST
Install Date: Wed 25 Apr 2012 07:28:48 PM IST      Build Host: x86-003.build.bos.redhat.com
Group       : Applications/System           Source RPM: sssd-1.8.0-23.el6.src.rpm
Size        : 7874744                          License: GPLv3+
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://fedorahosted.org/sssd/
Summary     : System Security Services Daemon
Comment 6 errata-xmlrpc 2012-06-20 07:50:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0747.html

Note You need to log in before you can comment on or make changes to this bug.