This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 808499 - dracut: FATAL: Don't know how to handle 'root=anaconda-kickstart'
dracut: FATAL: Don't know how to handle 'root=anaconda-kickstart'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-30 10:39 EDT by Martin Krizek
Modified: 2012-04-11 13:22 EDT (History)
17 users (show)

See Also:
Fixed In Version: anaconda-17.20-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-06 00:29:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Krizek 2012-03-30 10:39:20 EDT
Description of problem:
After runnning preupgrade on fully updated F16, rebooting into the new system from grub fails with

dracut: FATAL: Don't know how to handle 'root=anaconda-kickstart'

and resulting in Kernel panic

Version-Release number of selected component (if applicable):
anaconda-17.16-1.fc17
preupgrade run from F16: preupgrade-1.1.10-1.fc16


How reproducible:
Always

Steps to Reproduce:
1. Run preupgrade
2. Reboot
3. Boot "Upgrade to Fedora 17 (Beefy Miracle)" from grub menu
  
Actual results:
Fails with dracut: FATAL: Don't know how to handle 'root=anaconda-kickstart'.

Expected results:
System is upgraded.

Additional info:
Tested in KVM using virt-manager, libvirt.
Comment 1 Martin Krizek 2012-03-30 10:42:20 EDT
Proposing as Beta blocker per criterion: "The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria".
Comment 2 Adam Williamson 2012-03-30 14:25:17 EDT
Discussed during 2012-03-30 blocker review meeting. Accepted as blocker per criterion cited in comment #1.

I tested and reproduced this. bcl thinks it's due to "the kickstart parsing rewriting root=". Seems a good supposition, because there is no root= in the cmdline written by preupgrade, it is:

linux /upgrade/vmlinuz preupgrade repo=hd::/var/cache/yum/preupgrade ks=hd:UUID=blahblah:/upgrade/ks.cfg stage2=hd:UUID=blahblah:/upgrade/squashfs.img initrd /upgrade/initrd.img

note that there's no UUID= in the 'repo=' parameter. There are two colons, indicating something was maybe supposed to go between them. Seems like that may be a bug somewhere.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Adam Williamson 2012-03-30 15:19:50 EDT
Discussed at 2012-03-30 blocker review meeting. Accepted as a blocker per criterion cited in comment #1. We need to determine if the bug here is in preupgrade or anaconda to know whether we should block the RC3 compose for it; if anyone is prepared to decide that, please let us know :)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Williamson 2012-03-30 16:06:06 EDT
for now, bcl says anaconda.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Will Woods 2012-04-02 13:49:20 EDT
"hd::".. is a special preupgrade-only notation for "the disk device we're upgrading from", so that's legit. Digging deeper now.
Comment 6 Will Woods 2012-04-02 23:44:12 EDT
Actually this turns out to be pretty straightforward: we didn't support stage2= like we used to. Patches will be along soon.
Comment 7 Fedora Update System 2012-04-03 20:26:36 EDT
anaconda-17.17-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.17-1.fc17
Comment 8 Hongqing Yang 2012-04-05 02:07:11 EDT
reproduced with F17 Beta RC3
Comment 9 Adam Williamson 2012-04-05 05:02:36 EDT
Not reproduced here, but I hit another failure. https://bugzilla.redhat.com/show_bug.cgi?id=810136



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Martin Krizek 2012-04-05 07:06:08 EDT
Same here, this one seems to be fixed, but I hit #810136.
Comment 11 Fedora Update System 2012-04-05 14:27:36 EDT
Package anaconda-17.17-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.17-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5388/anaconda-17.17-1.fc17
then log in and leave karma (feedback).
Comment 12 nneul 2012-04-05 14:33:35 EDT
When should this be available in preupgrade from fc16?
Comment 13 Adam Williamson 2012-04-06 00:29:13 EDT
OK, further testing verifies that this is resolved, and the remaining bugs are 810005 and 810136.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Fedora Update System 2012-04-06 09:58:49 EDT
anaconda-17.19-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.19-1.fc17
Comment 15 Fedora Update System 2012-04-10 00:14:47 EDT
anaconda-17.20-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.20-1.fc17
Comment 16 Fedora Update System 2012-04-11 13:22:41 EDT
anaconda-17.20-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.