Bug 808550 - [abrt] kernel: [309640.801334] BUG: unable to handle kernel NULL pointer dereference at 0000000000000021
[abrt] kernel: [309640.801334] BUG: unable to handle kernel NULL pointer dere...
Status: CLOSED DUPLICATE of bug 806033
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:1ee88709f7b1ab9f09ff747eabc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 13:00 EDT by justin
Modified: 2012-04-02 11:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 11:37:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description justin 2012-03-30 13:00:34 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.3.0-4.fc16.x86_64 root=UUID=4ac798d0-fd00-44a4-a9c8-03ee03d765c6 ro rd.md=0 rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8
kernel:         3.3.0-4.fc16.x86_64
reason:         [309640.801334] BUG: unable to handle kernel NULL pointer dereference at 0000000000000021
time:           Fri 30 Mar 2012 12:25:35 AM PDT

backtrace:
:[309640.801334] BUG: unable to handle kernel NULL pointer dereference at 0000000000000021
:[309640.801380] IP: [<ffffffffa0492290>] hci_conn_hash_flush+0x90/0xf0 [bluetooth]
:[309640.801424] PGD 0 
:[309640.801438] Oops: 0000 [#1] SMP 
:[309640.801458] CPU 2 
:[309640.801468] Modules linked in: tcp_lp tun vmnet(O) vmblock(O) vsock(O) vmci(O) vmmon(O) fuse be2iscsi iscsi_boot_sysfs bnx2i 8021q fcoe garp stp cnic llc uio cxgb4i cxgb4 cxgb3i libfcoe libcxgbi libfc scsi_transport_fc scsi_tgt lockd cxgb3 mdio rfcomm ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi bnep nf_conntrack_ipv4 ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter nf_defrag_ipv4 xt_state nf_conntrack ip6_tables binfmt_misc snd_hda_codec_hdmi snd_hda_codec_idt arc4 snd_hda_intel btusb bluetooth iwlwifi mac80211 snd_hda_codec cfg80211 uvcvideo videobuf2_core videodev media snd_hwdep snd_seq microcode v4l2_compat_ioctl32 snd_seq_device snd_pcm ppdev snd_timer snd soundcore iTCO_wdt dell_laptop parport_pc i2c_i801 e1000e snd_page_alloc iTCO_vendor_support parport dell_wmi rfkill videobuf2_vmalloc dcdbas videobuf2_memops joydev sparse_keymap sunrpc uinput sdhci_pci sdhci mmc_core nouveau ttm drm_kms_helpe
:r drm i2c_core mxm_wmi video wmi [last unloaded: scsi_wait_scan]
:[309640.802109] 
:[309640.802119] Pid: 1051, comm: bluetoothd Tainted: G        W  O 3.3.0-4.fc16.x86_64 #1 Dell Inc. Latitude E6420/032T9K
:[309640.802170] RIP: 0010:[<ffffffffa0492290>]  [<ffffffffa0492290>] hci_conn_hash_flush+0x90/0xf0 [bluetooth]
:[309640.802219] RSP: 0018:ffff88021f459d68  EFLAGS: 00010282
:[309640.802243] RAX: 0000000000000000 RBX: 0000000000000000 RCX: 000000018200017b
:[309640.802273] RDX: 000000018200017c RSI: ffffea000882cc80 RDI: ffffffffa01fb8c0
:[309640.802303] RBP: ffff88021f459d88 R08: ffff880220b328c0 R09: 000000018200017b
:[309640.802334] R10: 0000000020b32901 R11: 0000000000000000 R12: ffff88021e4ea638
:[309640.802364] R13: ffff88021e4ea5d0 R14: ffff88021f3ac030 R15: 0000000000000010
:[309640.802394] FS:  00007f79a8a52700(0000) GS:ffff88022dc40000(0000) knlGS:0000000000000000
:[309640.802428] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
:[309640.802452] CR2: 0000000000000021 CR3: 000000021f401000 CR4: 00000000000406e0
:[309640.802482] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:[309640.802513] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:[309640.802543] Process bluetoothd (pid: 1051, threadinfo ffff88021f458000, task ffff880218600000)
:[309640.802578] Stack:
:[309640.802588]  ffff88021f459d88 0000000000000000 ffff88021e4ea000 ffff88021e4ea010
:[309640.802630]  ffff88021f459db8 ffffffffa048cb9b ffff88021e4ea000 0000000000000000
:[309640.802672]  ffff88022014dc00 ffff88021f3ac030 ffff88021f459dd8 ffffffffa048e75d
:[309640.802713] Call Trace:
:[309640.802734]  [<ffffffffa048cb9b>] hci_dev_do_close+0xbb/0x310 [bluetooth]
:[309640.802769]  [<ffffffffa048e75d>] hci_dev_close+0x2d/0x70 [bluetooth]
:[309640.802804]  [<ffffffffa049f69a>] hci_sock_ioctl+0x1aa/0x3f0 [bluetooth]
:[309640.802835]  [<ffffffff814cdd50>] sock_do_ioctl+0x30/0x70
:[309640.802860]  [<ffffffff814cee09>] sock_ioctl+0x79/0x2f0
:[309640.802885]  [<ffffffff81193498>] do_vfs_ioctl+0x98/0x550
:[309640.802910]  [<ffffffff811939e1>] sys_ioctl+0x91/0xa0
:[309640.802934]  [<ffffffff815fc029>] system_call_fastpath+0x16/0x1b
:[309640.802959] Code: 60 04 00 00 48 85 c0 74 0a be 16 00 00 00 48 89 df ff d0 48 89 df e8 10 fd ff ff 48 8b 03 48 89 45 e8 48 8b 5d e8 49 39 dc 74 30 <0f> b6 53 21 66 c7 43 1e 09 00 80 fa 01 74 11 73 9f be 16 00 00 
:[309640.803210] RIP  [<ffffffffa0492290>] hci_conn_hash_flush+0x90/0xf0 [bluetooth]
:[309640.803249]  RSP <ffff88021f459d68>
:[309640.804654] CR2: 0000000000000021
:[309640.806171] ---[ end trace 5dab865b1d8d4c79 ]---

smolt_data:
:
:
:General
:=================================
:UUID: 67790b9d-252f-46cf-9674-745845d37b7d
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4390.41
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 8
:CPU Speed: 2194
:System Memory: 7943
:System Swap: 7999
:Vendor: Dell Inc.
:System: Latitude E6420 01
:Form factor: Laptop
:Kernel: 3.3.0-4.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7247:4136:1171) pci, None, PCI/ISA, QM67 Express Chipset Family LPC Controller
:(4631:33313:4136:1171) pci, sdhci-pci, BASE, N/A
:(4631:33329:4136:1171) pci, None, STORAGE, N/A
:(32902:7188:4136:1171) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 3
:(32902:7190:4136:1171) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:4136:1171) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:4136:1171) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(4318:4182:4136:1171) pci, nouveau, VIDEO, GF108 [Quadro NVS 4200M]
:(32902:7200:4136:1171) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:5378:4136:1171) pci, e1000e, ETHERNET, 82579LM Gigabit Network Connection
:(32902:7202:4136:1171) pci, None, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:16939:32902:4385) pci, iwlwifi, NETWORK, Centrino Ultimate-N 6300 3x3 AGN
:(32902:10282:4136:1171) pci, ahci, RAID, Mobile 82801 SATA RAID Controller
:(32902:7213:4136:1171) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:4136:1171) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:4136:1171) pci, None, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:4136:1171) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(4318:3592:4136:1171) pci, snd_hda_intel, MULTIMEDIA, HDMI Audio stub
:(32902:7194:4136:1171) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 6
:(32902:257:4136:1171) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 74998368 6181859 5431367 18767872 18630813 18630813
:/dev/sr0 WITHHELD udf 2048 2048 4039951 0 0 23 0 0
:
Comment 1 Dave Jones 2012-04-02 11:37:45 EDT

*** This bug has been marked as a duplicate of bug 806033 ***

Note You need to log in before you can comment on or make changes to this bug.