Bug 806033 (hci_conn_hash_flush) - BUG: unable to handle kernel NULL pointer dereference at 0000000000000038 hci_conn_hash_flush
Summary: BUG: unable to handle kernel NULL pointer dereference at 0000000000000038 hci...
Keywords:
Status: CLOSED ERRATA
Alias: hci_conn_hash_flush
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f452d21acfd27b6d27acc08e391...
: 806243 806259 806389 806390 806391 806436 806455 806520 808533 808550 808593 808995 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-22 17:50 UTC by Renato F
Modified: 2014-09-13 18:56 UTC (History)
13 users (show)

Fixed In Version: kernel-3.3.0-5.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-01 00:26:48 UTC


Attachments (Terms of Use)

Description Renato F 2012-03-22 17:50:28 UTC
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.3.0-4.fc16.x86_64 root=UUID=81813a4e-7a75-41c2-9d31-669ea6524815 ro rd.md=0 rd.lvm=0 rd.dm=0 quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 KEYTABLE=us-acentos LANG=en_US.UTF-8 i915.modeset=1 modeset=1
kernel:         3.3.0-4.fc16.x86_64
reason:         BUG: unable to handle kernel NULL pointer dereference at 0000000000000038
time:           Thu 22 Mar 2012 02:45:40 PM BRT

backtrace:
:BUG: unable to handle kernel NULL pointer dereference at 0000000000000038
:IP: [<0000000000000038>] 0x37
:PGD 0 
:Oops: 0010 [#1] SMP 
:CPU 4 
:Modules linked in: ppdev parport_pc lp parport lockd rfcomm fcoe libfcoe libfc scsi_transport_fc scsi_tgt 8021q garp stp llc bnep be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi binfmt_misc snd_hda_codec_hdmi snd_hda_codec_realtek arc4 rtl8192ce rtl8192c_common rtlwifi mac80211 cfg80211 snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd btusb bluetooth sunrpc soundcore iTCO_wdt snd_page_alloc rfkill uvcvideo uinput iTCO_vendor_support i2c_i801 joydev jme mii videobuf2_core videodev media v4l2_compat_ioctl32 videobuf2_vmalloc videobuf2_memops jmb38x_ms memstick serio_raw microcode sdhci_pci sdhci mmc_core wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 46, comm: khubd Tainted: G           O 3.3.0-4.fc16.x86_64 #1 CLEVO CO.                        W150HNM/W170HN                  /W150HNM/W170HN                  
:RIP: 0010:[<0000000000000038>]  [<0000000000000038>] 0x37
:RSP: 0018:ffff8802334c7b78  EFLAGS: 00010202
:RAX: 0000000000000038 RBX: ffff88022fb05000 RCX: 000000000000033c
:RDX: 0000000000000000 RSI: 0000000000000016 RDI: ffff88022fb05000
:RBP: ffff8802334c7ba0 R08: 0000000000016440 R09: ffffea0008cef080
:R10: ffffffff812c2d35 R11: 0000000000000000 R12: ffff88023026d638
:R13: ffff88023026d5d0 R14: ffff88022ed4f000 R15: 0000000000000000
:FS:  0000000000000000(0000) GS:ffff88023f500000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
:CR2: 0000000000000038 CR3: 0000000231657000 CR4: 00000000000406e0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process khubd (pid: 46, threadinfo ffff8802334c6000, task ffff880233b7dcc0)
:Stack:
: ffffffffa0218278 ffff8802334c7ba0 ffff88022fb05000 ffff88023026d000
: ffff88023026d010 ffff8802334c7bd0 ffffffffa0212b9b ffff88023026d000
: 0000000000000000 ffff88023026d000 ffff88022ed4f000 ffff8802334c7bf0
:Call Trace:
: [<ffffffffa0218278>] ? hci_conn_hash_flush+0x78/0xf0 [bluetooth]
: [<ffffffffa0212b9b>] hci_dev_do_close+0xbb/0x310 [bluetooth]
: [<ffffffffa0215b46>] hci_unregister_dev+0x46/0x180 [bluetooth]
: [<ffffffffa01fe95d>] btusb_disconnect+0x6d/0xf0 [btusb]
: [<ffffffff8141c0a2>] usb_unbind_interface+0x52/0x180
: [<ffffffff813a151c>] __device_release_driver+0x7c/0xe0
: [<ffffffff813a15ac>] device_release_driver+0x2c/0x40
: [<ffffffff813a0fc3>] bus_remove_device+0xe3/0x150
: [<ffffffff8139dd10>] device_del+0x120/0x1a0
: [<ffffffff81419cb0>] usb_disable_device+0xb0/0x250
: [<ffffffff81410db5>] usb_disconnect+0xa5/0x160
: [<ffffffff81413596>] hub_thread+0xa16/0x16a0
: [<ffffffff8107a6d0>] ? remove_wait_queue+0x50/0x50
: [<ffffffff81412b80>] ? usb_remote_wakeup+0x70/0x70
: [<ffffffff81079c83>] kthread+0x93/0xa0
: [<ffffffff815fd3e4>] kernel_thread_helper+0x4/0x10
: [<ffffffff81079bf0>] ? kthread_freezable_should_stop+0x70/0x70
: [<ffffffff815fd3e0>] ? gs_change+0x13/0x13
:Code:  Bad RIP value.
:RIP  [<0000000000000038>] 0x37
: RSP <ffff8802334c7b78>
:CR2: 0000000000000038

comment:
:I was connecting my bluetooth mouse through kde bluedevil. 
:Notice: The bluetooth mouse was working fine with 3.2.9 and stopped working on 3.3.0

Comment 1 Dave Jones 2012-03-23 14:48:47 UTC
*** Bug 806243 has been marked as a duplicate of this bug. ***

Comment 2 Dave Jones 2012-03-23 14:51:53 UTC
*** Bug 806259 has been marked as a duplicate of this bug. ***

Comment 3 Dave Jones 2012-03-23 16:36:48 UTC
*** Bug 806390 has been marked as a duplicate of this bug. ***

Comment 4 Dave Jones 2012-03-23 16:37:06 UTC
*** Bug 806389 has been marked as a duplicate of this bug. ***

Comment 5 Dave Jones 2012-03-23 16:37:24 UTC
*** Bug 806391 has been marked as a duplicate of this bug. ***

Comment 6 Dave Jones 2012-03-23 18:03:53 UTC
merged two patches that should solve this for the next build.

Comment 7 Dave Jones 2012-03-23 18:04:33 UTC
*** Bug 806436 has been marked as a duplicate of this bug. ***

Comment 8 Dave Jones 2012-03-23 20:24:12 UTC
*** Bug 806455 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2012-03-26 13:40:33 UTC
kernel-3.3.0-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.0-5.fc17

Comment 10 Dave Jones 2012-03-26 15:53:31 UTC
*** Bug 806520 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2012-03-28 05:54:32 UTC
Package kernel-3.3.0-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.3.0-5.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4761/kernel-3.3.0-5.fc17
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2012-03-29 23:08:50 UTC
kernel-3.3.0-8.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.3.0-8.fc16

Comment 13 Fedora Update System 2012-04-01 00:26:48 UTC
kernel-3.3.0-8.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Dave Jones 2012-04-02 14:44:29 UTC
*** Bug 808593 has been marked as a duplicate of this bug. ***

Comment 15 Dave Jones 2012-04-02 15:37:21 UTC
*** Bug 808533 has been marked as a duplicate of this bug. ***

Comment 16 Dave Jones 2012-04-02 15:37:45 UTC
*** Bug 808550 has been marked as a duplicate of this bug. ***

Comment 17 Dave Jones 2012-04-02 17:05:28 UTC
*** Bug 808995 has been marked as a duplicate of this bug. ***

Comment 18 Fedora Update System 2012-04-12 02:01:14 UTC
kernel-3.3.0-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.