Bug 808559 - regression: upgrading to 3.3.0-[4,8] killed my sound
regression: upgrading to 3.3.0-[4,8] killed my sound
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 808756 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 13:33 EDT by Gabriel Somlo
Modified: 2012-04-27 11:04 EDT (History)
14 users (show)

See Also:
Fixed In Version: kernel-2.6.43.2-6.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-24 00:28:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info collected while running kernel 3.2.9-2 with model=imac24 and working sound (33.99 KB, text/plain)
2012-03-30 13:33 EDT, Gabriel Somlo
no flags Details

  None (edit)
Description Gabriel Somlo 2012-03-30 13:33:56 EDT
Created attachment 574046 [details]
alsa-info collected while running kernel 3.2.9-2 with model=imac24 and working sound

Description of problem:
Sound no longer works after upgrading from 3.2.9.2 to 3.3.0-4

Version-Release number of selected component (if applicable):
3.3.0-4.fc16.x86_64

How reproducible:
On my system, sound works when booted into 3.2.9-2.fc16.x86_64, but not when
using the (currently) latest 3.3.0-4.fc16.x86_64

Steps to Reproduce:
1. Boot machine into (currently) latest kernel 3.3.0-4.fc16.x86_64
2. Play something (e.g. using flac123 or ogg123)
  
Actual results:
silence (pavucontrol shows a pulsating "vu-meter" bar, but no sound is output

Expected results:
music should be playing like it used to with the earlier kernel

Additional info:

I'm on a MacPro5,1, and so far I could only get sound by explicitly setting the
model in /etc/modprobe.d/sound.conf:

options snd_hda_intel model=imac24

(imac24 is the only thing that appeared to work reliably after a rather exhaustive search I did earlier, in the F-14 days).

This stopped working after the 3.3.0-4 upgrade, and nothing I did (i.e., trying
alternate mac models for snd_hda_intel, or simply leaving it to autodetect)
seems to help anymore.

Please see the attached alsa-info output.

Thanks,
--Gabriel
Comment 1 Neil Horman 2012-03-30 14:09:31 EDT
no to be a "me too-er", but me too.  I've got a HP whitebox PC here using snd-hda-intel and sound is gone on 3.3.0-4.  I've done a bit of debugging, and pulseaudio starts fine, appears to find the sound device in /dev/snd/ properly, and streams data to it, but no noise on the speakers.  Its rather like the snd_hda_intel driver is just dropping everything, but I can't say that definitively.  I can test kernels or provide more info if anything is needed.
Comment 2 bug-zilla 2012-03-31 04:22:26 EDT
I have the same problem on desktop PC.
I noticed that "amixer -c 0 scontrols" on 3.3.0-4 doesn't show simple control 'CD'. On kernel 3.2.10 everything is OK and 'CD' is visible.

My sound car is on-board Realtek ALC883.
lspci shows "Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)"

An the same troubles on fully updated today F17 Alpha on kernel 3.3.0-8.

Can I help something? Any logs or so...
Comment 3 Paul Gier 2012-04-03 11:46:31 EDT
I'm using thinkpad t510 laptop with Fedora 16.  Audio output works fine, but audio input is not working in the 3.3 kernel.  If I boot into 3.2.10 kernel, audio input works fine again.
Comment 4 Nick Scavelli 2012-04-03 15:58:53 EDT
+1 to Paul's comment. Any updates here guys ?
Comment 5 Nick Scavelli 2012-04-03 16:33:10 EDT
Referencing the bug I opened when I initially thought it was both output and input: https://bugzilla.redhat.com/show_bug.cgi?id=808756
Comment 6 Gabriel Somlo 2012-04-04 09:22:11 EDT
Problem persists on 3.3.0-8
Comment 7 acidjunkie 2012-04-05 13:54:22 EDT
Same problem here. Kernel 3.3-X sound not working, Kernel 3.2-X sound is working.
Using Lenovo Thinkpad T410 with Fedora FC16 x86_64.

I once booted into 3.3.0-8 and surprisingly had sound. After some updates and a reboot there was again no sound.
The only updated package which may has influence to sound/kernel/chipset stuff is kmod-nivdia-3.3.0-8.fc16.x86_64.

I tried a lot but running out of ideas. Kernel 3.2 has an ugly but so I prefer using 3.3 with sound.
Comment 8 Nick Scavelli 2012-04-05 17:10:02 EDT
Booting into 3.3.0-8 I also have no output on top of input not working from 3.3.0-4. Not the right direction I was hoping for, but at least some consistency as sound is completely broken instead of 1/2 way broken...
Comment 9 acidjunkie 2012-04-07 20:33:59 EDT
Problem still appears with 3.3.1-2.fc16 x86_64.
Comment 10 acidjunkie 2012-04-09 14:02:16 EDT
Somehow with Kernel 3.3 the way the Intel kernel module options are set changed.

I fixed my problem by adding this line to /etc/modprobe.d/dist-alsa.conf
options snd-hda-intel model=thinkpad enable=1 index=0
Comment 11 Gabriel Somlo 2012-04-09 20:33:18 EDT
Still a problem in 3.3.1-3.fc16.x86_64;

> I fixed my problem by adding this line to /etc/modprobe.d/dist-alsa.conf
> options snd-hda-intel model=thinkpad enable=1 index=0

The problem is with how the "flavor" of your snd_hda_intel chip is auto-detected. It never worked well on my Mac Pro, even back in the 3.2.X days. Luckily, there was a similar enough chipset I could manually force (model=imac24) that worked well enough.

With the upgrade to 3.3.* that workaround no longer helps, and autodetect is stil borked :(
Comment 12 Nick Scavelli 2012-04-11 18:36:04 EDT
(In reply to comment #10)
> Somehow with Kernel 3.3 the way the Intel kernel module options are set
> changed.
> 
> I fixed my problem by adding this line to /etc/modprobe.d/dist-alsa.conf
> options snd-hda-intel model=thinkpad enable=1 index=0

This does fix my issue (thinkpad t510). However I don't think the solution should be to have to modify this file when it used to work OOTB with Kernel 3.2. Any update on what and why this was changed ? And when it will be changed back ?
Comment 13 Josh Boyer 2012-04-11 18:54:51 EDT
*** Bug 808756 has been marked as a duplicate of this bug. ***
Comment 14 Josh Boyer 2012-04-11 18:55:56 EDT
For a thinkpad 510, it seems commit 29c5fbbcfefba5225a6783683c46c39e10877703:

    ALSA: HDA: Use model=auto for Thinkpad T510
    
    The user reports that model=auto works fine for him. Using
    model=auto bring in new features such as jack detection notification
    to userspace.
    
    Alsa info is available at http://paste.ubuntu.com/805351/

changed to using model=auto for that machine.  That is probably what caused a regression on that particular model.

I'll try to get a kernel built with that reverted for testing later this evening.
Comment 15 Josh Boyer 2012-04-11 21:05:22 EDT
OK, the following scratch build has two changes in it:

1) Reverts the commit I mentioned above
2) Adds a quirk for the PCI device id found on the MacPro 5,1 machine reported in the initial comment.

So once it completes, please test.  Even if you don't have a MacPro 5,1 or a thinkpad, it might be worth testing.  We can address additional machines as we go forward.

http://koji.fedoraproject.org/koji/taskinfo?taskID=3981036
Comment 16 Gabriel Somlo 2012-04-12 11:53:59 EDT
(In reply to comment #15)
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3981036

Works great on the MacPro5,1 -- many thanks for the fix !!!
Comment 17 Claudio Saavedra 2012-04-13 02:55:20 EDT
This also seems to fix https://bugzilla.redhat.com/show_bug.cgi?id=810697
Comment 18 Josh Boyer 2012-04-13 08:44:15 EDT
I've emailed upstream about both problems.  The first patch to get sound working on the MacPro 5,1 was accepted.  We'll see what we can do about the thinkpads.
Comment 19 Josh Boyer 2012-04-13 09:19:07 EDT
Nick and Paul, could you please attach the output of alsa-info for your t510 machines?
Comment 20 Josh Boyer 2012-04-13 15:21:55 EDT
For those with the thinkpad issues, there is a new scratch kernel to test when it completes building:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3989218
Comment 21 Nick Scavelli 2012-04-13 19:06:57 EDT
(In reply to comment #19)
> Nick and Paul, could you please attach the output of alsa-info for your t510
> machines?

http://www.alsa-project.org/db/?f=a78c0ce9231934b05f21b56988f323eee5c41732
Comment 23 Kevin Fenzi 2012-04-17 20:01:09 EDT
I have a t510, and had no sound with kernel-3.3.2-1.fc17.x86_64 at least. 

With the scratch from comment 20 sound is back and working, so this may be affecting f17 as well, at least it did here.
Comment 24 Nick Scavelli 2012-04-18 22:51:50 EDT
(In reply to comment #20)
> For those with the thinkpad issues, there is a new scratch kernel to test when
> it completes building:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3989218

The scratch kernel worked and so does 3.3.1-5 for my t510.
Comment 25 Josh Boyer 2012-04-19 09:56:24 EDT
(In reply to comment #24)
> (In reply to comment #20)
> > For those with the thinkpad issues, there is a new scratch kernel to test when
> > it completes building:
> > 
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=3989218
> 
> The scratch kernel worked and so does 3.3.1-5 for my t510.

Erm... 3.3.1-5 doesn't have any patches that would fix the issues included.  Do you still have the workaround from comment #12 applied on your machine?  If so, testing the scratch kernel without that present would be appreciated.
Comment 26 Gabriel Somlo 2012-04-19 10:58:49 EDT
Looks like the MacPro 5,1 patch didn't make it into 3.3.2-1.fc16.x86_64...
Comment 27 Josh Boyer 2012-04-19 11:11:35 EDT
(In reply to comment #26)
> Looks like the MacPro 5,1 patch didn't make it into 3.3.2-1.fc16.x86_64...

No, it didn't.  I had planned to get it into the next update, but there were a large number of ath9k bugs that we needed to get fixed in the 3.3.2-1 build.  It will be in the next submitted update.  Bodhi will leave a comment here when it is pushed.
Comment 28 Nick Scavelli 2012-04-19 12:03:44 EDT
> Erm... 3.3.1-5 doesn't have any patches that would fix the issues included.  Do
> you still have the workaround from comment #12 applied on your machine?  If so,
> testing the scratch kernel without that present would be appreciated.

My apologies, didn't know the workaround would still be picked up if I renamed the file in /etc/modprobe.d. 

The scratch kernel did not appear to fix my internal mic. I will also add that output does not work after hooking it up to my docking station, I may re-open https://bugzilla.redhat.com/show_bug.cgi?id=808756 to specify this more clearly.
Comment 29 Josh Boyer 2012-04-19 14:37:32 EDT
(In reply to comment #28)
> The scratch kernel did not appear to fix my internal mic. I will also add that
> output does not work after hooking it up to my docking station, I may re-open
> https://bugzilla.redhat.com/show_bug.cgi?id=808756 to specify this more
> clearly.

The scratch kernel from comment #20 worked for another t510 user.  You might have to manually adjust the new mixer mute and volume settings one time.
Comment 30 Fedora Update System 2012-04-21 11:21:47 EDT
kernel-3.3.2-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.2-8.fc17
Comment 31 Fedora Update System 2012-04-21 12:26:34 EDT
kernel-3.3.2-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.3.2-6.fc16
Comment 32 Fedora Update System 2012-04-21 12:46:30 EDT
kernel-2.6.43.2-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.43.2-6.fc15
Comment 33 Fedora Update System 2012-04-21 17:07:28 EDT
Package kernel-3.3.2-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.3.2-8.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6344/kernel-3.3.2-8.fc17
then log in and leave karma (feedback).
Comment 34 Fedora Update System 2012-04-24 00:28:39 EDT
kernel-3.3.2-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 35 Fedora Update System 2012-04-24 10:54:21 EDT
kernel-3.3.2-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 36 acidjunkie 2012-04-25 12:49:17 EDT
I'm sorry but using kernel 3.3.2-6.fc16.x86_64 without the modprobe entry mentioned in comment 10 still results in no sound at all.
Do you need me to provide anything? alsa-info stuff? It is a Lenovo T410 with "Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)"
Comment 37 Josh Boyer 2012-04-25 13:53:39 EDT
(In reply to comment #36)
> I'm sorry but using kernel 3.3.2-6.fc16.x86_64 without the modprobe entry
> mentioned in comment 10 still results in no sound at all.

This bug is a victim of multiple issues being piled into it.  The MacPro 5,1 issue is fixed with that kernel, not the thinkpad one.

> Do you need me to provide anything? alsa-info stuff? It is a Lenovo T410 with
> "Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)"

Yeah, it would be nice if you tested the scratch build kernel in comment #20 without any module options set.
Comment 38 Fedora Update System 2012-04-25 23:27:45 EDT
kernel-2.6.43.2-6.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 39 Nick Scavelli 2012-04-27 10:10:31 EDT
(In reply to comment #29)
> The scratch kernel from comment #20 worked for another t510 user.  You might
> have to manually adjust the new mixer mute and volume settings one time.

The scratch kernel only works when I boot into it from a previous kernel that had the workaround. In other words, if I am booted into a kernel with the workaround, remove the workaround, and boot into the scratch kernel, input works. However if I reboot into another kernel and reboot back into the scratch kernel, input does not work again.

I will also note that output never works in any of these scenarios if I am connected to my docking station.

I think a new bug should be created to track the Thinkpad issues.
Comment 40 Josh Boyer 2012-04-27 11:04:18 EDT
(In reply to comment #39)
> (In reply to comment #29)
> > The scratch kernel from comment #20 worked for another t510 user.  You might
> > have to manually adjust the new mixer mute and volume settings one time.
> 
> The scratch kernel only works when I boot into it from a previous kernel that
> had the workaround. In other words, if I am booted into a kernel with the
> workaround, remove the workaround, and boot into the scratch kernel, input
> works. However if I reboot into another kernel and reboot back into the scratch
> kernel, input does not work again.
> 
> I will also note that output never works in any of these scenarios if I am
> connected to my docking station.
> 
> I think a new bug should be created to track the Thinkpad issues.

OK, please open a new bug.  When you do, please attach the alsa-info of your machine running the scratch kernel both docked and undocked.

Note You need to log in before you can comment on or make changes to this bug.