Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 808687 - RHEV-H 6.3 TUI: /etc/sysconfig/keyboard can't be persist.
Summary: RHEV-H 6.3 TUI: /etc/sysconfig/keyboard can't be persist.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: beta
: 6.3
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-31 08:27 UTC by cshao
Modified: 2016-04-26 15:53 UTC (History)
10 users (show)

Fixed In Version: ovirt-node-2.3.0-3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-19 14:20:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 808709 0 medium CLOSED Non-English keyboard does not work 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2012:0741 0 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2012-07-19 18:10:46 UTC

Internal Links: 808709

Description cshao 2012-03-31 08:27:29 UTC
Description of problem:
/etc/sysconfig/keyboard can't be persist.
# cat /config/files  | grep keyboard
#

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120330.0.el6 

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H and choose "German" keyboard layout as default.
2. Enter keyboard menu, choose "German" keyboard layout and apply.
3. Reboot host.
  
Actual results:
1. Check /etc/sysconfig/keyboard after step 1. Keyboard configure file show "us" as default.
# cat /etc/sysconfig/keyboard 
KEYTABLE="us"
MODEL="pc105+inet"
LAYOUT="us"

2. Check /etc/sysconfig/keyboard after step 2. Keyboard configure file show "de".
# cat /etc/sysconfig/keyboard 
KEYTABLE="de"
MODEL="pc105"
LAYOUT="de"

2. After reboot the host, keyboard configure file show "us" as default.
# cat /etc/sysconfig/keyboard 
KEYTABLE="us"
MODEL="pc105+inet"
LAYOUT="us"

Expected results:
/etc/sysconfig/keyboard can be persist.

Additional info:

Comment 5 Mike Burns 2012-06-13 17:23:57 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, when changing the keyboard, the setting would not persist across reboots.  Now, the change is correctly persisted.

Comment 6 Stephen Gordon 2012-06-14 15:13:17 UTC
Technical note on Bug #808709 adequetely explains the issue I think.

Comment 7 Stephen Gordon 2012-06-14 15:13:17 UTC
Deleted Technical Notes Contents.

Old Contents:
Previously, when changing the keyboard, the setting would not persist across reboots.  Now, the change is correctly persisted.

Comment 9 errata-xmlrpc 2012-07-19 14:20:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html


Note You need to log in before you can comment on or make changes to this bug.