Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 808817 - kdump udev rules 98-kexec.rules still use /etc/init.d/kdump
Summary: kdump udev rules 98-kexec.rules still use /etc/init.d/kdump
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kexec-tools
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Young
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 827152 (view as bug list)
Depends On:
Blocks: 808818
TreeView+ depends on / blocked
 
Reported: 2012-04-01 08:36 UTC by WANG Chao
Modified: 2012-10-07 07:48 UTC (History)
5 users (show)

Fixed In Version: kexec-tools-2.0.3-48
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 808818 (view as bug list)
Environment:
Last Closed: 2012-06-22 08:11:07 UTC
Type: ---


Attachments (Terms of Use)

Description WANG Chao 2012-04-01 08:36:26 UTC
Description of problem:
In 98-kexec.rules, we still use /etc/init.d/kdump to start/restart kdump service, which should be changed to /usr/bin/kdumpctl.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Américo Wang 2012-04-02 08:02:48 UTC
Should use systemctl to control the service, something like below:


diff --git a/98-kexec.rules b/98-kexec.rules
index 8b47671..5f0d56f 100644
--- a/98-kexec.rules
+++ b/98-kexec.rules
@@ -1,4 +1,4 @@
-SUBSYSTEM=="cpu", ACTION=="online", PROGRAM="/etc/init.d/kdump restart"
-SUBSYSTEM=="cpu", ACTION=="offline", PROGRAM="/etc/init.d/kdump restart"
-SUBSYSTEM=="memory", ACTION=="add", PROGRAM="/etc/init.d/kdump restart"
-SUBSYSTEM=="memory", ACTION=="remove", PROGRAM="/etc/init.d/kdump restart"
+SUBSYSTEM=="cpu", ACTION=="online", PROGRAM="/bin/systemctl restart kdump.service"
+SUBSYSTEM=="cpu", ACTION=="offline", PROGRAM="/bin/systemctl restart kdump.service"
+SUBSYSTEM=="memory", ACTION=="add", PROGRAM="/bin/systemctl restart kdump.service"
+SUBSYSTEM=="memory", ACTION=="remove", PROGRAM="/bin/systemctl restart kdump.service"

Comment 2 Fedora Admin XMLRPC Client 2012-04-16 06:12:56 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Dave Young 2012-06-01 01:26:06 UTC
*** Bug 827152 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.