Bug 827152 - /etc/init.d/kdump referenced but doesn't exist
/etc/init.d/kdump referenced but doesn't exist
Status: CLOSED DUPLICATE of bug 808817
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dave Young
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 14:39 EDT by joshua
Modified: 2012-05-31 21:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 21:26:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joshua 2012-05-31 14:39:03 EDT
Description of problem:

/etc/udev/rules.d/98-kexec.rules references /etc/init.d/kdump:

$ cat /etc/udev/rules.d/98-kexec.rules
SUBSYSTEM=="cpu", ACTION=="online", PROGRAM="/etc/init.d/kdump restart"
SUBSYSTEM=="cpu", ACTION=="offline", PROGRAM="/etc/init.d/kdump restart"
SUBSYSTEM=="memory", ACTION=="add", PROGRAM="/etc/init.d/kdump restart"
SUBSYSTEM=="memory", ACTION=="remove", PROGRAM="/etc/init.d/kdump restart"

... yet /etc/init.d/kdump no longer exists.

Can we get "/usr/sbin/service kdump restart" called instead, or similar?




Version-Release number of selected component (if applicable):

kexec-tools-2.0.3-47.fc17.x86_64
Comment 1 Dave Young 2012-05-31 21:25:32 EDT
(In reply to comment #0)
> Description of problem:
> 
> /etc/udev/rules.d/98-kexec.rules references /etc/init.d/kdump:
> 
> $ cat /etc/udev/rules.d/98-kexec.rules
> SUBSYSTEM=="cpu", ACTION=="online", PROGRAM="/etc/init.d/kdump restart"
> SUBSYSTEM=="cpu", ACTION=="offline", PROGRAM="/etc/init.d/kdump restart"
> SUBSYSTEM=="memory", ACTION=="add", PROGRAM="/etc/init.d/kdump restart"
> SUBSYSTEM=="memory", ACTION=="remove", PROGRAM="/etc/init.d/kdump restart"
> 
> ... yet /etc/init.d/kdump no longer exists.
> 
> Can we get "/usr/sbin/service kdump restart" called instead, or similar?
> 
> 
> 
> 
> Version-Release number of selected component (if applicable):
> 
> kexec-tools-2.0.3-47.fc17.x86_64

This is a duplicate of bug 808817, below patch has been commited in rawhide:
---
 98-kexec.rules |    8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

--- kexec-tools.orig/98-kexec.rules	2012-05-24 15:52:11.910081503 +0800
+++ kexec-tools/98-kexec.rules	2012-05-24 15:53:20.346748402 +0800
@@ -1,4 +1,4 @@
-SUBSYSTEM=="cpu", ACTION=="online", PROGRAM="/etc/init.d/kdump restart"
-SUBSYSTEM=="cpu", ACTION=="offline", PROGRAM="/etc/init.d/kdump restart"
-SUBSYSTEM=="memory", ACTION=="add", PROGRAM="/etc/init.d/kdump restart"
-SUBSYSTEM=="memory", ACTION=="remove", PROGRAM="/etc/init.d/kdump restart"
+SUBSYSTEM=="cpu", ACTION=="online", PROGRAM="/bin/systemctl try-restart kdump.service"
+SUBSYSTEM=="cpu", ACTION=="offline", PROGRAM="/bin/systemctl try-restart kdump.service"
+SUBSYSTEM=="memory", ACTION=="add", PROGRAM="/bin/systemctl try-restart kdump.service"
+SUBSYSTEM=="memory", ACTION=="remove", PROGRAM="/bin/systemctl try-restart kdump.service"
Comment 2 Dave Young 2012-05-31 21:26:06 EDT

*** This bug has been marked as a duplicate of bug 808817 ***

Note You need to log in before you can comment on or make changes to this bug.