Bug 808933 - SELinux is preventing /usr/bin/evince from 'write' accesses on the sock_file /home/francisco/.cache/keyring-kb9Cca/pkcs11.
SELinux is preventing /usr/bin/evince from 'write' accesses on the sock_file ...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:66dfc63f9323acb7509eba0ab73...
:
: 827773 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-01 16:30 EDT by Boricua
Modified: 2012-06-04 08:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 14:44:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boricua 2012-04-01 16:30:25 EDT
libreport version: 2.0.10
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-8.fc17.x86_64
time:           Sun 01 Apr 2012 04:29:48 PM AST

description:
:SELinux is preventing /usr/bin/evince from 'write' accesses on the sock_file /home/francisco/.cache/keyring-kb9Cca/pkcs11.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that evince should be allowed write access on the pkcs11 sock_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep evince /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:cache_home_t:s0
:Target Objects                /home/francisco/.cache/keyring-kb9Cca/pkcs11 [
:                              sock_file ]
:Source                        evince
:Source Path                   /usr/bin/evince
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           evince-3.4.0-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-106.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-8.fc17.x86_64 #1 SMP Thu Mar 29
:                              18:18:26 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Sun 01 Apr 2012 04:22:09 PM AST
:Last Seen                     Sun 01 Apr 2012 04:22:09 PM AST
:Local ID                      9a12ed70-b906-43c8-aaa3-5e2450e1a589
:
:Raw Audit Messages
:type=AVC msg=audit(1333311729.395:407): avc:  denied  { write } for  pid=8515 comm="evince" name="pkcs11" dev="dm-3" ino=23201288 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:cache_home_t:s0 tclass=sock_file
:
:
:type=SYSCALL msg=audit(1333311729.395:407): arch=x86_64 syscall=connect success=no exit=EACCES a0=13 a1=7fff6967aa60 a2=6e a3=21 items=0 ppid=1 pid=8515 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=evince exe=/usr/bin/evince subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: evince,mozilla_plugin_t,cache_home_t,sock_file,write
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-04-02 07:17:43 EDT
What are you exactly doing? Are you trying to sign a document or verify signature.
Comment 2 Daniel Walsh 2012-04-02 14:44:22 EDT
This looks like mozplugger.x86_64 is installed.

If you want to use mozplugger, you need to turn off confinement.

setsebool -P unconfined_mozilla_plugin_transition 1

Or you can remove mozplugger

yum remove mozplugger
Comment 3 Boricua 2012-04-02 18:30:49 EDT
(In reply to comment #1)
> What are you exactly doing? Are you trying to sign a document or verify
> signature.

No, I was trying to save a copy of the IRS form after opening it using firefox.

(In reply to comment #2)
> This looks like mozplugger.x86_64 is installed.
> 
> If you want to use mozplugger, you need to turn off confinement.
> 
> setsebool -P unconfined_mozilla_plugin_transition 1
> 
> Or you can remove mozplugger
> 
> yum remove mozplugger

Given the options. I choose removing muzplugger.
Comment 4 Miroslav Grepl 2012-06-04 08:55:48 EDT
*** Bug 827773 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.