Bug 808961 - DVD upgrade of F16- to F17 requires yum update on Reboot to complete
DVD upgrade of F16- to F17 requires yum update on Reboot to complete
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sugar (Show other bugs)
17
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-01 23:05 EDT by satellitgo
Modified: 2012-05-05 04:34 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-05 04:34:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ABRT log (4.58 KB, text/plain)
2012-04-02 07:15 EDT, satellitgo
no flags Details

  None (edit)
Description satellitgo 2012-04-01 23:05:23 EDT
Description of problem:
DVD upgrade of F16-sugar to F17 leaves "About my Computer" in sugar saying Soas v6; Fedora-16
gdm login says Fedora release 17 (Beefy Miracle)

Version-Release number of selected component (if applicable):
f16 Soas i686 Liveinst install to Hard disk (Virtualbox)


How reproducible:
Do DVD upgrade of f16 HD to f17 using f17 Beta DVD i686

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Upgrade was successful and booted and logged in correctly but "My Settings/About my Computer  says "Sugar on a Stick 6 (Pineapple) Fedora release 16 (Verne) sugar:0.94.1 Virtualbox" which is not updated.

Expected results:


Additional info:
Comment 1 satellitgo 2012-04-01 23:12:22 EDT
(In reply to comment #0)
> Description of problem:
> DVD upgrade of F16-sugar to F17 leaves "About my Computer" in sugar saying Soas
> v6; Fedora-16
> gdm login says Fedora release 17 (Beefy Miracle)
> 
> Version-Release number of selected component (if applicable):
> f16 Soas i686 Liveinst install to Hard disk (Virtualbox)
> 
> 
> How reproducible:
> Do DVD upgrade of f16 HD to f17 using f17 Beta DVD i686
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
> 
> Actual results:
> Upgrade was successful and booted and logged in correctly but "My
> Settings/About my Computer  says "Sugar on a Stick 6 (Pineapple) Fedora release
> 16 (Verne) sugar:0.94.1 Virtualbox" which is not updated.
> 
> Expected results:
> 
> 
> Additional info:

My Settings/Software updates shows (14). Was fully updated before DVD upgrade
Comment 2 satellitgo 2012-04-01 23:21:27 EDT
Still has surf-115 browser which does not start. (No browse). Installed browse 133.xo from 2nd USB stick (does not start) downgraded to Browse 120.xo then upgraded with software update to Browse-129.xo still does not start
*NO BROWSER available if DVD Upgrade of SoaS is done.
Comment 3 Peter Robinson 2012-04-02 05:17:18 EDT
I'm aware of the issue with the naming for upgrades, it's not something we really support at the moment.

For browse you need to do "yum upgrade sugar-browse" or even better post upgrade to "yum install @sugar-desktop" which will pull in all the latest components needed.
Comment 4 satellitgo 2012-04-02 06:11:20 EDT
As a test in VirtualBox;
I did a DVD install of f16 using updates and normal repos. selected gnome and sugar desktop plus browse and sugar-emulator from extras.
I started the Install and saw that sugar worked. logged out and logged in as sugar. then shutdown.
I then upgraded this Virtualbox install to f17 with the f17 Beta DVD:
after upgrade it logged in to gdm as f17 and sugar just as I left it.
 -About my Computer was updated correctly:
  Fedora release 17 (Beefy Miracle)
  0.94.1
  VirtualBox

 - Surf still worked!
 - Browse was 122 and software update went to 129 (Neither worked)
followed comment 3:

* yum update sugar-browse:
  sugar-browse.noarch 0:122-1.fc16 will be updated
  sugar-browse.noarch 0:133-1.fc17 will be obsoleting
  processing dependency: sugar-toolkit-gtk3 for package: sugar-browse.noarch 0:133-1.fc17
 y/N  N

*yum install @sugar-desktop
 install 5 packages (+ 4 dependent packages)
 Upgrade 29 packages (+13 Dependent packages)
 75M
 y/N y
Comment 5 satellitgo 2012-04-02 06:37:31 EDT
updates-testing/presto delta metadata;
Download size 2.2 M 
asks for public keys evince and csound y/N y
(Browse still at 129)
Did restart
Dracut warning: Signal Caught
/shutdown: 33: /shutdown: sh: not found
kernel panic
power off VirtualBox
restart:
Grub 2
gdm is f17 beefy miracle
logs in to fireworks display
Browse is now 133 and starts
jabber works
About my computer
 Fedora release 17 (Beefy Miracle)
 0.95.6
 VirtualBox
Software update
 record 94-95
Record does not start
IRC flashes
Moon flashes
shutdown

enforcing=0 on boot:
NO CHANGE  terminal and Turtle Art also flash and do not start

This update rendered all tested activities un-startable.
Comment 6 satellitgo 2012-04-02 07:15:04 EDT
Created attachment 574461 [details]
ABRT log

Looks like it transferred from f16 on DVD Upgrade to F17 of gnome and sugar-desktop install
Comment 7 satellitgo 2012-04-02 10:56:47 EDT
repeated DVD update
 -About my Computer was updated correctly:
  Fedora release 17 (Beefy Miracle)
  0.94.1
  VirtualBox

 - Surf still worked!
*yum upgrade sugar-browse
Installing:
 sugar-browse          noarch       133-1.fc17    updates-testing
     replacing sugar-surf.noarch 115-2.fc16
Installing for dependencies:
 sugar-toolkit-gtk3    i686        0.95.5-1.fc17  updates-testing

Transaction Check error
 file /usr/bin/sugar-activity from install of sugar-toolkit-gtk3-0.95.5-1.fc17.i686 conflicts with file from sugar-0.94.1-1.fc16.noarch
Comment 8 satellitgo 2012-04-02 11:59:11 EDT
*yum update
4 packages (+12 Dependent packages)
Upgrade 459 packages
598 M

downloads 271 drpms
locally rebuilding of rpms, from deltarpms

*after yum update sugar-desktop works
-About my Computer was updated correctly:
  Fedora release 17 (Beefy Miracle)
  0.95,6
  VirtualBox

Gnome is 3.4.0
Comment 9 satellitgo 2012-04-02 12:38:30 EDT
(In reply to comment #8)
> *yum update
> 4 packages (+12 Dependent packages)
> Upgrade 459 packages
> 598 M
> 
> downloads 271 drpms
> locally rebuilding of rpms, from deltarpms
> 
> *after yum update sugar-desktop works
> -About my Computer was updated correctly:
>   Fedora release 17 (Beefy Miracle)
>   0.95,6
>   VirtualBox
> 
> Gnome is 3.4.0
Why is this not part of DVD upgrade process?
Comment 10 Adam Williamson 2012-04-02 15:24:44 EDT
well, the updates-testing repo is enabled by default for pre-releases, but none of those packages will be on the Beta RC2 DVD, because it's built from the 'stable' repo. this is quite normal, and how the process is meant to work.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 satellitgo 2012-04-02 19:40:02 EDT
this is related to https://bugzilla.redhat.com/show_bug.cgi?id=808039
there is no sugar-desktop files in the DVD repo doing the f16-f17 update
Comment 12 Adam Williamson 2012-05-04 09:09:32 EDT
So, now Sugar is on the DVD, is there any bug left here? Should we close it?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Peter Robinson 2012-05-05 04:34:59 EDT
No, this is resolved

Note You need to log in before you can comment on or make changes to this bug.