Bug 808989 - reformatting of inline tags creates excessive whitespace in docs
reformatting of inline tags creates excessive whitespace in docs
Status: CLOSED DUPLICATE of bug 814393
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Casperson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 03:19 EDT by Dana Mison
Modified: 2014-08-04 18:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 23:41:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dana Mison 2012-04-02 03:19:15 EDT
/Topic.xhtml

When the XML gets reformatted, some inline tags get broken up onto multiple lines.  This creates additional whitespace in the output which needs to be avoided.  

Note it doesn't happen with all inline tags.  Examples: <filename> doesn't get reformatted, <systemitem> does and gains whitespace in the ouput, <acronym> gets reformatted but doesn't seem to gain whitespace in output.

Eg.

data grid server using <systemitem>Hot Rod</systemitem>, <systemitem>memcached</systemitem> or <systemitem>REST</systemitem> client APIs.

gets reformatted as:

data grid server using 
<systemitem>
	Hot Rod
</systemitem>, 
<systemitem>
	memcached
</systemitem> or 
<systemitem>
	REST
</systemitem> client APIs. 

This results in HTML output with additional spaces on either side of the contents of the marked up text.  

data grid server using <code class="systemitem"> Hot Rod </code>, <code class="system item"> memcached </code> or <code class="systemitem"> REST </code> client APIs.

The additional white space inside the <code> elements are a problem.

If it is necessary to break some inline elements onto new lines in the XML we should keep the element itself together to avoid this:

eg.

data grid server using 
<systemitem class="protocol">Hot Rod</systemitem>
, 
<systemitem class="protocol">memcached</systemitem> 
or 
<systemitem class="protocol">REST</systemitem> 
client APIs. 

But I would prefer if this could be avoided as it creates a situation where the white space after it is "hidden" and easily forgotten by the writer who may inadvertently edit it out and therefore effectively remove spaces from between words in the output.
Comment 1 Matthew Casperson 2012-07-09 23:41:04 EDT

*** This bug has been marked as a duplicate of bug 814393 ***

Note You need to log in before you can comment on or make changes to this bug.