Bug 814393 - Skynet inserts errant whitespace in emphasis, acronym, systemitem, package, and keycap tags.
Skynet inserts errant whitespace in emphasis, acronym, systemitem, package, a...
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.x
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Lee Newson
:
: 808989 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 14:49 EDT by Stephen Gordon
Modified: 2014-05-26 21:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-16 02:14:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2012-04-19 14:49:35 EDT
Description of problem:

When re-visiting some edits to topic 7868 I found that this (as originally entered):

		<para>
			For every type of switch it is important to set up the switch bonding with the <firstterm>Link Aggregation Control Protocol</firstterm> (<acronym>LACP</acronym>) protocol and <emphasis>not</emphasis> the Cisco <firstterm>Port Aggregation Protocol</firstterm> (<acronym>PAgP</acronym>) protocol. 
		</para>

Had become this (as modified by the system when the topic is saved):

		<para>
			For every type of switch it is important to set up the switch bonding with the <firstterm>Link Aggregation Control Protocol</firstterm> (
			<acronym>
				LACP
			</acronym>) protocol and 
			<emphasis>
				not
			</emphasis> the Cisco <firstterm>Port Aggregation Protocol</firstterm> (
			<acronym>
				PAgP
			</acronym>) protocol. 
		</para>

I anticipate that when rendered this will mean that there is (unexpectedly) additional whitespace around the acronyms and the emphasised 'not'.

Expected behaviour:

These tags to be handled in the same way as the <firstterm> in the example, no additional whitespace injected. Possibly impacts other tags too but these are just the ones I have come across.
Comment 1 Stephen Gordon 2012-06-25 11:39:58 EDT
I've found that systemitem, package and keycap tags have the same issue - probably others. I'm raising the priority on this because:

a) It's noticeable in the English output, and even if we edit the topic to remove the whitespace in skynet when the topic is saved it is re-inserted.

b) It impacts translation matching, and adds some additional work for translators (because they can actually remove the errant whitespace in translated versions).
Comment 3 Stephen Gordon 2012-06-25 11:51:00 EDT
Looks like editing out the whitespace around the <acronym> tags actually does save, not so for the others though.
Comment 4 Lee Newson 2012-06-27 00:27:46 EDT
Sorry Steve, I completely missed this bug. I'll update the system variables that control the inline elements at COB in BNE today, unfortunately we don't have a way to update them at this point in time so that means manually going back and editing the content. I'll discuss that component with Matt once he gets back.
Comment 5 Lee Newson 2012-06-27 00:32:53 EDT
Just as reference we have this bug open for the white space Bug #812716

and these are the current inline variables as of 27th of June (before editing):

code,prompt,command,firstterm,ulink,guilabel,filename,replaceable,parameter,literal,classname,sgmltag,guibutton,guimenuitem,guimenu,menuchoice,citetitle,application,systemitem,acronym,keycap

So package and emphasis are the only two that I can see to be missing. If you know of any others that are missing please let us know.
Comment 6 Lee Newson 2012-06-27 01:07:44 EDT
Added more inline elements that I found from: http://www.docbook.org/tdg5/en/html/ch02.html

New Elements:

quote,trademark,abbrev,phrase,anchor,citation,glossterm,link,xref,markup,tag,
keycode,keycombo,accel,guisubmenu,keysym,shortcut,mousebutton,constant,errorcode,
errorname,errortype,function,msgtext,property,returnvalue,symbol,token,varname,
database,email,hardware,option,optional,type
Comment 7 Lee Newson 2012-06-27 02:37:35 EDT
Missed one:

methodname
Comment 9 Lee Newson 2012-06-27 07:46:32 EDT
One more that I found when looking through different topics:

interfacename
Comment 10 Matthew Casperson 2012-07-01 17:38:18 EDT
We could simply run through a bulk re-save of topics, which will change the formatting of the topics. However this does have implications on the translations as any changes to the original topic could potentially force a retranslation.

However, I don't think there are any topics in Zanata for anyone other than EAP6 and maybe EDG, so this may not be such a large issue.
Comment 11 Lee Newson 2012-07-01 18:34:31 EDT
The other issue with a bulk re-save is that the white space would still exist it would just make it easy to see where the white space is.

eg

Original:

    Some Text <systemitem>Some more Text</systemitem>

Bugged:

    Some Text
    <systemitem>SPACE
        Some more TextSPACE
    </systemitem>

Re-Save:

    Some Text <systemitem> Some more Text </systemitem>
Comment 12 Stephen Gordon 2012-07-04 15:30:33 EDT
Seems like the <uri> tag is also impacted.
Comment 13 Lee Newson 2012-07-05 08:40:07 EDT
Confirmed and added to the list of inline elements.
Comment 14 Matthew Casperson 2012-07-09 23:41:04 EDT
*** Bug 808989 has been marked as a duplicate of this bug. ***
Comment 15 Stephen Gordon 2012-10-11 12:16:53 EDT
<computeroutput> as well. As per the docbook guide this is an inline:

http://www.docbook.org/tdg/en/html/computeroutput.html
Comment 16 Lee Newson 2012-10-11 18:45:28 EDT
Added computeroutput to the list of inline elements.
Comment 17 Misty Stanley-Jones 2013-05-28 22:19:22 EDT
This hasn't been touched in a while, which implies that we haven't found more. Am I correct that this issue is actually fixed for all known impacted elements?
Comment 18 Lee Newson 2013-08-16 02:14:45 EDT
Closing this since we haven't found anymore known elements.

Note You need to log in before you can comment on or make changes to this bug.