This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 809052 - Gnome - Corrupted windows displaying
Gnome - Corrupted windows displaying
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
17
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-04-02 06:54 EDT by David Spurek
Modified: 2015-03-02 00:26 EST (History)
15 users (show)

See Also:
Fixed In Version: xorg-x11-drv-cirrus-1.3.2-19.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 20:47:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Firefox fail (201.20 KB, image/png)
2012-04-02 06:54 EDT, David Spurek
no flags Details
corrupted windows displaying (273.54 KB, image/png)
2012-04-02 07:55 EDT, Branislav Blaškovič
no flags Details

  None (edit)
Description David Spurek 2012-04-02 06:54:14 EDT
Created attachment 574458 [details]
Firefox fail

Description of problem:
Run Firefox from menu in fallback mode, after then firefox starts, but bad. Show the picture in attachment. 

Version-Release number of selected component (if applicable):
firefox-11.0-2.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1.Boot in fallback mode
2.Run Firefox from menu
3.
  
Actual results:
Firefox starts with bad "screen"

Expected results:
Starts without problem
Comment 1 Branislav Blaškovič 2012-04-02 07:55:50 EDT
Created attachment 574477 [details]
corrupted windows displaying

This problem is not only with firefox and fallback mode. 
In my VM it's happening always. I attached image showing Nautilus + Firefox - both are corrupted.

Panels are OK, login screen too.

I tagged this bug as blocker F17Beta.

(I tried LXDE also and there is everything ok with displaying)
Comment 2 Kamil Páral 2012-04-02 09:05:56 EDT
I can reproduce by running F17 Beta RC2 i686 Live in VM. The desktop wallpaper is distorted and so is every application I run. The only thing that is not distorted is Gnome Shell UI. In fallback mode everything works ok (David's screenshot also indicates he was running gnome-shell, not fallback mode).

I see this problem only with vnc+cirrus, I don't see it with spice+qxl.

Re-assigning to gnome-shell.
Comment 3 Kamil Páral 2012-04-02 09:08:56 EDT
Or, more probably, this could be a problem in llvmpipe or mesa (since cirrus has only 9MB RAM and there were some changes regarding this in llvmpipe/mesa lately).
Comment 4 Adam Williamson 2012-04-02 11:49:36 EDT
Looks very much like it's a mesa issue somehow. Ajax?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Kamil Páral 2012-04-02 12:31:14 EDT
It is very interesting that all applications I tried are blurred, but gnome-terminal runs just fine.

The rendering is broken with following packages:
mesa-dri-drivers-8.0.1-9.fc17
llvm-libs-3.0-8.fc17 or llvm-libs-3.0-10.fc17

I'm experimenting with previous composes, I have a feeling this is a very recent regression.
Comment 6 Kamil Páral 2012-04-02 13:12:01 EDT
Voila, it works with F17 Beta RC1 live:

mesa-dri-drivers-8.0.1-2.fc17
llvm-libs-3.0-8.fc17

Definitely a regression in mesa.
Comment 7 Owen Taylor 2012-04-02 14:03:09 EDT
(In reply to comment #5)
> It is very interesting that all applications I tried are blurred, but
> gnome-terminal runs just fine.

Presumably the difference is that gnome-terminal uses an ARGB visual while other applications use RGB visuals, so different code pathsiin Mesa and the X server are exercised.
Comment 8 Adam Williamson 2012-04-02 15:21:43 EDT
Discussed at 2012-04-02 QA meeting, acting as a blocker review meeting. Agreed that this is a blocker, under the criteria "The release must install and boot successfully as a virtual guest in a situation where the virtual host is running the previous stable Fedora release, using Fedora's current preferred virtualization technology", "The release must be able host virtual guest instances of the same release, using Fedora's current preferred virtualization technology" and "Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention", in the case of a virtual machine using the cirrus driver.

We believe this is a sufficiently common case to consider this a blocker: any VM definition created prior to F16 that wasn't explicitly changed to use qxl will still be using cirrus, and people often re-use existing VM definitions rather than creating new ones. Also, any newly-created 32-bit VM will still default to using the cirrus driver. We believe qxl is only used by default on 64-bit VMs created with Fedora 16 or Fedora 17.

ajax is aware of the bug and working on a fix. It is a regression between mesa -1 and -9, caused by a performance improvement ajax does not want to lose.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Adam Jackson 2012-04-02 16:21:41 EDT
There's two changes I want to make for this.  One is to switch cirrus to 16bpp, which should both be a performance improvement and align it with the other fallback drivers, which prefer 16bpp to 24bpp.  The other is a fix to the Mesa code itself for paths other than 32bpp.  Note that the 24bpp path in Mesa might still be broken, but honestly 24bpp is pretty broken all the time anyway.
Comment 10 Fedora Update System 2012-04-02 16:49:02 EDT
xorg-x11-drv-cirrus-1.3.2-19.fc17,mesa-8.0.2-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-cirrus-1.3.2-19.fc17,mesa-8.0.2-2.fc17
Comment 11 Adam Williamson 2012-04-02 17:48:50 EDT
Fix confirmed, I installed the updated packages in a live boot, restarted X, and got a nice non-corrupted Shell. Thanks ajax!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Adam Williamson 2012-04-02 19:25:12 EDT
so I did notice one problem - if you boot KDE with cirrus/vnc and run Konqueror, you see this:

http://www.happyassassin.net/extras/kde_purple.png

with the new mesa and cirrus. With Beta RC2 - mesa 8.0.1-1 - there's no such issue. I don't know the status of 8.0.1-9.

overall, the state with 8.0.2-2 is still probably better, but I figured it was worth noting.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Adam Williamson 2012-04-04 17:45:29 EDT
Confirmed that a VNC/cirrus VM displays Firefox just fine with the Beta RC3 desktop live.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Fedora Update System 2012-04-04 20:47:49 EDT
xorg-x11-drv-cirrus-1.3.2-19.fc17, mesa-8.0.2-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Jaroslav Reznik 2012-04-05 07:59:43 EDT
(In reply to comment #12)
> so I did notice one problem - if you boot KDE with cirrus/vnc and run
> Konqueror, you see this:
> 
> http://www.happyassassin.net/extras/kde_purple.png
> 
> with the new mesa and cirrus. With Beta RC2 - mesa 8.0.1-1 - there's no such
> issue. I don't know the status of 8.0.1-9.
> 
> overall, the state with 8.0.2-2 is still probably better, but I figured it was
> worth noting.
> 
> 
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers

This update really breaks the whole Plasma Desktop, it's not affecting the apps (here Konqueror) only. I already filled #810161 (I missed this bug report).

Note You need to log in before you can comment on or make changes to this bug.