Bug 80907 - man pages don't display correctly
Summary: man pages don't display correctly
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-01-02 05:05 UTC by Jason McCormick
Modified: 2008-01-17 17:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-30 23:08:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason McCormick 2003-01-02 05:05:36 UTC
Description of problem:
  Some man pages don't display correctly in any terminal setup using either
konsole/kterm or xterm in KDE.

Screenshot of Konsole/Kterm with 'man tar' -
http://www.ironlizard.org/illformatted-man.png

Screenshot of Xterm with 'man tar' -
http://www.ironlizard.org/formatted-man1.png

Screenshot of gnome-terminal with 'man tar' -
http://www.ironlizard.org/formatted-man2.png

I've tried setting various font and other settings and man pages, particularly
characters using - or / appear as small squares (kterm) or are completely absent
(xterm).  If I use Gnome and view man pages through gnome-terminal, everything
appears normal.  Some man pages work fine (see 'man gcc' or 'man emacs') but
others are unreadable due to the small squares.

Version-Release number of selected component (if applicable):
  I'm using the default pages that came with 8.0.92 / Phoebe

How reproducible:
  Always with certain types of man pages

Steps to Reproduce:
1. Open Konsole
2. 'man tar' (bad)
3. 'man 1 crontab' (bad)
4. 'man gcc' (fine)
5. 'man  gzip' (fine in some places, squares in others)
    
Actual results:
  Man pages are formatted incorrectly

Expected results:
  Correctly formatted man pages

Additional info:
  Can provide more screenshots if necessary.  This was also present in 8.0 but I
assumed it would be fixed in the next release since RH8 was a new branch of KDE
and was somewhat minor but I filed since I noticed it was still present in Phoebe.

Comment 1 Michael Wardle 2003-01-14 03:59:39 UTC
Bug 80544 relates to problems displaying manual pages in Konsole.


Comment 2 Jason McCormick 2003-01-22 03:32:46 UTC
Troubleshooting some Perl problems, I ran into the UTF-8 isues with older Perl
code.  On a whim I did a:

LANG=en_US; export LANG

And this cleared up the manpage formatting issues.  Perhaps this is some help. 
I gathered from reading other bug reports that i18n support could be causing the
problem.  This is at least a temp workaround for the issue.

Comment 3 Ngo Than 2003-02-01 09:24:37 UTC
does it show man page correct if you use fixed font in konsole?
konsole works with fixed font at best.

Comment 4 Ngo Than 2003-02-03 19:07:07 UTC
Thomas, is it a groff issue? does the new groff fix this problem? please close it
if it's fixed.

Comment 5 Tim Waugh 2003-02-06 09:57:28 UTC
This seems to be fixed with the current groff and less packages.

Comment 6 Bill Nottingham 2003-07-30 23:08:22 UTC
Closing out some bugs that have been in MODIFIED state. Please reopen if they
persist.


Note You need to log in before you can comment on or make changes to this bug.