Bug 809123 - Unable to login to desktop after upgrading to NM-0.9.4-1.git20120328.fc16
Unable to login to desktop after upgrading to NM-0.9.4-1.git20120328.fc16
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
16
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
RejectedNTH
:
: 808152 809215 810053 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 10:33 EDT by James Laska
Modified: 2013-09-02 03:01 EDT (History)
11 users (show)

See Also:
Fixed In Version: NetworkManager-0.9.4.0-7.git20120403.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 01:24:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2012-04-02 10:33:43 EDT
Description of problem:

After upgrading to NetworkManager-0.9.4-1.git20120328.fc16.x86_64, it seems I am unable to login.  The gnome-shell presents the startup-failure screen.

When downgrading to NetworkManager-0.9.2-1.fc16, the problem goes away.

Version-Release number of selected component (if applicable):
 * NetworkManager-0.9.4-1.git20120328.fc16.x86_64


Steps to Reproduce:
1. Manually configure a Network bridge following instructions from libvirt.org
   > /etc/sysconfig/network-scripts/ifcfg-em1 has NM_CONTROLLED=no
   > /etc/sysconfig/network-scripts/ifcfg-br0 also has NM_CONTROLLED=no
2. Upgrade to latest NM from 'updates-testing'
3. Login to desktop
  
Actual results:

 * Gnome shell fails to start

Expected results:

 * After upgrading NM, the desktop should start without error

Additional info:

 * See libnm-glib backtrace in attachment#574498 [details]
Comment 1 Jirka Klimes 2012-04-02 11:42:59 EDT
Upstream fix: 8bb278944496102a4afad46b53e1e8279425aaac
Comment 2 James Laska 2012-04-02 11:56:24 EDT
(In reply to comment #1)
> Upstream fix: 8bb278944496102a4afad46b53e1e8279425aaac

I'm unable to reproduce the reported problem when testing using a provided scratch build (http://koji.fedoraproject.org/koji/taskinfo?taskID=3956993)
Comment 3 Fedora Update System 2012-04-03 11:19:07 EDT
NetworkManager-0.9.4-2.git20120403.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.4-2.git20120403.fc16
Comment 4 Fedora Update System 2012-04-04 03:31:59 EDT
NetworkManager-0.9.4-3.git20120403.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.4-3.git20120403.fc17
Comment 5 Jirka Klimes 2012-04-04 03:35:13 EDT
*** Bug 808152 has been marked as a duplicate of this bug. ***
Comment 6 Jirka Klimes 2012-04-04 03:36:43 EDT
*** Bug 809215 has been marked as a duplicate of this bug. ***
Comment 7 Konrad Rzeszutek Wilk 2012-04-04 10:45:00 EDT
I was triggering it with NetworkManager enabled - as the install was done through HTTP. I hadn't done anything special to the network interface.

systemctl tells me:
NetworkManager.service    loaded active   running       Network Manager

The /etc/sysconfig/network-scripts/ifcfg-eth0 tells me:
[root@f17 ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0 
UUID="a2d015cf-1d0b-41bb-a851-e7669415383f"
NM_CONTROLLED="yes"
BOOTPROTO="dhcp"
DEVICE="eth0"
ONBOOT="yes"
HWADDR=00:16:3E:FA:8F:9C
TYPE=Ethernet
DEFROUTE=yes
PEERDNS=yes
PEERROUTES=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System eth0"

I had download the NetworkManager-0.9.4-3.git20120403.fc17 and I am still hitting this. rpm -qa | grep NetworkManager tells me:

[root@f17 ~]# rpm -qa | grep Network
NetworkManager-0.9.4-3.git20120403.fc17.i686
NetworkManager-pptp-0.9.3.997-1.fc17.i686
NetworkManager-gnome-0.9.4-3.git20120403.fc17.i686
NetworkManager-vpnc-0.9.3.997-1.fc17.i686
NetworkManager-openconnect-0.9.3.997-1.fc17.i686
NetworkManager-gtk-0.9.4-3.git20120403.fc17.i686
evolution-NetworkManager-3.4.0.1-1.fc17.i686
NetworkManager-openvpn-0.9.3.997-1.fc17.i686
NetworkManager-glib-0.9.4-3.git20120403.fc17.i686


And it here is something more strange:

root@f17 ~]# nmcli  nm
RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         connected       enabled         enabled    enabled         disabled  
[root@f17 ~]# su - konrad
[konrad@f17 ~]$ nmcli nm

** (process:3305): WARNING **: Could not initialize NMClient /org/freedesktop/NetworkManager: Rejected send message, 3 matched rules; type="method_call", sender=":1.53" (uid=1000 pid=3305 comm="nmcli nm ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination="org.freedesktop.NetworkManager" (uid=0 pid=443 comm="/usr/sbin/NetworkManager --no-daemon ")
Error: nmcli (0.9.4.0) and NetworkManager (unknown) versions don't match. Force execution using --nocheck, but the results are unpredictable.

So:

[root@f17 ~]# rpm -qf `which nmcli`
NetworkManager-0.9.4-3.git20120403.fc17.i686
[root@f17 ~]# ps -eff|grep Network
root       443     1  0 09:02 ?        00:00:00 /usr/sbin/NetworkManager --no-daemon
root      3313  3183  0 10:44 hvc0     00:00:00 grep --color=auto Network
[root@f17 ~]# rpm -qf `which NetworkManager`
NetworkManager-0.9.4-3.git20120403.fc17.i686
[root@f17 ~]#
Comment 8 Jirka Klimes 2012-04-04 11:35:36 EDT
I'd say that there can be some problem with D-Bus or PolicyKit causing the rejected messages.

But the crash of /usr/bin/gnome-shell in libnm-glib should be fixed.
Try to obtain some logs to found out what's the problem (~/.xsession-errors, /var/log/messages)
Comment 9 Konrad Rzeszutek Wilk 2012-04-05 08:53:16 EDT
Uninstalling fprintd (and fprintd-pam) fixed it.
Comment 10 Adam Williamson 2012-04-05 13:42:51 EDT
*** Bug 810053 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2012-04-05 14:25:46 EDT
Package NetworkManager-0.9.4-3.git20120403.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.9.4-3.git20120403.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5355/NetworkManager-0.9.4-3.git20120403.fc17
then log in and leave karma (feedback).
Comment 12 Adam Williamson 2012-04-06 01:01:58 EDT
Nominating this as a Beta NTH so we can discuss whether to pull it into RC4. My best guess as to the circumstance that produces this bug is running Shell with the NetworkManager service disabled, though I couldn't reproduce it that simply when I tried in a VM.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Adam Williamson 2012-04-09 23:11:11 EDT
Discussed at 2012-04-09 blocker review meeting. We agreed this is rejected as NTH as the trigger - disabling NM - is not something anyone's likely to do on a live image, so fixing this with an update should be good enough.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Adam Williamson 2012-04-09 23:11:40 EDT
correction - 2012-04-06 NTH review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-04-06/f17-beta-blocker-review-5.2012-04-06-17.01.log.html
Comment 15 Fedora Update System 2012-04-19 01:24:24 EDT
NetworkManager-0.9.4-2.git20120403.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2012-04-19 18:02:54 EDT
NetworkManager-0.9.4-5.git20120403.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.4-5.git20120403.fc17
Comment 17 Fedora Update System 2012-04-20 10:29:00 EDT
NetworkManager-0.9.4.0-6.git20120403.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.4.0-6.git20120403.fc17
Comment 18 Fedora Update System 2012-04-23 18:42:14 EDT
NetworkManager-0.9.4.0-7.git20120403.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.4.0-7.git20120403.fc17
Comment 19 Fedora Update System 2012-05-02 16:51:30 EDT
NetworkManager-0.9.4.0-7.git20120403.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.