Bug 810053 - NetworkManager causes gnome-shell to crash
Summary: NetworkManager causes gnome-shell to crash
Status: CLOSED DUPLICATE of bug 809123
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 17
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F17Beta-accepted, F17BetaFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2012-04-05 02:06 UTC by Jonathan Kamens
Modified: 2012-04-06 05:01 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-04-05 17:42:51 UTC


Attachments (Terms of Use)
patch to fix uninitialized variable (428 bytes, patch)
2012-04-05 02:06 UTC, Jonathan Kamens
no flags Details | Diff

Description Jonathan Kamens 2012-04-05 02:06:13 UTC
Created attachment 575255 [details]
patch to fix uninitialized variable

My gnome-shell was starting to get sluggish tonight, which in F16 was a sign that it was bloated from memory leaks and needed to be restarted, so I type Alt-F2 r RET to restart it.

Unfortunately, when it restarted it crashed ("Oops! Logout" dialog). Then it crashed again, and again, and again. I even tried rebooting to see if I would be able to log in after the reboot.

I analyzed the core dump and discovered that the NetworkManager being called by gnome-shell was using an uninitialized GError pointer. The attached patch fixes the bug.

Given that this is a gnome-shell crash from which there is no recovery -- it'll apparently keep crashing no matter how many times you try to log in -- I think this fix probably needs to make it into F17.

Comment 1 Adam Williamson 2012-04-05 17:42:51 UTC
jon, can you say exactly what your config is wrt NM? Is the NM service actually enabled? Do you have any interfaces being controlled with the network service?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 809123 ***

Comment 2 Jonathan Kamens 2012-04-05 17:55:18 UTC
NM service disabled, no interfaces controlled with NM.

Comment 3 Adam Williamson 2012-04-06 05:01:41 UTC
Nominating this as a Beta NTH so we can discuss whether to pull it into RC4. My best guess as to the circumstance that produces this bug is running Shell with the NetworkManager service disabled, though I couldn't reproduce it that simply when I tried in a VM.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.