Bug 809142 - mod_perl fails to rebuild in rawhide
mod_perl fails to rebuild in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mod_perl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 746215 808855 839640
  Show dependency treegraph
 
Reported: 2012-04-02 11:23 EDT by Gabriel Somlo
Modified: 2012-07-25 09:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 839640 (view as bug list)
Environment:
Last Closed: 2012-07-25 09:01:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabriel Somlo 2012-04-02 11:23:03 EDT
Description of problem:
I am co-maintainer of a new package which depends on mod_perl. Building my package in rawhide fails with:

Error: Package: mod_perl-2.0.5-8.fc18.x86_64 (fedora)
           Requires: httpd-mmn = 20051115-x86-64
           Installing: httpd-2.4.1-6.fc18.x86_64 (fedora)
               httpd-mmn = 20120211-x86-64
               httpd-mmn = 20120211

Attempting to build mod_perl 2.0.5 in mock against rawhide also fails, most likely due to incompatibility with apache 2.4

Version-Release number of selected component (if applicable):
mod_perl-2.0.5-8.fc18

How reproducible:
mock -r fedora-devel-x86_64 mod_perl-2.0.5-8.fc18.src.rpm

Additional info:

There's a svn branch dedicated to mod_perl on apache 2.4 you may want to track, in case you're not doing that already:
  http://svn.apache.org/repos/asf/perl/modperl/branches/httpd24

Thanks,
--Gabriel
Comment 1 Jan Kaluža 2012-04-03 03:16:36 EDT
I'm tracking the branch already, but it's 8 months old and lot of 2.4 API changes were made after that.

Currently I have patch to compile mod_perl with httpd-2.4, but it breaks the API compatibility. Unfortunately there is no consensus if and how to keep to the compatibility. I can't decide it without upstream...

I will continue the discussion with upstream and try to fix it as soon as possible.
Comment 2 Jan Kaluža 2012-07-25 09:01:03 EDT
This should be fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.