Bug 80922 - (xkb swedish) Can't use DEAD_KEY + space combinations to write for example ~
(xkb swedish) Can't use DEAD_KEY + space combinations to write for example ~
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 80595 (view as bug list)
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2003-01-02 08:29 EST by Daniel Resare
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-23 14:00:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Resare 2003-01-02 08:29:29 EST
Description of problem:

On my swedish keyboard i use dead_tilde + space to write tilde. With the phoebe
release this has ceased working. The same thing seems to be the case with
dead_diaresis + space and dead_circumflex + space.

All combinations works as expected in gnome-terminal and other gtk2 apps (tested
with Network Proxy preferences program

Version-Release number of selected component (if applicable):
evolution-1.2.1-2

How reproducible:
always

Steps to Reproduce:
1. switch to a keyboard setting with dead keys (For example swedish)
2. start evolution
3. try to input tilde by pressing dead_tilde + space anywhere where evolution
accepts text input.

    
Actual results:

nothing gets written

Expected results:

tilde should be written

Additional info:

the same problem exists in mozilla and derived programs
Comment 1 Jeremy Katz 2003-01-02 10:08:25 EST
evolution uses gtk+ 1.2 -- do other gtk+ 1.2 apps such as xchat and the GIMP
have this problem?
Comment 2 Daniel Resare 2003-01-02 10:15:05 EST
It seems so yes :/ The problem is verified to exist in gimp and xchat
Comment 3 Daniel Resare 2003-01-02 10:18:17 EST
*** Bug 80595 has been marked as a duplicate of this bug. ***
Comment 4 Owen Taylor 2003-01-02 10:34:35 EST
libX11 bug (or more likely config file bug), not GTK+ bug ... GTK+-1.2 just uses 
X11's compose handling. I suspect this is a dup... you might want to look at
open XFree86 bugs to check.

This was reported to xpert@xfree86.org a week ago or so (as it happens, 
by Linus...) not sure if it's fixed in CVS or not.
Comment 5 Henrik Nordstrom 2003-01-17 09:00:16 EST
Problem still exists in RawHide XFree86-4.2.99.3-20021230.4.
Comment 6 Mike A. Harris 2003-01-18 05:05:39 EST
Recommendation first: Upgrade to XFree86 4.2.99.3-20030115.0 from

ftp://people.redhat.com/mharris/testing/unstable

If the problem persists, in order to maximize the possibility of this being
fixed as soon as possible, it is highly recommended for this to be reported
by the original bug reporter above to the XFree86 team.  Any similar issues
should be reported in the future both to Red Hat, as well as to the XFree86
team as well.

The XFree86 team contains a number of experts who generally can and do fix
these types of problems soon after they are made aware of the problem,
which also has the effect generally of the best fix being made upstream
rather than a possible kludge which might not be officially correct made
locally by Red Hat.

You can report this, and similar issues to XFree86.org by emailing a detailed
report to the devel@xfree86.org mailing list.  You may also wish to join the
mailing list and track the progress of the problem also.

The upstream XFree86 development will be monitored, and this bug will
continue to be tracked.  Once fixed, the status will be updated here, and
new packages made available.

Thanks.
Comment 7 Daniel Resare 2003-01-20 18:48:54 EST
As mentioned above a detailed report was sent (by Linus) to the
xpert@xfree86.org list. It included patches, however no comment seems to be made
by any committer about the problem.

http://marc.theaimsgroup.com/?l=xfree-xpert&m=104103816009227&w=2

This is definitely a real problem for lots of people, and if it doesn't get
fixed upstream I think that the patch should go into the redhat rpms.

Btw. why is this marked as NEEDINFO?
Comment 8 Mike A. Harris 2003-01-21 05:55:59 EST
It's marked NEEDINFO, because I asked for a newer release to be tested,
and do not plan on looking at this problem again until someone who cares
about this bug being fixed installs the newer release and tests it, and
then provides an updated comment here as to wether or not the problem
is fixed or not in the absolute latest rawhide build.

Many such problems have been fixed lately, and people have been closing
bugs they've opened as "fixed now in RAWHIDE, thanks".  So until someone
tests rawhide out with similar problems that are reported and still
open, the bug sits in NEEDINFO untouched.
Comment 9 Daniel Resare 2003-01-21 06:16:50 EST
I'm sorry. I missed writing the most important thing that I should have written
in the previous comment. 

I have now tested XFree86-4.2.99.3-20030115.0 and the problem still persists.

ps. I don't want to upset anyone. Is it correct to change status of a bug such
as this one to ASSIGNED, when the requested informatin is provided?
Comment 10 Mike A. Harris 2003-01-21 06:28:22 EST
Yep, that's fine.

Comment 11 Henrik Nordstrom 2003-01-22 19:36:54 EST
One interesting note:

Usig XFree86-4.2.99.3-20030115.0 I have found that it seems works in the gdb
login box, but not once logged in.
Comment 12 Mike A. Harris 2003-01-22 21:06:09 EST
Fixed in 4.2.99.4-20030121.1 in rawhide, please test.

Changing state to MODIFIED.  If problem persists, change state back to
ASSIGNED and update report with new info.  If problem is resolved, please
change state to RAWHIDE
Comment 13 Daniel Resare 2003-01-23 14:00:43 EST
Excellent work! This issue is confirmed to be resolved in
XFree86-4.2.99.4-20030121.0

Note You need to log in before you can comment on or make changes to this bug.