Bug 809502 - SUNRPC: We must not use list_for_each_entry_safe() in rpc_wake_up()
SUNRPC: We must not use list_for_each_entry_safe() in rpc_wake_up()
Status: CLOSED DUPLICATE of bug 809937
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: nfs-maint
Filesystem QE
:
Depends On: 809495 809928
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 10:34 EDT by Steve Dickson
Modified: 2013-03-03 19:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 809495
Environment:
Last Closed: 2012-04-04 13:21:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dickson 2012-04-03 10:34:08 EDT
+++ This bug was initially created as a clone of Bug #809495 +++

Description of problem:

    The problem is that for the case of priority queues, we
    have to assume that __rpc_remove_wait_queue_priority will move new
    elements from the tk_wait.links lists into the queue->tasks[] list.
    We therefore cannot use list_for_each_entry_safe() on queue->tasks[],
    since that will skip these new tasks that __rpc_remove_wait_queue_priority
    is adding.
    
    Without this fix, rpc_wake_up and rpc_wake_up_status will both fail
    to wake up all functions on priority wait queues, which can result
    in some nasty hangs.


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes 

Additional info:

Upstream commit:

commit 540a0f7584169651f485e8ab67461fcb06934e38
Author: Trond Myklebust <Trond.Myklebust@netapp.com>
Date:   Mon Mar 19 13:39:35 2012 -0400

    SUNRPC: We must not use list_for_each_entry_safe() in rpc_wake_up()
Comment 1 RHEL Product and Program Management 2012-04-03 10:39:36 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Steve Dickson 2012-04-04 13:21:46 EDT

*** This bug has been marked as a duplicate of bug 809937 ***

Note You need to log in before you can comment on or make changes to this bug.