Bug 809650 - [FEAT] - gluster cli has no way to specify username/password
[FEAT] - gluster cli has no way to specify username/password
Status: CLOSED DUPLICATE of bug 764034
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Amar Tumballi
Depends On:
  Show dependency treegraph
Reported: 2012-04-03 19:02 EDT by Kevin Fenzi
Modified: 2013-12-18 19:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-05-28 06:38:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2012-04-03 19:02:50 EDT
If you have volumes where you have specified a username / password, there's no way to use the cli with them as it has no way to send the username/password. Instead you get: 

Connection failed. Please check if gluster daemon is operational.

It would be nice to add a '-u/--username' and '-p/--password' (or prompt for password).
Comment 1 Amar Tumballi 2012-05-28 06:38:43 EDT

*** This bug has been marked as a duplicate of bug 764034 ***

Note You need to log in before you can comment on or make changes to this bug.