Bug 809720 - [abrt] yum-3.4.3-23.fc16: yumRepo.py:999:_cachingRepoXML:RepoError: Cannot find repomd.xml file for fedora
[abrt] yum-3.4.3-23.fc16: yumRepo.py:999:_cachingRepoXML:RepoError: Cannot fi...
Status: CLOSED DUPLICATE of bug 809469
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
abrt_hash:4be1e1eee7155988174c3c68f09...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 03:32 EDT by geneg
Modified: 2014-01-21 18:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 03:43:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description geneg 2012-04-04 03:32:27 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python -t /usr/share/yum-cli/completion-helper.py -d 0 -C list available thu
comment:        bash-compleation error when typed begining of packet and double pressed 'tab'
executable:     /usr/share/yum-cli/completion-helper.py
kernel:         3.3.0-8.fc16.i686
reason:         yumRepo.py:999:_cachingRepoXML:RepoError: Cannot find repomd.xml file for fedora
time:           Wed 04 Apr 2012 11:26:56 AM MSK
uid:            1000
username:       geneg

backtrace:
:yumRepo.py:999:_cachingRepoXML:RepoError: Cannot find repomd.xml file for fedora
:
:Traceback (most recent call last):
:  File "/usr/share/yum-cli/completion-helper.py", line 81, in <module>
:    main(sys.argv[1:])
:  File "/usr/share/yum-cli/completion-helper.py", line 77, in main
:    base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 485, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/share/yum-cli/completion-helper.py", line 44, in doCommand
:    patterns=[get_pattern(extcmds)])
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2660, in doPackageLists
:    avail = self.pkgSack.returnNewestByNameArch(patterns=patterns,
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1003, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 767, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 294, in populateSack
:    sack.populate(repo, mdtype, callback, cacheonly)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 167, in populate
:    if self._check_db_version(repo, mydbtype):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 225, in _check_db_version
:    return repo._check_db_version(mdtype)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1272, in _check_db_version
:    repoXML = self.repoXML
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1466, in <lambda>
:    repoXML = property(fget=lambda self: self._getRepoXML(),
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1462, in _getRepoXML
:    self._loadRepoXML(text=self)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1453, in _loadRepoXML
:    return self._groupLoadRepoXML(text, self._mdpolicy2mdtypes())
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1428, in _groupLoadRepoXML
:    if self._commonLoadRepoXML(text):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1233, in _commonLoadRepoXML
:    if self._cachingRepoXML(local):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 999, in _cachingRepoXML
:    raise Errors.RepoError, 'Cannot find repomd.xml file for %s' % self
:RepoError: Cannot find repomd.xml file for fedora
:
:Local variables in innermost frame:
:self: <yum.yumRepo.YumRepository object at 0x8cea48c>
:local: '/var/tmp/yum-geneg-fDUrE8/i386/16/fedora/repomd.xml'
Comment 1 Zdeněk Pavlas 2012-04-04 03:43:57 EDT

*** This bug has been marked as a duplicate of bug 809469 ***

Note You need to log in before you can comment on or make changes to this bug.