Bug 809469 - [abrt] yum-3.4.3-23.fc16: yumRepo.py:999:_cachingRepoXML:RepoError: Cannot find repomd.xml file for virtualbox
[abrt] yum-3.4.3-23.fc16: yumRepo.py:999:_cachingRepoXML:RepoError: Cannot fi...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
abrt_hash:701a7637d73049eae35231ae712...
:
: 809556 809720 809769 810538 810550 810624 812558 813737 814993 816411 817397 819355 819840 820441 820627 820635 828037 853330 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 08:57 EDT by Agustin Ferrario
Modified: 2014-01-21 18:21 EST (History)
27 users (show)

See Also:
Fixed In Version: yum-3.4.3-24.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-05 05:13:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Agustin Ferrario 2012-04-03 08:57:23 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python -t /usr/share/yum-cli/completion-helper.py -d 0 -C list available dkms
comment:        Just trying to install a package lookin for it with doble tab. VirtualBox.repo was downloaded and copied to /etc/yum.repos.d/
executable:     /usr/share/yum-cli/completion-helper.py
kernel:         3.3.0-8.fc16.x86_64
reason:         yumRepo.py:999:_cachingRepoXML:RepoError: Cannot find repomd.xml file for virtualbox
time:           Tue 03 Apr 2012 09:53:23 AM ART
uid:            1000
username:       crash

backtrace:
:yumRepo.py:999:_cachingRepoXML:RepoError: Cannot find repomd.xml file for virtualbox
:
:Traceback (most recent call last):
:  File "/usr/share/yum-cli/completion-helper.py", line 81, in <module>
:    main(sys.argv[1:])
:  File "/usr/share/yum-cli/completion-helper.py", line 77, in main
:    base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 485, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/share/yum-cli/completion-helper.py", line 44, in doCommand
:    patterns=[get_pattern(extcmds)])
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2660, in doPackageLists
:    avail = self.pkgSack.returnNewestByNameArch(patterns=patterns,
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1003, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 767, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 294, in populateSack
:    sack.populate(repo, mdtype, callback, cacheonly)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 167, in populate
:    if self._check_db_version(repo, mydbtype):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 225, in _check_db_version
:    return repo._check_db_version(mdtype)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1272, in _check_db_version
:    repoXML = self.repoXML
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1466, in <lambda>
:    repoXML = property(fget=lambda self: self._getRepoXML(),
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1462, in _getRepoXML
:    self._loadRepoXML(text=self)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1453, in _loadRepoXML
:    return self._groupLoadRepoXML(text, self._mdpolicy2mdtypes())
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1428, in _groupLoadRepoXML
:    if self._commonLoadRepoXML(text):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1233, in _commonLoadRepoXML
:    if self._cachingRepoXML(local):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 999, in _cachingRepoXML
:    raise Errors.RepoError, 'Cannot find repomd.xml file for %s' % self
:RepoError: Cannot find repomd.xml file for virtualbox
:
:Local variables in innermost frame:
:self: <yum.yumRepo.YumRepository object at 0x1d3ab90>
:local: '/var/tmp/yum-crash-HdOXmh/x86_64/16/virtualbox/repomd.xml'
Comment 1 Zdeněk Pavlas 2012-04-04 03:43:43 EDT
*** Bug 809556 has been marked as a duplicate of this bug. ***
Comment 2 Zdeněk Pavlas 2012-04-04 03:43:57 EDT
*** Bug 809720 has been marked as a duplicate of this bug. ***
Comment 3 Zdeněk Pavlas 2012-04-04 04:55:58 EDT
With --cacheonly base.doPackageLists() and base.doGroupLists() *can/should* traceback, if there are no metadata.  And we probably don't want to fetch it..
So, just do something simple to prevent the abrt report?
Comment 4 Zdeněk Pavlas 2012-04-04 07:10:31 EDT
*** Bug 809769 has been marked as a duplicate of this bug. ***
Comment 5 Zdeněk Pavlas 2012-04-10 02:49:27 EDT
*** Bug 810538 has been marked as a duplicate of this bug. ***
Comment 6 Zdeněk Pavlas 2012-04-10 02:49:37 EDT
*** Bug 810624 has been marked as a duplicate of this bug. ***
Comment 7 Zdeněk Pavlas 2012-04-10 02:50:20 EDT
*** Bug 810550 has been marked as a duplicate of this bug. ***
Comment 8 Zdeněk Pavlas 2012-04-16 05:23:04 EDT
*** Bug 812558 has been marked as a duplicate of this bug. ***
Comment 9 Zdeněk Pavlas 2012-04-18 07:02:59 EDT
*** Bug 813737 has been marked as a duplicate of this bug. ***
Comment 10 Zdeněk Pavlas 2012-04-23 03:00:09 EDT
*** Bug 814993 has been marked as a duplicate of this bug. ***
Comment 11 Euloiix 2012-04-25 08:00:11 EDT
Any update on this bug ?
Comment 12 Euloiix 2012-04-25 08:01:33 EDT
Any update on this bug ?
Comment 13 Zdeněk Pavlas 2012-04-26 10:30:33 EDT
*** Bug 816411 has been marked as a duplicate of this bug. ***
Comment 14 Zdeněk Pavlas 2012-05-02 06:38:30 EDT
*** Bug 817397 has been marked as a duplicate of this bug. ***
Comment 15 tuxor 2012-05-06 13:10:51 EDT
I understand, why this bug has been closed. But the error message is really getting on my nerves. Two questions:

1. Where can we report this if not here?
2. Is there at least a workaround to suppress the error message?
Comment 16 Zdeněk Pavlas 2012-05-09 04:06:47 EDT
*** Bug 819355 has been marked as a duplicate of this bug. ***
Comment 17 Zdeněk Pavlas 2012-05-09 05:15:24 EDT
*** Bug 819840 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2012-05-09 05:25:13 EDT
yum-3.4.3-24.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/yum-3.4.3-24.fc16
Comment 19 Zdeněk Pavlas 2012-05-10 02:55:15 EDT
*** Bug 820441 has been marked as a duplicate of this bug. ***
Comment 20 Zdeněk Pavlas 2012-05-10 10:32:54 EDT
*** Bug 820627 has been marked as a duplicate of this bug. ***
Comment 21 Zdeněk Pavlas 2012-05-10 10:51:33 EDT
*** Bug 820635 has been marked as a duplicate of this bug. ***
Comment 22 Fedora Update System 2012-05-18 06:33:31 EDT
yum-3.4.3-24.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 tuxor 2012-05-30 17:58:03 EDT
The exact same error is present in Fedora 17, as well. Here, the most recent version of yum still is 3.4.3-23.fc17.

Is there any chance we will be getting the yum update for fc17 any time soon?
Comment 24 tuxor 2012-05-31 07:19:17 EDT
With yum-3.4.3-24.fc17 from http://koji.fedoraproject.org/koji/packageinfo?packageID=21 I'm still having this problem.

Is it appropriate to open a new bug about this?
Comment 25 Zdeněk Pavlas 2012-05-31 07:49:17 EDT
Fixed this in F17, too.
http://koji.fedoraproject.org/koji/buildinfo?buildID=321257
Comment 26 Mohammad Razeghi 2012-05-31 20:05:00 EDT
i still have this error on F17 with latest version of yum and rpm :

[mohammad@Mohammad Learn]$ yum --version
3.4.3
  Installed: rpm-4.9.1.3-7.fc17.x86_64 at 2012-05-30 21:00
  Built    : Fedora Project at 2012-05-07 10:05
  Committed: Panu Matilainen <pmatilai@redhat.com> at 2012-05-07

  Installed: yum-3.4.3-23.fc17.noarch at 2012-05-22 20:40
  Built    : Fedora Project at 2012-03-16 19:12
  Committed: James Antill <james at fedoraproject.org> at 2012-03-16
Comment 27 tuxor 2012-06-01 03:56:20 EDT
Please try yum-3.4.3-25 from koji (refered to above by Zdeněk Pavlas) or wait for that update to be pushed to the repo :)
Comment 28 Fedora Update System 2012-06-01 09:30:22 EDT
yum-3.4.3-25.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/yum-3.4.3-25.fc17
Comment 29 Zdeněk Pavlas 2012-06-04 03:47:38 EDT
*** Bug 828037 has been marked as a duplicate of this bug. ***
Comment 30 Mohammad Razeghi 2012-06-07 06:11:05 EDT
i have  updated yum :


3.4.3
  Installed: rpm-4.9.1.3-7.fc17.x86_64 at 2012-05-30 21:00
  Built    : Fedora Project at 2012-05-07 10:05
  Committed: Panu Matilainen <pmatilai@redhat.com> at 2012-05-07

  Installed: yum-3.4.3-25.fc17.noarch at 2012-06-01 09:56
  Built    : Fedora Project at 2012-05-31 11:45
  Committed: Zdenek Pavlas <zpavlas at redhat.com> at 2012-05-31


but problem still exists !
Comment 31 Fedora Update System 2012-06-07 18:55:03 EDT
yum-3.4.3-25.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 32 Mohammad Razeghi 2012-06-07 20:17:45 EDT
yes . problem still persist !
Comment 33 Zdeněk Pavlas 2012-06-08 06:06:01 EDT
What, you get the same traceback (RepoError exception) with yum-3.4.3-25.fc17?
I belive it's fixed, we handle it in populateSack().  If it's something different, please fill a new bug.
Comment 34 Zdeněk Pavlas 2012-09-05 09:50:29 EDT
*** Bug 853330 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.