Bug 80975 - empty file is created when trying to 'rpmbuild -tb' tarballs w/o .spec
Summary: empty file is created when trying to 'rpmbuild -tb' tarballs w/o .spec
Status: CLOSED DUPLICATE of bug 8527
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-02 21:55 UTC by Daniel Resare
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Resare 2003-01-02 21:55:39 UTC
Description of problem:
When I run 'rpmbuild -tb somepackage.tar.gz' and somepackage.tar.gz does not
contain a somepackage.spec, rpmbuild kindly creates an empty file in my
/usr/src/redhat/SPECS with the name 'tar: *.spec: Not found in archive'

Version-Release number of selected component (if applicable):
rpm-4.2-0.25.1 (but this bug has been around for a long time

How reproducible:
always

Steps to Reproduce:
2. touch foo.tar.gz
3. rpmbuild -tb foo.tar.gz
4. ls /usr/src/redhat/SPECS/tar*
    
Actual results:
[noa@c-2c1a72d5 slask]$ ls /usr/src/redhat/SPECS/tar*
/usr/src/redhat/SPECS/tar: *.spec: Not found in archive

Expected results:
no file :)

Additional info:

Comment 1 Jeff Johnson 2003-01-02 22:23:40 UTC

*** This bug has been marked as a duplicate of 8527 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:52 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.