Bug 809804 - RFE: Persistent Revision History
RFE: Persistent Revision History
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Lee Newson
Joshua Wulf
:
: 819720 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 08:33 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.32.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 01:11:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-04-04 08:33:52 EDT
At the moment we don't have a revision history for the Content Spec that can be written into the package when it's created. 

Should the Revision History information be stored in the Content Spec, or (more likely) as a Topic?

Then a parameter can be added to the CS Metadata Section:

RevHistory=<TopicID>

And that Topic can be written into the publican assembly as Revision_History.xml
Comment 1 Lee Newson 2012-04-04 18:39:13 EDT
Ideally the revision history should be automatically populated. So basically you would need this first: Bug #731902. After that you could use the log messages as the revision history, though you'd need some mechanism to different random log messages to states that would be part of the revision history.
Comment 2 Matthew Casperson 2013-03-06 16:27:38 EST
*** Bug 819720 has been marked as a duplicate of this bug. ***
Comment 3 Lee Newson 2013-05-16 17:54:36 EDT
Added in 0.32.0, syntax is as follows:

Revision History = [<ID>]

or

Revision History = [<ID>, rev: <REV>]

and it goes in the metadata section of a content specification. The topic itself must also be a "Revision History" topic as defined by the "Topic Type" tag.
Comment 4 Lee Newson 2013-05-22 00:04:44 EDT
I've also added validation rules to the builder to check that the <revnumber> fields are valid for publican and also that the revisions are in descending chronological order.
Comment 5 Lee Newson 2013-10-09 01:11:16 EDT
Moving this bug to CLOSED CURRENT_RELEASE to clean up old bugs that were QA'd by the PressGang team but not by the original reporter.

Note You need to log in before you can comment on or make changes to this bug.